aboutsummaryrefslogtreecommitdiff
path: root/www/gnome-user-share
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-26 22:16:16 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-26 22:16:16 +0000
commitc3892fcb485843486f7fb699fb904d2da917505a (patch)
tree5356c2331e64eba9574f1c21ef73cb9f5ef02b4d /www/gnome-user-share
parentd33bc206ed87daa8705e3177dc94ce9adce03c78 (diff)
Add gnome-user-share, an application that lets GNOME users share a personal,
public file space via WebDAV. The resulting share will automatically be visible in Nautilus.
Notes
Notes: svn path=/head/; revision=122533
Diffstat (limited to 'www/gnome-user-share')
-rw-r--r--www/gnome-user-share/Makefile37
-rw-r--r--www/gnome-user-share/distinfo2
-rw-r--r--www/gnome-user-share/files/patch-dav_user.conf9
-rw-r--r--www/gnome-user-share/files/patch-file-share-properties.c10
-rw-r--r--www/gnome-user-share/files/patch-user_share.c26
-rw-r--r--www/gnome-user-share/pkg-descr11
-rw-r--r--www/gnome-user-share/pkg-plist5
7 files changed, 100 insertions, 0 deletions
diff --git a/www/gnome-user-share/Makefile b/www/gnome-user-share/Makefile
new file mode 100644
index 000000000000..bb78bf6fedf3
--- /dev/null
+++ b/www/gnome-user-share/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: gnome-user-share
+# Date created: 26 November 2004
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnome-user-share
+PORTVERSION= 0.3
+CATEGORIES= www deskutils gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.3
+DIST_SUBDIR= gnome2
+
+MAINTAINER= marcus@FreeBSD.org
+COMMENT= Personal file-sharing service for the GNOME Desktop
+
+LIB_DEPENDS= howl:${PORTSDIR}/net/howl
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_APACHE= yes
+APACHE_PORT= www/apache2
+USE_GNOME= gnomeprefix gnomehack intlhack libglade2 gconf2
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= desktop_gnome_file_sharing.schemas
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc/httpd/modules|${LOCALBASE}/libexec/apache2|g' \
+ ${WRKSRC}/dav_user.conf
+
+.include <bsd.port.mk>
diff --git a/www/gnome-user-share/distinfo b/www/gnome-user-share/distinfo
new file mode 100644
index 000000000000..4b79fc6b28dc
--- /dev/null
+++ b/www/gnome-user-share/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome2/gnome-user-share-0.3.tar.bz2) = 2f760af8691d5a7202aa2d52f286d965
+SIZE (gnome2/gnome-user-share-0.3.tar.bz2) = 219045
diff --git a/www/gnome-user-share/files/patch-dav_user.conf b/www/gnome-user-share/files/patch-dav_user.conf
new file mode 100644
index 000000000000..f3d258adf7d2
--- /dev/null
+++ b/www/gnome-user-share/files/patch-dav_user.conf
@@ -0,0 +1,9 @@
+--- dav_user.conf.orig Fri Nov 26 15:50:13 2004
++++ dav_user.conf Fri Nov 26 15:50:22 2004
+@@ -1,5 +1,6 @@
+ ServerRoot ${HOME}/.gnome2/user-share
+ PidFile pid
++LockFile lock
+ LogLevel crit
+ #LogLevel info
+ ErrorLog log
diff --git a/www/gnome-user-share/files/patch-file-share-properties.c b/www/gnome-user-share/files/patch-file-share-properties.c
new file mode 100644
index 000000000000..099dc2f4f450
--- /dev/null
+++ b/www/gnome-user-share/files/patch-file-share-properties.c
@@ -0,0 +1,10 @@
+--- file-share-properties.c.orig Fri Nov 26 14:53:54 2004
++++ file-share-properties.c Fri Nov 26 14:54:07 2004
+@@ -1,6 +1,7 @@
+ #include "config.h"
+
+ #include <string.h>
++#include <stdio.h>
+
+ #include <gtk/gtk.h>
+ #include <glib/gi18n.h>
diff --git a/www/gnome-user-share/files/patch-user_share.c b/www/gnome-user-share/files/patch-user_share.c
new file mode 100644
index 000000000000..20be2b00b78f
--- /dev/null
+++ b/www/gnome-user-share/files/patch-user_share.c
@@ -0,0 +1,26 @@
+--- user_share.c.orig Fri Nov 26 04:33:51 2004
++++ user_share.c Fri Nov 26 17:12:13 2004
+@@ -59,6 +59,14 @@
+ return -1;
+ }
+
++#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__APPLE__)
++ /* XXX This exposes a potential race condition, but without this,
++ * httpd will not start on the above listed platforms due to the fact
++ * that SO_REUSEADDR is also needed when Apache binds to the listening
++ * socket. At this time, Apache does not support that socket option.
++ */
++ close (sock);
++#endif
+ return ntohs (addr.sin_port);
+ }
+
+@@ -171,7 +179,7 @@
+ char *free1, *free2;
+ gboolean res;
+ char *argv[10];
+- char *env[10];;
++ char *env[10];
+ int i;
+ gint status;
+ char *pid_filename;
diff --git a/www/gnome-user-share/pkg-descr b/www/gnome-user-share/pkg-descr
new file mode 100644
index 000000000000..e5aa8a4777ab
--- /dev/null
+++ b/www/gnome-user-share/pkg-descr
@@ -0,0 +1,11 @@
+gnome-user-share is a small package that binds together various free
+software projects to bring easy to use user-level file sharing to the
+masses.
+
+The program is meant to run in the background when the user is logged
+in, and when file sharing is enabled a webdav server is started that
+shares the $HOME/Public folder. The share is then published to all
+computers on the local network using mDNS/rendezvous, so that it shows
+up in the Network location in Gnome.
+
+-- gnome-user-share README
diff --git a/www/gnome-user-share/pkg-plist b/www/gnome-user-share/pkg-plist
new file mode 100644
index 000000000000..f4725c59e3ce
--- /dev/null
+++ b/www/gnome-user-share/pkg-plist
@@ -0,0 +1,5 @@
+bin/gnome-file-share-properties
+libexec/gnome-user-share
+share/gnome/gnome-user-share/dav_user.conf
+share/gnome/gnome-user-share/file-share-properties.glade
+@dirrm share/gnome/gnome-user-share