aboutsummaryrefslogtreecommitdiff
path: root/www/googler/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2016-10-18 17:00:27 +0000
committerNicola Vitale <nivit@FreeBSD.org>2016-10-18 17:00:27 +0000
commit1e42a9b759c4c3eef8447b425cface8950083328 (patch)
tree942aec3d15d9423a28cf9b641fe9b8d69a4d0e7e /www/googler/Makefile
parentf9d0a9666d96a8c58c726aaf03a4422834db64cd (diff)
downloadports-1e42a9b759c4c3eef8447b425cface8950083328.tar.gz
ports-1e42a9b759c4c3eef8447b425cface8950083328.zip
Notes
Diffstat (limited to 'www/googler/Makefile')
-rw-r--r--www/googler/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/googler/Makefile b/www/googler/Makefile
new file mode 100644
index 000000000000..d34ef16ae35a
--- /dev/null
+++ b/www/googler/Makefile
@@ -0,0 +1,31 @@
+# Created by: Nicola Stanislao Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= googler
+PORTVERSION= 2.8
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Google Search, Google Site Search, Google News from the terminal
+
+LICENSE= GPLv3
+
+GH_ACCOUNT= jarun
+
+NO_BUILD= yes
+
+PLIST_FILES= bin/googler man/man1/googler.1.gz
+
+USE_GITHUB= yes
+USES= python:3.3+
+
+post-patch:
+ @${SED} -i.bak 's/^\(ENABLE_SELF_UPGRADE_MECHANISM=\)True$$/\1False/' \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}/${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}/${MANPREFIX}/man/man1/
+
+.include <bsd.port.mk>