aboutsummaryrefslogtreecommitdiff
path: root/www/grafana3/Makefile
diff options
context:
space:
mode:
authorBrad Davis <brd@FreeBSD.org>2017-01-30 14:41:18 +0000
committerBrad Davis <brd@FreeBSD.org>2017-01-30 14:41:18 +0000
commitb2653a25fd540a8d3910b121722f43155d8f080b (patch)
treeee504d8b34bff2f39948bf389bee6038b199f7e7 /www/grafana3/Makefile
parent409bcb271829e8ce43da41bd3142a392ff8f5f3a (diff)
downloadports-b2653a25fd540a8d3910b121722f43155d8f080b.tar.gz
ports-b2653a25fd540a8d3910b121722f43155d8f080b.zip
Notes
Diffstat (limited to 'www/grafana3/Makefile')
-rw-r--r--www/grafana3/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/www/grafana3/Makefile b/www/grafana3/Makefile
index d5055dbbed3a..8430ebe62c50 100644
--- a/www/grafana3/Makefile
+++ b/www/grafana3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= grafana
PORTVERSION= 3.1.1
DISTVERSIONPREFIX= v
-PORTREVISION= 2
+PORTREVISION= 3
PKGNAMESUFFIX= 3
CATEGORIES= www
@@ -14,6 +14,9 @@ LICENSE= APACHE20
BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go
+RUN_DEPENDS= ${LOCALBASE}/bin/phantomjs:lang/phantomjs \
+ webfonts>=0:x11-fonts/webfonts
+
ONLY_FOR_ARCHS= i386 amd64
USE_RC_SUBR= grafana3
@@ -140,6 +143,10 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/src/github.com/grafana/grafana/conf/defaults.ini \
${STAGEDIR}${GRAFANAHOMEDIR}/conf/defaults.ini
${INSTALL_DATA} ${WRKDIR}/grafana3.conf ${STAGEDIR}${PREFIX}/etc/grafana3.conf.sample
+ ${MKDIR} ${STAGEDIR}${GRAFANAHOMEDIR}/vendor/phantomjs/
+ ${INSTALL_DATA} ${WRKSRC}/src/github.com/grafana/grafana/vendor/phantomjs/render.js \
+ ${STAGEDIR}${GRAFANAHOMEDIR}/vendor/phantomjs/
+ ${LN} -s /usr/local/bin/phantomjs ${STAGEDIR}${GRAFANAHOMEDIR}/vendor/phantomjs/phantomjs
.include <bsd.port.pre.mk>