aboutsummaryrefslogtreecommitdiff
path: root/www/groupoffice
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2007-02-20 21:35:56 +0000
committerJuergen Lock <nox@FreeBSD.org>2007-02-20 21:35:56 +0000
commita0117e97896e24e99c219641c44546a7838b8613 (patch)
tree8d755e92364735ba91054b49ca3963c0798e15e6 /www/groupoffice
parent4dbeec9af9c1036e33abe7bceb91e1eadf6dba0b (diff)
downloadports-a0117e97896e24e99c219641c44546a7838b8613.tar.gz
ports-a0117e97896e24e99c219641c44546a7838b8613.zip
Notes
Diffstat (limited to 'www/groupoffice')
-rw-r--r--www/groupoffice/Makefile67
-rw-r--r--www/groupoffice/distinfo3
-rw-r--r--www/groupoffice/files/pkg-message.in21
-rw-r--r--www/groupoffice/pkg-descr5
4 files changed, 96 insertions, 0 deletions
diff --git a/www/groupoffice/Makefile b/www/groupoffice/Makefile
new file mode 100644
index 000000000000..629a42e1d9e9
--- /dev/null
+++ b/www/groupoffice/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: www/groupoffice
+# Date created: 16 February 2007
+# Whom: Aron Schlesinger <as@bsdgroup.de>
+#
+# $FreeBSD$
+
+PORTNAME= groupoffice
+PORTVERSION= 2.16.11
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= group-office
+DISTNAME= ${PORTNAME}-com-2.16-11
+
+MAINTAINER= as@bsdgroup.de
+COMMENT= A modular web application framework vor office
+
+RESTRICTED= Free for personal use only
+
+NO_BUILD= yes
+
+.if !defined(WITHOUT_PHP_DEPENDS)
+USE_PHP= mysql session mbstring pcre xml
+.endif
+
+WANT_PHP_WEB= yes
+USE_MYSQL= yes
+IGNORE_WITH_MYSQL= 323
+
+OPTIONS= IMAP "IMAP support" on
+
+PORT_DBDIR?= ${DESTDIR}/var/db/ports
+LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
+OPTIONSFILE?= ${PORT_DBDIR}/${LATEST_LINK}/options
+
+.if exists(${OPTIONSFILE})
+.include "${OPTIONSFILE}"
+.endif
+
+.if !defined(WITHOUT_PHP_DEPENDS)
+. if !defined(WITHOUT_IMAP) || defined(WITH_IMAP)
+USE_PHP+= imap
+. endif
+.endif
+
+GROUPOFFICEDIR?= www/${PORTNAME}2
+
+SUB_FILES= pkg-message
+SUB_LIST= "GROUPOFFICEDIR=${GROUPOFFICEDIR}" \
+ "PKGNAME=${PKGNAME}" \
+ "WWWOWN=${WWWOWN}"
+
+pre-everything::
+ @${ECHO_CMD} "# you can customize the installation directory"
+ @${ECHO_CMD} "# by setting GROUPOFFICEDIR in /etc/make.conf"
+
+do-install:
+ @${MKDIR} ${PREFIX}/${GROUPOFFICEDIR}
+ ${CP} -r ${WRKSRC}/ ${PREFIX}/${GROUPOFFICEDIR}
+
+post-install:
+ @${FIND} ${WRKSRC}/${file} -not -type d \
+ | ${SED} -ne 's,^${WRKSRC},${GROUPOFFICEDIR},p' >> ${TMPPLIST}
+ @${FIND} -d ${WRKSRC}/${file} -type d \
+ | ${SED} -ne 's,^${WRKSRC},@dirrm ${GROUPOFFICEDIR},p' >> ${TMPPLIST}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/groupoffice/distinfo b/www/groupoffice/distinfo
new file mode 100644
index 000000000000..94f1886c6e07
--- /dev/null
+++ b/www/groupoffice/distinfo
@@ -0,0 +1,3 @@
+MD5 (groupoffice-com-2.16-11.tar.gz) = c7fd480ef5a65e16bb0ac61777584c5f
+SHA256 (groupoffice-com-2.16-11.tar.gz) = a95b9c66b75e143e72188bd4f6b56f203d7556e78be47e660b7acd4bd90d122f
+SIZE (groupoffice-com-2.16-11.tar.gz) = 9088076
diff --git a/www/groupoffice/files/pkg-message.in b/www/groupoffice/files/pkg-message.in
new file mode 100644
index 000000000000..c73536404ebf
--- /dev/null
+++ b/www/groupoffice/files/pkg-message.in
@@ -0,0 +1,21 @@
+%%PKGNAME%% has been installed into:
+
+ %%PREFIX%%/%%GROUPOFFICEDIR%%
+
+You will probably want to add an alias to your httpd.conf file,
+somethinglike this:
+
+ Alias /groupoffice "%%PREFIX%%/%%GROUPOFFICEDIR%%"
+
+And restart Apache.
+Before the first use of GroupOffice, create config.php
+
+ touch %%PREFIX%%/%%GROUPOFFICEDIR%%/config.php
+
+and change the owner to %%WWWOWN%%:
+
+ chown %%WWWOWN%% %%PREFIX%%/%%GROUPOFFICEDIR%%/config.php
+
+Please visit 'http://localhost/groupoffice/install/install.php'
+in a web-browser and follow the configuration instructions.
+
diff --git a/www/groupoffice/pkg-descr b/www/groupoffice/pkg-descr
new file mode 100644
index 000000000000..001123197dc9
--- /dev/null
+++ b/www/groupoffice/pkg-descr
@@ -0,0 +1,5 @@
+Group-Office is a powerfull modular Internet/Intranet application framework.
+It features calendaring, project management, e-mail, tasks, addressbook,
+file management.
+
+WWW: http://www.group-office.com/