aboutsummaryrefslogtreecommitdiff
path: root/www/gtkhtml38
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /www/gtkhtml38
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Notes
Diffstat (limited to 'www/gtkhtml38')
-rw-r--r--www/gtkhtml38/Makefile10
-rw-r--r--www/gtkhtml38/distinfo4
-rw-r--r--www/gtkhtml38/files/patch-po_Makefile.in.in10
-rw-r--r--www/gtkhtml38/files/patch-src_htmltext.c15
-rw-r--r--www/gtkhtml38/pkg-plist3
5 files changed, 31 insertions, 11 deletions
diff --git a/www/gtkhtml38/Makefile b/www/gtkhtml38/Makefile
index c121c5312d17..e44a89101dae 100644
--- a/www/gtkhtml38/Makefile
+++ b/www/gtkhtml38/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gtkhtml3
-PORTVERSION= 3.2.5
+PORTVERSION= 3.6.0
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/3$//}/3.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/3$//}/3.6
DISTNAME= ${PORTNAME:S/3$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -27,10 +27,6 @@ USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-PLIST_SUB= VERSION="3.1"
-
-post-patch:
- @${REINPLACE_CMD} -e 's|@mkdir_p@|${MKDIR}|g' \
- ${WRKSRC}/po/Makefile.in.in
+PLIST_SUB= VERSION="3.6"
.include <bsd.port.mk>
diff --git a/www/gtkhtml38/distinfo b/www/gtkhtml38/distinfo
index 1ecf07b8d8cc..3809c42806f5 100644
--- a/www/gtkhtml38/distinfo
+++ b/www/gtkhtml38/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gtkhtml-3.2.5.tar.bz2) = 86e1ce32fed536bce5b2d6e8d41b0c65
-SIZE (gnome2/gtkhtml-3.2.5.tar.bz2) = 1315567
+MD5 (gnome2/gtkhtml-3.6.0.tar.bz2) = a53378f57544ef2e2e7b40616dc237a1
+SIZE (gnome2/gtkhtml-3.6.0.tar.bz2) = 1348975
diff --git a/www/gtkhtml38/files/patch-po_Makefile.in.in b/www/gtkhtml38/files/patch-po_Makefile.in.in
new file mode 100644
index 000000000000..df4fac948548
--- /dev/null
+++ b/www/gtkhtml38/files/patch-po_Makefile.in.in
@@ -0,0 +1,10 @@
+--- po/Makefile.in.in.orig Tue Nov 23 17:53:53 2004
++++ po/Makefile.in.in Tue Nov 23 17:58:38 2004
+@@ -31,6 +31,7 @@
+ localedir = $(libdir)/locale
+ gnulocaledir = $(datadir)/locale
+ gettextsrcdir = $(datadir)/glib-2.0/gettext/po
++mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ subdir = po
+
+ INSTALL = @INSTALL@
diff --git a/www/gtkhtml38/files/patch-src_htmltext.c b/www/gtkhtml38/files/patch-src_htmltext.c
new file mode 100644
index 000000000000..f970e5b654c2
--- /dev/null
+++ b/www/gtkhtml38/files/patch-src_htmltext.c
@@ -0,0 +1,15 @@
+--- src/htmltext.c.orig Wed Dec 8 01:45:57 2004
++++ src/htmltext.c Wed Dec 8 01:46:10 2004
+@@ -2433,10 +2433,11 @@
+ gsize
+ html_text_sanitize (const gchar **str, gint *len)
+ {
++ gchar *end;
+ g_return_val_if_fail (str != NULL, 0);
+ g_return_val_if_fail (len != NULL, 0);
+
+- gchar *end = offset_to_pointer_validated (*str, *len, len);
++ end = offset_to_pointer_validated (*str, *len, len);
+ if (end) {
+ return end - *str;
+ } else {
diff --git a/www/gtkhtml38/pkg-plist b/www/gtkhtml38/pkg-plist
index 796491d14ceb..5c4468b4861a 100644
--- a/www/gtkhtml38/pkg-plist
+++ b/www/gtkhtml38/pkg-plist
@@ -85,7 +85,7 @@ include/libgtkhtml-%%VERSION%%/gtkhtml/htmlundo.h
lib/gtkhtml/libgnome-gtkhtml-editor-%%VERSION%%.so
lib/libgtkhtml-%%VERSION%%.a
lib/libgtkhtml-%%VERSION%%.so
-lib/libgtkhtml-%%VERSION%%.so.12
+lib/libgtkhtml-%%VERSION%%.so.18
libdata/bonobo/servers/GNOME_GtkHTML_Editor-%%VERSION%%.server
libdata/pkgconfig/libgtkhtml-%%VERSION%%.pc
share/gnome/gtkhtml-%%VERSION%%/Editor.idl
@@ -179,7 +179,6 @@ share/locale/he/LC_MESSAGES/gtkhtml-%%VERSION%%.mo
share/locale/hi/LC_MESSAGES/gtkhtml-%%VERSION%%.mo
share/locale/hr/LC_MESSAGES/gtkhtml-%%VERSION%%.mo
share/locale/hu/LC_MESSAGES/gtkhtml-%%VERSION%%.mo
-share/locale/id/LC_MESSAGES/gtkhtml-%%VERSION%%.mo
share/locale/it/LC_MESSAGES/gtkhtml-%%VERSION%%.mo
share/locale/ja/LC_MESSAGES/gtkhtml-%%VERSION%%.mo
share/locale/ko/LC_MESSAGES/gtkhtml-%%VERSION%%.mo