aboutsummaryrefslogtreecommitdiff
path: root/www/h2o
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2015-09-16 12:29:56 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2015-09-16 12:29:56 +0000
commit07ef4947042c009f70137c1037f0e42d1a051d54 (patch)
treef0171110800b3fa8cdbfd8c4f0cf864a69fa7a7b /www/h2o
parent1589139ea5a3025ef0b8a7f2884f78a6ecbe8bd9 (diff)
downloadports-07ef4947042c009f70137c1037f0e42d1a051d54.tar.gz
ports-07ef4947042c009f70137c1037f0e42d1a051d54.zip
- Fix rc.d issues introduced with recent perl changes [1]
- Update to 1.4.5 [2] PR: 203147 [1], 203096 [2] Submitted by: Dave Cottlehuber (maintainer)
Notes
Notes: svn path=/head/; revision=397062
Diffstat (limited to 'www/h2o')
-rw-r--r--www/h2o/Makefile13
-rw-r--r--www/h2o/distinfo4
-rw-r--r--www/h2o/files/h2o.in2
3 files changed, 13 insertions, 6 deletions
diff --git a/www/h2o/Makefile b/www/h2o/Makefile
index 1df1ca1d9f9f..f61fe927aee6 100644
--- a/www/h2o/Makefile
+++ b/www/h2o/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= h2o
-PORTVERSION= 1.4.4
+PORTVERSION= 1.4.5
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= www
MAINTAINER= dch@skunkwerks.at
@@ -14,7 +13,8 @@ LICENSE= MIT
USE_GITHUB= yes
-USES= cmake compiler:c11 shebangfix
+USES= cmake compiler:c11 perl5 shebangfix
+USE_PERL5= run
SHEBANG_FILES= share/h2o/start_server
PORTDOCS= README.md
@@ -40,6 +40,13 @@ USE_RC_SUBR= ${PORTNAME}
CMAKE_ARGS+= -DWITH_BUNDLED_SSL=OFF -DEXTRA_LIBRARIES=OFF
USE_OPENSSL_PORT= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|exec perl|exec ${LOCALBASE}/bin/perl|' \
+ ${WRKSRC}/share/h2o/annotate-backtrace-symbols \
+ ${WRKSRC}/share/h2o/fetch-ocsp-response \
+ ${WRKSRC}/share/h2o/kill-on-close \
+ ${WRKSRC}/share/h2o/start_server
+
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR} \
${STAGEDIR}${ETCDIR} \
diff --git a/www/h2o/distinfo b/www/h2o/distinfo
index e3bae57063bd..073a66e5e775 100644
--- a/www/h2o/distinfo
+++ b/www/h2o/distinfo
@@ -1,2 +1,2 @@
-SHA256 (h2o-h2o-v1.4.4_GH0.tar.gz) = 0297ca73dba460653c6edb14dab17095f60616baf7c51e45ac9f8a6d54b9ba55
-SIZE (h2o-h2o-v1.4.4_GH0.tar.gz) = 4736114
+SHA256 (h2o-h2o-v1.4.5_GH0.tar.gz) = 0f60e8d35afad61afc284a7abfa9c9a3b976e8f9faed3f0966fb34056e2e138d
+SIZE (h2o-h2o-v1.4.5_GH0.tar.gz) = 4736984
diff --git a/www/h2o/files/h2o.in b/www/h2o/files/h2o.in
index 3b13fb0354e2..a6d335b3e550 100644
--- a/www/h2o/files/h2o.in
+++ b/www/h2o/files/h2o.in
@@ -28,7 +28,7 @@ rcvar=h2o_enable
pidfile=`grep pid-file ${h2o_config} | cut -d' ' -f2`
command="%%PREFIX%%/bin/${name}"
command_args="-m daemon -c ${h2o_config}"
-procname="perl"
+procname="%%LOCALBASE%%/bin/perl"
load_rc_config $name
run_rc_command "$1"