aboutsummaryrefslogtreecommitdiff
path: root/www/h2o
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2016-12-17 22:42:05 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2016-12-17 22:42:05 +0000
commit58bb9854743cd3e204ca4512f8a6397a03657f22 (patch)
treec03bc3b05dfaf7555a9bb535dea09141e599560f /www/h2o
parentc64bb13b460dd476358cf9c7a290bc3a815f0ada (diff)
downloadports-58bb9854743cd3e204ca4512f8a6397a03657f22.tar.gz
ports-58bb9854743cd3e204ca4512f8a6397a03657f22.zip
- add option knob mruby handler as default
- simplify ssl option - bump portversion PR: 213733 Submitted by: dch@skunkwerks.at (maintainer)
Notes
Notes: svn path=/head/; revision=428810
Diffstat (limited to 'www/h2o')
-rw-r--r--www/h2o/Makefile23
-rw-r--r--www/h2o/pkg-plist3
2 files changed, 19 insertions, 7 deletions
diff --git a/www/h2o/Makefile b/www/h2o/Makefile
index fd1b0ca21ea4..7786227b2586 100644
--- a/www/h2o/Makefile
+++ b/www/h2o/Makefile
@@ -5,6 +5,7 @@ PORTNAME= h2o
PORTVERSION= 2.0.4
PORTREVISION= 1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= dch@skunkwerks.at
@@ -36,20 +37,30 @@ H2O_LOGDIR= /var/log/${PORTNAME}/
USE_RC_SUBR= ${PORTNAME}
-OPTIONS_DEFINE= LIBRESSL
+OPTIONS_DEFINE= LIBRESSL MRUBY
+OPTIONS_DEFAULT= LIBRESSL MRUBY
+OPTIONS_SUB= yes
LIBRESSL_DESC= Build with bundled LibreSSL instead of OpenSSL
-OPTIONS_DEFAULT= LIBRESSL
+MRUBY_DESC= Build with mruby handler support
CMAKE_ARGS+= -DEXTRA_LIBRARIES=OFF -DWITHOUT_LIBS=ON
.include <bsd.port.options.mk>
+LIBRESSL_CMAKE_ON= -DWITH_BUNDLED_SSL=ON
+LIBRESSL_CMAKE_OFF= -DWITH_BUNDLED_SSL=OFF
+MRUBY_CMAKE_ON= -DWITH_MRUBY=ON
+MRUBY_CMAKE_OFF= -DWITH_MRUBY=OFF
+
.if ${PORT_OPTIONS:MLIBRESSL}
-CMAKE_ARGS+= -DWITH_BUNDLED_SSL=ON
-WITH_OPENSSL_PORT= no
+USES_SSL= yes
.else
-CMAKE_ARGS+= -DWITH_BUNDLED_SSL=OFF
-WITH_OPENSSL_PORT= yes
+USES_SSL= no
+.endif
+
+.if ${PORT_OPTIONS:MMRUBY}
+USE_RUBY= yes
+BUILD_DEPENDS+= bison:devel/bison
.endif
post-patch:
diff --git a/www/h2o/pkg-plist b/www/h2o/pkg-plist
index 43d002b3dd88..21bebbc62766 100644
--- a/www/h2o/pkg-plist
+++ b/www/h2o/pkg-plist
@@ -7,7 +7,7 @@ share/h2o/start_server
%%DATADIR%%/fastcgi-cgi
%%DATADIR%%/setuidgid
%%DATADIR%%/status/index.html
-@dir(%%H2O_USER%%,%%H2O_GROUP%%,0750) %%H2O_LOGDIR%%
+%%MRUBY%%%%DATADIR%%/mruby/htpasswd.rb
%%PORTDOCS%%%%DOCSDIR%%/assets/8mbps100msec-nginx195-h2o150.png
%%PORTDOCS%%%%DOCSDIR%%/assets/firstpaintbench.png
%%PORTDOCS%%%%DOCSDIR%%/assets/remotebench.png
@@ -57,4 +57,5 @@ share/h2o/start_server
%%PORTDOCS%%%%DOCSDIR%%/search/oktavia-english-search.js
%%PORTDOCS%%%%DOCSDIR%%/search/oktavia-jquery-ui.js
%%PORTDOCS%%%%DOCSDIR%%/search/searchindex.js
+@dir(%%H2O_USER%%,%%H2O_GROUP%%,0750) %%H2O_LOGDIR%%
@sample %%ETCDIR%%/h2o.conf.sample