aboutsummaryrefslogtreecommitdiff
path: root/www/h2o
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-02 20:05:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-02 20:05:45 +0000
commit9fdb98e408fa59397725ce5707a60d3995d9de2f (patch)
tree4a0a8d6796edc4d92b33ee74ac308a72f2817190 /www/h2o
parent3d69a965fedd63f23f4bc26f6c1bc7d865ac112f (diff)
downloadports-9fdb98e408fa59397725ce5707a60d3995d9de2f.tar.gz
ports-9fdb98e408fa59397725ce5707a60d3995d9de2f.zip
www/h2o: Unbreak: build and install libraries that this project builds by default
Port changes: * Remove -DWITHOUT_LIBS=ON: the project builds libs by default, and has "it can also be used as a library" in its description. If desired, the option NOLIBS can potentially be created. * Remove stray -DEXTRA_LIBRARIES=OFF: EXTRA_LIBRARIES doesn't exist in the CMakeLists.txt Approved by: portmgr
Notes
Notes: svn path=/head/; revision=471402
Diffstat (limited to 'www/h2o')
-rw-r--r--www/h2o/Makefile5
-rw-r--r--www/h2o/pkg-plist41
2 files changed, 45 insertions, 1 deletions
diff --git a/www/h2o/Makefile b/www/h2o/Makefile
index 2bf5eaf2b853..b087f018b847 100644
--- a/www/h2o/Makefile
+++ b/www/h2o/Makefile
@@ -4,6 +4,7 @@
PORTNAME= h2o
DISTVERSIONPREFIX= v
DISTVERSION= 2.2.4
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= dch@FreeBSD.org
@@ -15,6 +16,8 @@ LICENSE_COMB= multi
BROKEN_armv6= fails to compile: asm_arm.inc:139:36: '.syntax divided' arm assembly not supported
BROKEN_armv7= fails to compile: asm_arm.inc:139:36: '.syntax divided' arm assembly not supported
+LIB_DEPENDS= libuv.so:devel/libuv
+
USES= cmake:noninja compiler:c11 cpe perl5 shebangfix ssl pkgconfig
CPE_VENDOR= h2o_project
USE_GITHUB= yes
@@ -45,7 +48,7 @@ OPTIONS_DEFAULT= MRUBY
OPTIONS_SUB= yes
MRUBY_DESC= Build with embedded mruby handler support
-CMAKE_ARGS+= -DEXTRA_LIBRARIES=OFF -DWITHOUT_LIBS=ON -DWITH_BUNDLED_SSL=OFF
+CMAKE_ARGS+= -DBUILD_SHARED_LIBS=ON -DWITH_BUNDLED_SSL=OFF
CMAKE_VERBOSE= yes
MRUBY_CMAKE_BOOL= WITH_MRUBY
diff --git a/www/h2o/pkg-plist b/www/h2o/pkg-plist
index c91bdb6e2a32..0a347a0bf165 100644
--- a/www/h2o/pkg-plist
+++ b/www/h2o/pkg-plist
@@ -1,4 +1,45 @@
bin/h2o
+include/h2o.h
+include/h2o/cache.h
+include/h2o/cache_digests.h
+include/h2o/configurator.h
+include/h2o/file.h
+include/h2o/filecache.h
+include/h2o/hostinfo.h
+include/h2o/http1.h
+include/h2o/http1client.h
+include/h2o/http2.h
+include/h2o/http2_casper.h
+include/h2o/http2_internal.h
+include/h2o/http2_scheduler.h
+include/h2o/linklist.h
+include/h2o/memcached.h
+include/h2o/memory.h
+include/h2o/mruby_.h
+include/h2o/multithread.h
+include/h2o/openssl_backport.h
+include/h2o/rand.h
+include/h2o/serverutil.h
+include/h2o/socket.h
+include/h2o/socket/evloop.h
+include/h2o/socket/uv-binding.h
+include/h2o/socketpool.h
+include/h2o/string_.h
+include/h2o/time_.h
+include/h2o/timeout.h
+include/h2o/token.h
+include/h2o/tunnel.h
+include/h2o/url.h
+include/h2o/version.h
+include/h2o/websocket.h
+lib/libh2o-evloop.so
+lib/libh2o-evloop.so.0.13
+lib/libh2o-evloop.so.0.13.4
+lib/libh2o.so
+lib/libh2o.so.0.13
+lib/libh2o.so.0.13.4
+libdata/pkgconfig/libh2o-evloop.pc
+libdata/pkgconfig/libh2o.pc
%%DATADIR%%/annotate-backtrace-symbols
%%DATADIR%%/fetch-ocsp-response
%%DATADIR%%/kill-on-close