aboutsummaryrefslogtreecommitdiff
path: root/www/harvest/files
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-08-02 16:20:20 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-08-02 16:20:20 +0000
commit0a46264f4c625e375c726871af8c4195be1c2fb7 (patch)
tree9c77deae5bf2077488f87ba368bdef9ea3991f0b /www/harvest/files
parenta0c49d0de88e79c7dce53799da9f03e0d39e903f (diff)
downloadports-0a46264f4c625e375c726871af8c4195be1c2fb7.tar.gz
ports-0a46264f4c625e375c726871af8c4195be1c2fb7.zip
Notes
Diffstat (limited to 'www/harvest/files')
-rw-r--r--www/harvest/files/patch-components::broker::zebra::yaz::lib::Makefile.in8
-rw-r--r--www/harvest/files/patch-components::gatherer::WordPerfect::wp2x-2.3::Makefile.in7
-rw-r--r--www/harvest/files/patch-components::gatherer::standard::pstext::libs::include::sio.h14
-rw-r--r--www/harvest/files/patch-components::gatherer::standard::pstext::libs::include::str.h15
-rw-r--r--www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::sio::sio.h27
-rw-r--r--www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::sio::sprint.c31
-rw-r--r--www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::str::str.h54
-rw-r--r--www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::str::strprint.c135
-rw-r--r--www/harvest/files/patch-components::gatherer::standard::pstext::pstext::common.c35
-rw-r--r--www/harvest/files/patch-components::gatherer::standard::pstext::pstext::defs.h15
-rw-r--r--www/harvest/files/patch-src::broker::log.c53
-rw-r--r--www/harvest/files/patch-src::broker::log.h13
-rw-r--r--www/harvest/files/patch-src::configure11
13 files changed, 409 insertions, 9 deletions
diff --git a/www/harvest/files/patch-components::broker::zebra::yaz::lib::Makefile.in b/www/harvest/files/patch-components::broker::zebra::yaz::lib::Makefile.in
index 813658a2cc9a..3db09902635a 100644
--- a/www/harvest/files/patch-components::broker::zebra::yaz::lib::Makefile.in
+++ b/www/harvest/files/patch-components::broker::zebra::yaz::lib::Makefile.in
@@ -1,8 +1,8 @@
---- components/broker/zebra/yaz/lib/Makefile.in.orig Sat Nov 30 00:47:25 2002
-+++ components/broker/zebra/yaz/lib/Makefile.in Thu Dec 5 21:44:41 2002
-@@ -190,7 +190,7 @@
+--- ./components/broker/zebra/yaz/lib/Makefile.in.orig Fri Apr 25 18:22:11 2003
++++ ./components/broker/zebra/yaz/lib/Makefile.in Fri Aug 1 13:24:57 2003
+@@ -197,7 +197,7 @@
$(AUTOMAKE) --gnu lib/Makefile
- Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ Makefile: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.in $(top_builddir)/config.status
cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)
-libLTLIBRARIES_INSTALL = $(INSTALL)
+libLTLIBRARIES_INSTALL = $(INSTALL_DATA)
diff --git a/www/harvest/files/patch-components::gatherer::WordPerfect::wp2x-2.3::Makefile.in b/www/harvest/files/patch-components::gatherer::WordPerfect::wp2x-2.3::Makefile.in
index 3e51ae50620a..5dbd8d4f8411 100644
--- a/www/harvest/files/patch-components::gatherer::WordPerfect::wp2x-2.3::Makefile.in
+++ b/www/harvest/files/patch-components::gatherer::WordPerfect::wp2x-2.3::Makefile.in
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- components/gatherer/WordPerfect/wp2x-2.3/Makefile.in.orig Wed Dec 18 23:55:21 2002
-+++ components/gatherer/WordPerfect/wp2x-2.3/Makefile.in Wed Dec 18 23:55:50 2002
+--- ./components/gatherer/WordPerfect/wp2x-2.3/Makefile.in.orig Thu Feb 7 23:19:22 2002
++++ ./components/gatherer/WordPerfect/wp2x-2.3/Makefile.in Fri Aug 1 13:24:57 2003
@@ -29,7 +29,7 @@
OBJS = wp2x.o dopen.o tokens.o charsets.o
diff --git a/www/harvest/files/patch-components::gatherer::standard::pstext::libs::include::sio.h b/www/harvest/files/patch-components::gatherer::standard::pstext::libs::include::sio.h
new file mode 100644
index 000000000000..3f8a9fe386cd
--- /dev/null
+++ b/www/harvest/files/patch-components::gatherer::standard::pstext::libs::include::sio.h
@@ -0,0 +1,14 @@
+--- ./components/gatherer/standard/pstext/libs/include/sio.h.orig Fri Aug 1 14:20:17 2003
++++ ./components/gatherer/standard/pstext/libs/include/sio.h Fri Aug 1 14:20:27 2003
+@@ -12,7 +12,11 @@
+ #define __SIO_H
+
+ #include <errno.h>
++#ifdef __STRICT_ANSI__
++#include <stdarg.h>
++#else
+ #include <varargs.h>
++#endif
+
+ /*
+ * Naming conventions:
diff --git a/www/harvest/files/patch-components::gatherer::standard::pstext::libs::include::str.h b/www/harvest/files/patch-components::gatherer::standard::pstext::libs::include::str.h
new file mode 100644
index 000000000000..da261cc2aa18
--- /dev/null
+++ b/www/harvest/files/patch-components::gatherer::standard::pstext::libs::include::str.h
@@ -0,0 +1,15 @@
+--- ./components/gatherer/standard/pstext/libs/include/str.h.orig Fri Aug 1 14:17:54 2003
++++ ./components/gatherer/standard/pstext/libs/include/str.h Fri Aug 1 14:19:40 2003
+@@ -12,8 +12,11 @@
+ * str.h,v 1.1.1.1 1994/04/26 19:08:08 hardy Exp
+ */
+
++#ifdef __STRICT_ANSI__
++#include <stdarg.h>
++#else
+ #include <varargs.h>
+-
++#endif
+
+ #ifdef __ARGS
+ #undef __ARGS
diff --git a/www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::sio::sio.h b/www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::sio::sio.h
new file mode 100644
index 000000000000..a4af0d1817eb
--- /dev/null
+++ b/www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::sio::sio.h
@@ -0,0 +1,27 @@
+--- ./components/gatherer/standard/pstext/libs/src/sio/sio.h.orig Sun Mar 16 22:07:04 1997
++++ ./components/gatherer/standard/pstext/libs/src/sio/sio.h Fri Aug 1 13:24:57 2003
+@@ -12,7 +12,11 @@
+ #define __SIO_H
+
+ #include <errno.h>
++#if defined(__STRICT_ANSI__)
++#include <stdarg.h>
++#else
+ #include <varargs.h>
++#endif
+
+ /*
+ * Naming conventions:
+@@ -240,8 +244,10 @@
+ */
+ int Swrite __ARGS( ( int fd, char *buf, int nbytes ) ) ;
+ int Sputc __ARGS( ( int fd, char c ) ) ;
+-int Sprint __ARGS( ( int fd, char *format, ... ) ) ;
+-int Sprintv __ARGS( ( int fd, char *format, va_list ) ) ;
++#ifndef __STRICT_ANSI__
++int Sprint __ARGS( ( int fd, char *format , ...) ) ;
++#endif
++int Sprintv __ARGS( ( int fd, char *format, va_args ) ) ;
+
+ /*
+ * other functions
diff --git a/www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::sio::sprint.c b/www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::sio::sprint.c
new file mode 100644
index 000000000000..6658afb13538
--- /dev/null
+++ b/www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::sio::sprint.c
@@ -0,0 +1,31 @@
+--- ./components/gatherer/standard/pstext/libs/src/sio/sprint.c.orig Fri Jan 31 17:25:04 2003
++++ ./components/gatherer/standard/pstext/libs/src/sio/sprint.c Fri Aug 1 13:24:58 2003
+@@ -132,6 +132,15 @@
+ * - all floating point arguments are passed as doubles
+ */
+ /* VARARGS2 */
++#if defined(__STRICT_ANSI__)
++int Sprint( int fd, char *fmt,... )
++{
++ __sio_descriptor_t *dp = &__sio_descriptors[ fd ] ;
++ register __sio_od_t *odp = ODP( dp ) ;
++ register int cc ;
++ va_list ap ;
++ va_start( ap,fmt ) ;
++#else
+ int Sprint( fd, fmt, va_alist )
+ int fd ;
+ register char *fmt ;
+@@ -141,10 +150,10 @@
+ register __sio_od_t *odp = ODP( dp ) ;
+ register int cc ;
+ va_list ap ;
+-
++ va_start( ap ) ;
++#endif
+ IO_SETUP( fd, dp, __SIO_OUTPUT_STREAM, SIO_ERR ) ;
+
+- va_start( ap ) ;
+ cc = __sio_converter( odp, fd, fmt, ap ) ;
+ va_end( ap ) ;
+ return( cc ) ;
diff --git a/www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::str::str.h b/www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::str::str.h
new file mode 100644
index 000000000000..2a24aab4429f
--- /dev/null
+++ b/www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::str::str.h
@@ -0,0 +1,54 @@
+--- ./components/gatherer/standard/pstext/libs/src/str/str.h.orig Sun Mar 16 22:07:27 1997
++++ ./components/gatherer/standard/pstext/libs/src/str/str.h Fri Aug 1 13:47:57 2003
+@@ -11,9 +11,11 @@
+ /*
+ * str.h,v 1.1.1.1 1994/04/26 19:08:12 hardy Exp
+ */
+-
++#ifdef __STRICT_ANSI__
++#include <stdarg.h>
++#else
+ #include <varargs.h>
+-
++#endif
+
+ #ifdef __ARGS
+ #undef __ARGS
+@@ -25,21 +27,32 @@
+ # define __ARGS( s ) ()
+ #endif
+
++// void strx_print( int ccp, char *buf, int len, char *format, ... )
++// char *strx_sprint( char *buf, int len, char *format, ... )
++// int strx_nprint( char *buf, int len, char *format, ... )
++// void str_print( int ccp, char *buf, char *format, ... )
++// char *str_sprint( char *buf, char *format, ... )
++// int str_nprint( char *buf, char *format, ... )
++
+
+ /*
+ * strprint(3) functions
+ */
++
++#ifndef __STRICT_ANSI__
++void strx_print __ARGS( ( int *count, char *buf, int len, char *fmt, ... ) ) ;
++int strx_nprint __ARGS( ( char *buf, int len, char *fmt, ... ) ) ;
++void str_print __ARGS( ( int *count, char *buf, char *fmt, ... ) ) ;
++char *strx_sprint __ARGS( ( char *buf, int len, char *fmt, ... ) ) ;
++int str_nprintv __ARGS( ( char *buf, char *fmt, va_list ) ) ;
+ char *str_sprint __ARGS( ( char *buf, char *fmt, ... ) ) ;
+ int str_nprint __ARGS( ( char *buf, char *fmt, ... ) ) ;
+-void str_print __ARGS( ( int *count, char *buf, char *fmt, ... ) ) ;
++#endif
++
+
+ char *str_sprintv __ARGS( ( char *buf, char *fmt, va_list ) ) ;
+-int str_nprintv __ARGS( ( char *buf, char *fmt, va_list ) ) ;
+ void str_printv __ARGS( ( int *count, char *buf, char *fmt, va_list ) ) ;
+
+-char *strx_sprint __ARGS( ( char *buf, int len, char *fmt, ... ) ) ;
+-int strx_nprint __ARGS( ( char *buf, int len, char *fmt, ... ) ) ;
+-void strx_print __ARGS( ( int *count, char *buf, int len, char *fmt, ... ) ) ;
+
+ char *strx_sprintv __ARGS( ( char *buf, int len, char *fmt, va_list ) ) ;
+ int strx_nprintv __ARGS( ( char *buf, int len, char *fmt, va_list ) ) ;
diff --git a/www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::str::strprint.c b/www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::str::strprint.c
new file mode 100644
index 000000000000..f3d5f94ebbbf
--- /dev/null
+++ b/www/harvest/files/patch-components::gatherer::standard::pstext::libs::src::str::strprint.c
@@ -0,0 +1,135 @@
+--- ./components/gatherer/standard/pstext/libs/src/str/strprint.c.orig Fri Aug 1 13:34:23 2003
++++ ./components/gatherer/standard/pstext/libs/src/str/strprint.c Fri Aug 1 13:47:29 2003
+@@ -62,6 +62,13 @@
+ }
+
+
++#ifdef __STRICT_ANSI__
++void strx_print( int ccp, char *buf, int len, char *format, ... )
++{
++ va_list ap ;
++
++ va_start( ap, *format ) ;
++#else
+ void strx_print( ccp, buf, len, format, va_alist )
+ int *ccp ;
+ char *buf ;
+@@ -70,13 +77,19 @@
+ va_dcl
+ {
+ va_list ap ;
+-
+ va_start( ap ) ;
++#endif
+ strx_printv( ccp, buf, len, format, ap ) ;
+ va_end( ap ) ;
+ }
+
++#ifdef __STRICT_ANSI__
++char *strx_sprint( char *buf, int len, char *format, ... )
++{
++ va_list ap ;
+
++ va_start( ap, *format ) ;
++#else
+ char *strx_sprint( buf, len, format, va_alist )
+ char *buf ;
+ int len ;
+@@ -86,6 +99,7 @@
+ va_list ap ;
+
+ va_start( ap ) ;
++#endif
+ strx_printv( INT_NULL, buf, len, format, ap ) ;
+ va_end( ap ) ;
+ return( buf ) ;
+@@ -102,7 +116,14 @@
+ return( buf ) ;
+ }
+
++#ifdef __STRICT_ANSI__
++int strx_nprint( char *buf, int len, char *format, ... )
++{
++ int cc ;
++ va_list ap ;
+
++ va_start( ap, *format ) ;
++#else
+ int strx_nprint( buf, len, format, va_alist )
+ char *buf ;
+ int len ;
+@@ -113,6 +134,7 @@
+ va_list ap ;
+
+ va_start( ap ) ;
++#endif
+ strx_printv( &cc, buf, len, format, ap ) ;
+ va_end( ap ) ;
+ return( cc ) ;
+@@ -137,6 +159,13 @@
+ * Group 2: the str_* functions
+ */
+
++#ifdef __STRICT_ANSI__
++void str_print( int ccp, char *buf, char *format, ... )
++{
++ va_list ap ;
++
++ va_start( ap, *format ) ;
++#else
+ void str_print( ccp, buf, format, va_alist )
+ int *ccp ;
+ char *buf ;
+@@ -146,6 +175,7 @@
+ va_list ap ;
+
+ va_start( ap ) ;
++#endif
+ strx_printv( ccp, buf, 0, format, ap ) ;
+ va_end( ap ) ;
+ }
+@@ -160,7 +190,13 @@
+ strx_printv( ccp, buf, 0, format, ap ) ;
+ }
+
++#ifdef __STRICT_ANSI__
++char *str_sprint( char *buf, char *format, ... )
++{
++ va_list ap ;
+
++ va_start( ap, *format ) ;
++#else
+ char *str_sprint( buf, format, va_alist )
+ char *buf ;
+ char *format ;
+@@ -169,6 +205,7 @@
+ va_list ap ;
+
+ va_start( ap ) ;
++#endif
+ strx_printv( INT_NULL, buf, 0, format, ap ) ;
+ va_end( ap ) ;
+ return( buf ) ;
+@@ -184,7 +221,14 @@
+ return( buf ) ;
+ }
+
++#ifdef __STRICT_ANSI__
++int str_nprint( char *buf, char *format, ... )
++{
++ int cc ;
++ va_list ap ;
+
++ va_start( ap, *format) ;
++#else
+ int str_nprint( buf, format, va_alist )
+ char *buf ;
+ char *format ;
+@@ -194,6 +238,7 @@
+ va_list ap ;
+
+ va_start( ap ) ;
++#endif
+ strx_printv( &cc, buf, 0, format, ap ) ;
+ va_end( ap ) ;
+ return( cc ) ;
diff --git a/www/harvest/files/patch-components::gatherer::standard::pstext::pstext::common.c b/www/harvest/files/patch-components::gatherer::standard::pstext::pstext::common.c
new file mode 100644
index 000000000000..872e38efcecb
--- /dev/null
+++ b/www/harvest/files/patch-components::gatherer::standard::pstext::pstext::common.c
@@ -0,0 +1,35 @@
+--- ./components/gatherer/standard/pstext/pstext/common.c.orig Fri Aug 1 13:50:18 2003
++++ ./components/gatherer/standard/pstext/pstext/common.c Fri Aug 1 14:09:05 2003
+@@ -6,7 +6,11 @@
+
+ static char RCSid[] = "common.c,v 1.4 1995/01/20 23:03:20 hardy Exp";
+
++#ifdef __STRICT_ANSI__
++#include <stdarg.h>
++#else
+ #include <varargs.h>
++#endif
+
+ void exit();
+ char *malloc();
+@@ -143,6 +147,12 @@
+ }
+
+
++#ifdef __STRICT_ANSI__
++void error(char *fmt, ...)
++{
++ va_list ap;
++ va_start(ap,fmt);
++#else
+ void error(fmt, va_alist)
+ char *fmt;
+ va_dcl
+@@ -150,6 +160,7 @@
+ va_list ap;
+
+ va_start(ap);
++#endif
+ Sprint(2, "pstext: Line %d: ", line_count);
+ Sprintv(2, fmt, ap);
+ exit(1);
diff --git a/www/harvest/files/patch-components::gatherer::standard::pstext::pstext::defs.h b/www/harvest/files/patch-components::gatherer::standard::pstext::pstext::defs.h
new file mode 100644
index 000000000000..fe3724c42fe2
--- /dev/null
+++ b/www/harvest/files/patch-components::gatherer::standard::pstext::pstext::defs.h
@@ -0,0 +1,15 @@
+--- ./components/gatherer/standard/pstext/pstext/defs.h.orig Fri Aug 1 13:51:49 2003
++++ ./components/gatherer/standard/pstext/pstext/defs.h Fri Aug 1 13:58:59 2003
+@@ -43,7 +43,12 @@
+ TOK_STRING, TOK_NUMBER, TOK_OTHER, TOK_CMD
+ } token_e;
+
++#ifdef __STRICT_ANSI__
++void error (char *fmt, ...);
++#else
+ void error();
++#endif
++
+ void printout();
+
+ extern int line_count;
diff --git a/www/harvest/files/patch-src::broker::log.c b/www/harvest/files/patch-src::broker::log.c
new file mode 100644
index 000000000000..3c8361237305
--- /dev/null
+++ b/www/harvest/files/patch-src::broker::log.c
@@ -0,0 +1,53 @@
+--- ./src/broker/log.c.orig Fri May 2 20:34:44 1997
++++ ./src/broker/log.c Fri Aug 1 13:24:58 2003
+@@ -151,10 +151,28 @@
+ }
+
+ /* Log Something */
+-int LOG_statlog(va_alist)
++#if defined(__STRICT_ANSI__)
++int LOG_statlog(char *fmt,...)
++{
++ time_t curtime;
++ unsigned int type;
++ char *outstr = NULL;
++ char *statname = NULL;
++ char *url = NULL;
++ char *gn = NULL;
++ char *gh = NULL;
++ char *gv = NULL;
++ int gid;
++ fd_t FD;
++
++ va_list ap;
++ va_start(ap,fmt);
++ va_list args;
++ va_start(args,fmt);
++#else
++int LOG_statlog(va_alist)
+ va_dcl
+ {
+- va_list args;
+ time_t curtime;
+ unsigned int type;
+ char *outstr = NULL;
+@@ -166,10 +184,18 @@
+ int gid;
+ fd_t FD;
+
++ va_list ap;
++ char *fmt;
++ va_list args;
++ va_start(ap);
++ fmt = va_arg(ap, char *);
++ fmt = va_arg(args, char *);
++ va_start(args);
++#endif /* __STRICT_ANSI__ */
++
+ if (!log_file)
+ return ERROR;
+
+- va_start(args);
+ type = va_arg(args, unsigned int);
+ if (LOG_do_logging(type) == TRUE) {
+ statname = va_arg(args, char *);
diff --git a/www/harvest/files/patch-src::broker::log.h b/www/harvest/files/patch-src::broker::log.h
new file mode 100644
index 000000000000..87add84b23ff
--- /dev/null
+++ b/www/harvest/files/patch-src::broker::log.h
@@ -0,0 +1,13 @@
+--- ./src/broker/log.h.orig Fri Mar 21 17:20:01 1997
++++ ./src/broker/log.h Fri Aug 1 13:24:58 2003
+@@ -147,8 +147,9 @@
+ #define L_CONNECT_S "CONNECTION"
+
+ /* ========== Logging Macros ========= */
+-
++#ifndef __STRICT_ANSI__
+ int LOG_statlog();
++#endif
+
+ #define LOGUPDATE(X) \
+ {LOG_statlog(L_UPDATE,L_UPDATE_S,(X)->url,(X)->FD,(X)->GID);}
diff --git a/www/harvest/files/patch-src::configure b/www/harvest/files/patch-src::configure
new file mode 100644
index 000000000000..57494d959a81
--- /dev/null
+++ b/www/harvest/files/patch-src::configure
@@ -0,0 +1,11 @@
+--- ./src/configure.orig Fri Aug 1 13:24:59 2003
++++ ./src/configure Fri Aug 1 13:24:59 2003
+@@ -7299,7 +7299,7 @@
+ ac_prev=prefix ;;
+ -prefix=* | --prefix=* | --prefi=* | --pref=* | --pre=* | --pr=* | --p=*)
+ ;;
+- *) ac_sub_configure_args="$ac_sub_configure_args $ac_arg" ;;
++ *) ac_sub_configure_args="$ac_arg" ;;
+ esac
+ done
+