aboutsummaryrefslogtreecommitdiff
path: root/www/horde2
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 03:54:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 03:54:09 +0000
commit0825d343b67d333a5eb074ffc162e99e36afd05b (patch)
treefa9e30457336a2f3f64d4b8aec724296f7285e0a /www/horde2
parent527b94968318c37ba67fae67811b60ad2500b11c (diff)
downloadports-0825d343b67d333a5eb074ffc162e99e36afd05b.tar.gz
ports-0825d343b67d333a5eb074ffc162e99e36afd05b.zip
Notes
Diffstat (limited to 'www/horde2')
-rw-r--r--www/horde2/Makefile40
-rw-r--r--www/horde2/files/patch-ab27
-rw-r--r--www/horde2/pkg-deinstall3
3 files changed, 34 insertions, 36 deletions
diff --git a/www/horde2/Makefile b/www/horde2/Makefile
index 81189991849c..08db76bb5435 100644
--- a/www/horde2/Makefile
+++ b/www/horde2/Makefile
@@ -34,6 +34,9 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libssl.so:${PORTSDIR}/www/apache13-mod
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeHorde
DOCS= COPYING README docs/CHANGES docs/CODING_STANDARDS \
docs/CONTRIBUTING docs/CREDITS docs/HACKING docs/INSTALL
CONFFILE= html.php lang.php mime_drivers.php mime_mapping.php \
@@ -92,33 +95,35 @@ do-install:
@${CP} -p ${WRKSRC}/*.php ${HORDEDIR}
@if [ ! -f ${CONFDIR}/horde.php ]; then \
${CP} ${CONFDIR}/horde.php.dist ${CONFDIR}/horde.php ; \
- ${PERL} -pi -e "s:/var/www/htdocs/horde/templates:${HORDEDIR}/templates:g" \
- ${CONFDIR}/horde.php ; \
- ${PERL} -pi -e "s:/tmp/horde.log:${LOG_FILE}:g" ${CONFDIR}/horde.php ; \
+ ${REINPLACE_CMD} -e "s:/tmp/horde.log:${LOG_FILE}:g" ${CONFDIR}/horde.php ; \
+ ${RM} ${CONFDIR}/horde.php.beforeHorde ; \
fi
- @${PERL} -pi -e "s:/etc/mpasswd:${LOCALBASE}/etc/mpasswd:g" \
+ @${REINPLACE_CMD} -e "s:/etc/mpasswd:${LOCALBASE}/etc/mpasswd:g" \
${HORDEDIR}/lib/Auth/mcal.php
+ @${RM} ${HORDEDIR}/lib/Auth/mcal.php.beforeHorde
.for FILE in ${CONFFILE}
@if [ ! -f ${CONFDIR}/${FILE} ]; then \
${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
fi
.endfor
- @${PERL} -pi -e "s:%%LOCALBASE%%:${LOCALBASE}:" ${CONFDIR}/mime_drivers.php
+ @${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:" ${CONFDIR}/mime_drivers.php
+ @${RM} ${CONFDIR}/mime_drivers.php.beforeHorde
@${CP} ${WRKSRC}/scripts/set_perms.sh ${HORDESBIN}/horde_set_perms.sh
- @${PERL} -pi -e "s:UPDATED_BY_THE_PORT:${HORDEDIR}/:g" \
+ @${REINPLACE_CMD} -e "s:UPDATED_BY_THE_PORT:${HORDEDIR}/:g" \
${HORDESBIN}/horde_set_perms.sh
+ @${RM} ${HORDESBIN}/horde_set_perms.sh.beforeHorde
@${CHMOD} u+x ${HORDESBIN}/horde_set_perms.sh
@(if [ -f ${APACHE_CONF} ] ; then \
- ${MKDIR} ${HORDE_INC} ; \
- ${CP} -p ${FILESDIR}/httpd.conf.horde ${HORDE_INC} ; \
- ${PERL} -pi -e "s:/home/httpd/html/horde:${HORDEDIR}:g" ${HORDE_INC}/httpd.conf.horde ; \
- ${PERL} -pi -e "s:/home/httpd/phplib:${PHP_LIB}:g" ${HORDE_INC}/httpd.conf.horde ; \
- ${ECHO_MSG} "===> Updating ${APACHE_CONF}..." ; \
- ${CP} -p ${APACHE_CONF} ${APACHE_CONF}.beforeHorde ; \
- ${PERL} -pi -e "s:php_value auto_prepend_file:# php_value auto_prepend_file:g" ${APACHE_CONF} ; \
- ${PERL} -pi -e "s:${HORDEDIR}/phplib:${PHP_LIB}:g" ${APACHE_CONF} ; \
- ${ECHO_CMD} "# Horde's include directory" >> ${APACHE_CONF} ; \
- ${ECHO_CMD} "Include ${HORDE_INC}" >> ${APACHE_CONF} ; \
+ ${MKDIR} ${HORDE_INC} ; \
+ ${CP} -p ${FILESDIR}/httpd.conf.horde ${HORDE_INC} ; \
+ ${REINPLACE_CMD} -e "s:/home/httpd/html/horde:${HORDEDIR}:g ; \
+ s:/home/httpd/phplib:${PHP_LIB}:g" ${HORDE_INC}/httpd.conf.horde ; \
+ ${RM} ${HORDE_INC}/httpd.conf.horde.beforeHorde ; \
+ ${ECHO_MSG} "===> Updating ${APACHE_CONF}..." ; \
+ ${REINPLACE_CMD} -e "s:php_value auto_prepend_file:# php_value auto_prepend_file:g ; \
+ s:${HORDEDIR}/phplib:${PHP_LIB}:g" ${APACHE_CONF} ; \
+ ${ECHO_CMD} "# Horde's include directory" >> ${APACHE_CONF} ; \
+ ${ECHO_CMD} "Include ${HORDE_INC}" >> ${APACHE_CONF} ; \
fi)
@${CHOWN} -R www:www ${HORDEDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@@ -129,7 +134,8 @@ do-install:
.for FILE in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
- @${PERL} -pi -e "s:/usr/local/apache/htdocs/horde:${DOCSDIR}:g" ${DOCSDIR}/INSTALL
+ @${REINPLACE_CMD} -e "s:/usr/local/apache/htdocs:${PREFIX}/www:g" ${DOCSDIR}/INSTALL
+ @${RM} ${DOCSDIR}/INSTALL.beforeHorde
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/www/horde2/files/patch-ab b/www/horde2/files/patch-ab
index 16553bca732a..fbbef346a07f 100644
--- a/www/horde2/files/patch-ab
+++ b/www/horde2/files/patch-ab
@@ -1,5 +1,5 @@
---- config/horde.php.dist.orig Sat Mar 9 19:43:35 2002
-+++ config/horde.php.dist Wed Mar 13 01:21:30 2002
+--- config/horde.php.dist.orig Sat Jun 1 01:57:03 2002
++++ config/horde.php.dist Mon Jun 24 21:59:21 2002
@@ -75,7 +75,7 @@
// What backend should we use for authenticating users to Horde? Valid
@@ -9,18 +9,9 @@
// An array holding any parameters that the Auth object will need to
// function correctly.
-@@ -106,7 +106,7 @@
- // and for sql it would be the table name to use. For the 'syslog'
- // driver it is the facility as a _constant_ (with no quotes), e.g.:
- // ... = LOG_LOCAL0;
--$conf['log']['name'] = '/tmp/horde.log';
-+$conf['log']['name'] = '/var/log/horde.log';
-
- // What level of messages should we log? The values are LOG_EMERG,
- // LOG_ALERT, LOG_CRIT, LOG_ERR, LOG_WARNING, LOG_NOTICE, LOG_INFO,
@@ -131,7 +131,7 @@
// (meaning use system defaults and don't save any user preferences),
- // 'session' (preferences only persist during the login), 'ldap',
+ // 'session' (preferences only persist during the login), 'ldap',
// and 'sql'.
-$conf['prefs']['driver'] = 'none';
+$conf['prefs']['driver'] = 'sql';
@@ -44,18 +35,18 @@
+$conf['prefs']['params']['database'] = 'horde';
+$conf['prefs']['params']['table'] = 'horde_prefs';
-
- /**
-@@ -177,7 +177,7 @@
- // function correctly. For sendmail, this is mainly the sendmail_path
- // option; SMTP requires at least a server and a port (if nonstandard).
+ // This is an example configuration for an LDAP preference backend.
+ // The schemas needed for ldap are in horde/scripts/ldap. For more
+@@ -195,7 +195,7 @@
+ // If you want to use SMTP authentication, set the 'auth' parameter
+ // to 'true' (without quotes).
$conf['mailer']['params'] = array();
-// $conf['mailer']['params'] = array('sendmail_path' => '/usr/lib/sendmail');
+// $conf['mailer']['params'] = array('sendmail_path' => '/usr/sbin/sendmail');
// $conf['mailer']['params'] = array('host' => 'smtp.example.com');
-@@ -223,3 +223,9 @@
+@@ -241,3 +241,9 @@
// Should we use DHTML to display a floating menu of Horde appliation
// links, instead of a frame?
$conf['menu']['floating_bar'] = false;
diff --git a/www/horde2/pkg-deinstall b/www/horde2/pkg-deinstall
index 6a75b26f7a23..8352504f3599 100644
--- a/www/horde2/pkg-deinstall
+++ b/www/horde2/pkg-deinstall
@@ -8,6 +8,7 @@ fi
if [ -f ${PKG_PREFIX}/etc/apache/httpd.conf.beforeHorde ] ; then
echo "Restoring httpd.conf..."
cp ${PKG_PREFIX}/etc/apache/httpd.conf ${PKG_PREFIX}/etc/apache/httpd.conf.deinstHorde
- perl -pi -e "s:Include ${PKG_PREFIX}/etc/horde:# Include ${PKG_PREFIX}/etc/horde:g" \
+ sed_inplace -i.tmp -e "s:Include ${PKG_PREFIX}/etc/horde:# Include ${PKG_PREFIX}/etc/horde:g" \
${PKG_PREFIX}/etc/apache/httpd.conf
+ rm ${PKG_PREFIX}/etc/apache/httpd.conf.tmp
fi