aboutsummaryrefslogtreecommitdiff
path: root/www/hs-gitit
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-02-18 03:25:18 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-02-18 03:25:18 +0000
commitbd8178b27a7c1e18a4df5dc19e6fefb99cee68d5 (patch)
tree3855e644148a1ce76e4d6746bad558e180fb10fc /www/hs-gitit
parent81c73710a6fc1d6454b029f5e2c81f592c5be130 (diff)
downloadports-bd8178b27a7c1e18a4df5dc19e6fefb99cee68d5.tar.gz
ports-bd8178b27a7c1e18a4df5dc19e6fefb99cee68d5.zip
Notes
Diffstat (limited to 'www/hs-gitit')
-rw-r--r--www/hs-gitit/Makefile28
-rw-r--r--www/hs-gitit/distinfo2
-rw-r--r--www/hs-gitit/pkg-descr18
3 files changed, 48 insertions, 0 deletions
diff --git a/www/hs-gitit/Makefile b/www/hs-gitit/Makefile
new file mode 100644
index 000000000000..28c3093c17ce
--- /dev/null
+++ b/www/hs-gitit/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: hs-gitit
+# Date created: December 2, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gitit
+PORTVERSION= 0.8.1
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Wiki using happstack, git or darcs, and pandoc
+
+LICENSE= GPLv2
+
+USE_CABAL= cgi ConfigFile>=1 feed>=0.3.6 filestore>=0.4.0.2 \
+ happstack-server>=6.0 happstack-util>=6.0 \
+ highlighting-kate>=0.2.7.1 hslogger>=1 HStringTemplate>=0.6 \
+ HTTP>=4000.0 json>=0.4 mtl network>=2.1.0.0 pandoc>=1.8.2 \
+ pandoc-types>=1.8.2 parsec recaptcha>=0.1 safe SHA>1 text \
+ url>=2.1 utf8-string>=0.3 xhtml xml>=1.3.5 xss-sanitize>=0.3 \
+ zlib>=0.5
+
+EXECUTABLE= gitit expireGititCache
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-gitit/distinfo b/www/hs-gitit/distinfo
new file mode 100644
index 000000000000..f1a976ff4b23
--- /dev/null
+++ b/www/hs-gitit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/gitit-0.8.1.tar.gz) = d6ed871590e58ea4a5c70e7b9ca96182f549e7effd54f0dfa6906f64aa33b1ac
+SIZE (cabal/gitit-0.8.1.tar.gz) = 180641
diff --git a/www/hs-gitit/pkg-descr b/www/hs-gitit/pkg-descr
new file mode 100644
index 000000000000..14882da515ef
--- /dev/null
+++ b/www/hs-gitit/pkg-descr
@@ -0,0 +1,18 @@
+Gitit is a wiki backed by a git, darcs, or mercurial filestore. Pages
+and uploaded files can be modified either directly via the VCS's
+command-line tools or through the wiki's web interface. Pandoc is used
+for markup processing, so pages may be written in (extended) markdown,
+reStructuredText, LaTeX, HTML, or literate Haskell, and exported in ten
+different formats, including LaTeX, ConTeXt, DocBook, RTF, OpenOffice
+ODT, and MediaWiki markup.
+
+Notable features include:
+
+ * plugins: dynamically loaded page transformations written in Haskell.
+ * conversion of TeX math to MathML for display in web browsers.
+ * syntax highlighting of source code files and code snippets.
+ * Atom feeds (site-wide and per-page).
+ * a library, Network.Gitit, that makes it simple to include a gitit
+ wiki in any happstack application.
+
+WWW: http://gitit.net/