aboutsummaryrefslogtreecommitdiff
path: root/www/htdump
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-27 08:51:20 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-27 08:51:20 +0000
commitbbf9ef9afe4ab0d08b267e5b46a19466d2aac327 (patch)
tree93e1f9e6c2f5039d7bdd556cbe10ccdc702ccd7b /www/htdump
parentc2156ba7675d7515df101de62066651a0fa05247 (diff)
downloadports-bbf9ef9afe4ab0d08b267e5b46a19466d2aac327.tar.gz
ports-bbf9ef9afe4ab0d08b267e5b46a19466d2aac327.zip
Use PLIST_FILES, OPTIONS, MAKE_ARGS
Notes
Notes: svn path=/head/; revision=134237
Diffstat (limited to 'www/htdump')
-rw-r--r--www/htdump/Makefile13
-rw-r--r--www/htdump/files/patch-aa12
-rw-r--r--www/htdump/pkg-plist2
3 files changed, 7 insertions, 20 deletions
diff --git a/www/htdump/Makefile b/www/htdump/Makefile
index f141c1a759cb..002758b66b0f 100644
--- a/www/htdump/Makefile
+++ b/www/htdump/Makefile
@@ -14,21 +14,22 @@ MASTER_SITES= http://ivo.palli.nl/prog/linux/htdump/bin/
MAINTAINER= ports@FreeBSD.org
COMMENT= A tool to retrieve WWW data
+OPTIONS= SSL "SSL support" on
+
USE_GETOPT_LONG=yes
CFLAGS+= ${CPPFLAGS}
-MAKE_ENV= LDFLAGS="${LDFLAGS}"
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LFLAGS="-s ${LDFLAGS}"
+
+.include <bsd.port.pre.mk>
.if defined(WITH_SSL)
USE_OPENSSL= yes
ALL_TARGET= ssl
.endif
-pre-extract:
-.if !defined(WITH_SSL)
- @${ECHO} "Define WITH_SSL if you want to build with SSL support"
-.endif
+PLIST_FILES= bin/htdump
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/htdump ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/htdump/files/patch-aa b/www/htdump/files/patch-aa
index 7efabae7b018..1c3cbc937922 100644
--- a/www/htdump/files/patch-aa
+++ b/www/htdump/files/patch-aa
@@ -1,17 +1,5 @@
--- Makefile.orig Wed Dec 20 00:26:47 2000
+++ Makefile Sun Jul 6 20:19:19 2003
-@@ -5,10 +5,8 @@
- #
- #
-
--CFLAGS = -O4 -m486 -Wall #-funsigned-char -Wshadow -Wmissing-prototypes -Wmissing-declarations -Winline
- PROGS = htdump
--LFLAGS = -s #-static
--CC = cc
-+LFLAGS = -s ${LDFLAGS}
-
- # Nothing should have to change beneath this line
-
@@ -26,15 +24,15 @@
ssl: $(OBJS) socket-ssl.o
diff --git a/www/htdump/pkg-plist b/www/htdump/pkg-plist
deleted file mode 100644
index ebd837673bf2..000000000000
--- a/www/htdump/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-@comment $FreeBSD$
-bin/htdump