aboutsummaryrefslogtreecommitdiff
path: root/www/httest
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-10-16 16:58:31 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-10-16 16:58:31 +0000
commit84dc2468c6215dc5e26a290df9d846bcba0d23eb (patch)
tree368d4fd55dac24cb3887084d721f43c16bbfca69 /www/httest
parent024a27336ab6293232c7697a3ea0ebe3c7f99cc9 (diff)
downloadports-84dc2468c6215dc5e26a290df9d846bcba0d23eb.tar.gz
ports-84dc2468c6215dc5e26a290df9d846bcba0d23eb.zip
This port does not build with OpenSSL 1.1.1. Mark BROKEN for OSVERSION 1200085
and above while a solution is being sought. An upstream ticket has been created. Also pacify portlint by moving USES. Notified by: pkg-fallout
Notes
Notes: svn path=/head/; revision=482236
Diffstat (limited to 'www/httest')
-rw-r--r--www/httest/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/www/httest/Makefile b/www/httest/Makefile
index c37c4d93011a..90d665ebd13d 100644
--- a/www/httest/Makefile
+++ b/www/httest/Makefile
@@ -18,6 +18,11 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libpcre.so:devel/pcre \
libapr-1.so:devel/apr1
+USES= iconv lua libtool bdb ssl
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
OPTIONS_DEFINE= EXAMPLES
CONFIGURE_ARGS= --enable-lua-module \
@@ -27,9 +32,6 @@ CONFIGURE_ARGS= --enable-lua-module \
--with-pcre="${LOCALBASE}/bin" \
--with-ssl="${OPENSSLLIB}"
CPPFLAGS+= -I${LUA_INCDIR}
-GNU_CONFIGURE= yes
-USES= iconv lua libtool bdb ssl
-USE_LDCONFIG= yes
PORTEXAMPLES= *
@@ -37,6 +39,15 @@ INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
+.include <bsd.port.pre.mk>
+
+# Reported upstream:
+# https://sourceforge.net/p/htt/tickets/5/
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085
+BROKEN= does not build with OpenSSL 1.1.1
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|`$$APR_CONFIG --cflags`||; s|-llua|-llua-${LUA_VER}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/generate_modules_c.sh
@@ -47,4 +58,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.htt ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>