aboutsummaryrefslogtreecommitdiff
path: root/www/httest
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2024-06-30 11:26:49 +0000
committerRene Ladan <rene@FreeBSD.org>2024-06-30 11:27:11 +0000
commit96078f58070bfb6350ac41f4f3562e9859aba464 (patch)
treec78aea4fc95d7b06af54957da532cdbd2d6ab709 /www/httest
parent703683cc73f0098bdfecad8f9b2b93c8f82fb7f8 (diff)
www/httest: Remove expired port
2024-06-30 www/httest: Abandonware, no activity from upstream for years and depends on deprecated library devel/pcre
Diffstat (limited to 'www/httest')
-rw-r--r--www/httest/Makefile54
-rw-r--r--www/httest/distinfo3
-rw-r--r--www/httest/files/patch-src_lua__crypto.c189
-rw-r--r--www/httest/files/patch-src_ssl__module.c38
-rw-r--r--www/httest/pkg-descr13
-rw-r--r--www/httest/pkg-plist13
6 files changed, 0 insertions, 310 deletions
diff --git a/www/httest/Makefile b/www/httest/Makefile
deleted file mode 100644
index 0a8302d5ba11..000000000000
--- a/www/httest/Makefile
+++ /dev/null
@@ -1,54 +0,0 @@
-PORTNAME= httest
-PORTVERSION= 2.4.24
-PORTREVISION= 2
-CATEGORIES= www
-MASTER_SITES= SF/htt/htt${PORTVERSION:R}/${PORTNAME}-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= HTTP Test Tool
-WWW= https://htt.sourceforge.net/
-
-LICENSE= APACHE20
-
-DEPRECATED= Abandonware, no activity from upstream for years and depends on deprecated library devel/pcre
-EXPIRATION_DATE=2024-06-30
-
-BUILD_DEPENDS= help2man:misc/help2man
-LIB_DEPENDS= libexpat.so:textproc/expat2 \
- libgdbm.so:databases/gdbm \
- libpcre.so:devel/pcre \
- libapr-1.so:devel/apr1
-
-USES= iconv lua:-52 libtool ssl
-USE_LDCONFIG= yes
-
-GNU_CONFIGURE= yes
-
-CPPFLAGS+= -I${LUA_INCDIR}
-LDFLAGS+= -Wl,--as-needed
-
-
-INSTALL_TARGET= install-strip
-MAKE_JOBS_UNSAFE= yes
-PORTEXAMPLES= *
-
-CONFIGURE_ARGS= --enable-lua-module \
- --with-apr="${LOCALBASE}/bin" \
- --with-apr-util="${LOCALBASE}/bin" \
- --with-lua="${LUA_LIBDIR}" \
- --with-pcre="${LOCALBASE}/bin" \
- --with-ssl="${OPENSSLLIB}"
-
-OPTIONS_DEFINE= EXAMPLES
-
-post-patch:
- @${REINPLACE_CMD} -e 's|`$$APR_CONFIG --cflags`||; s|-llua|-llua-${LUA_VER}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/generate_modules_c.sh
- @${REINPLACE_CMD} -e 's|^apr_time_t start_time|extern &|' \
- ${WRKSRC}/src/perf_module.c
-
-post-install:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*.htt ${STAGEDIR}${EXAMPLESDIR}
-
-.include <bsd.port.mk>
diff --git a/www/httest/distinfo b/www/httest/distinfo
deleted file mode 100644
index 9f84690e7765..000000000000
--- a/www/httest/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1553719184
-SHA256 (httest-2.4.24.tar.gz) = b154361a6ed7aa07bfe86b874a84b2c24e09aafa1f0c23d94ad5989914e22cdf
-SIZE (httest-2.4.24.tar.gz) = 641889
diff --git a/www/httest/files/patch-src_lua__crypto.c b/www/httest/files/patch-src_lua__crypto.c
deleted file mode 100644
index 1410cf2d7263..000000000000
--- a/www/httest/files/patch-src_lua__crypto.c
+++ /dev/null
@@ -1,189 +0,0 @@
---- src/lua_crypto.c.orig 2019-01-12 14:43:35 UTC
-+++ src/lua_crypto.c
-@@ -124,7 +124,7 @@ static EVP_MD_CTX *evp_pget(lua_State *L, int i) {
- }
-
- static EVP_MD_CTX *evp_pnew(lua_State *L) {
-- EVP_MD_CTX *c = lua_newuserdata(L, sizeof(EVP_MD_CTX));
-+ EVP_MD_CTX *c = lua_newuserdata(L, sizeof(c));
- luaL_getmetatable(L, LUACRYPTO_EVP);
- lua_setmetatable(L, -2);
- return c;
-@@ -158,8 +158,7 @@ static int evp_clone(lua_State *L) {
- static int evp_reset(lua_State *L) {
- EVP_MD_CTX *c = evp_pget(L, 1);
- const EVP_MD *t = EVP_MD_CTX_md(c);
-- EVP_MD_CTX_cleanup(c);
-- EVP_MD_CTX_init(c);
-+ EVP_MD_CTX_reset(c);
- EVP_DigestInit_ex(c, t, NULL);
- return 0;
- }
-@@ -216,7 +215,7 @@ static int evp_tostring(lua_State *L) {
-
- static int evp_gc(lua_State *L) {
- EVP_MD_CTX *c = evp_pget(L, 1);
-- EVP_MD_CTX_cleanup(c);
-+ EVP_MD_CTX_free(c);
- return 1;
- }
-
-@@ -266,7 +265,7 @@ static HMAC_CTX *hmac_pget(lua_State *L, int i) {
- }
-
- static HMAC_CTX *hmac_pnew(lua_State *L) {
-- HMAC_CTX *c = lua_newuserdata(L, sizeof(HMAC_CTX));
-+ HMAC_CTX *c = lua_newuserdata(L, sizeof(c));
- luaL_getmetatable(L, LUACRYPTO_HMAC);
- lua_setmetatable(L, -2);
- return c;
-@@ -283,7 +282,7 @@ static int hmac_fnew(lua_State *L) {
- return 0;
- }
-
-- HMAC_CTX_init(c);
-+ c = HMAC_CTX_new();
- HMAC_Init_ex(c, k, strlen(k), type, NULL);
-
- return 1;
-@@ -292,7 +291,7 @@ static int hmac_fnew(lua_State *L) {
- static int hmac_clone(lua_State *L) {
- HMAC_CTX *c = hmac_pget(L, 1);
- HMAC_CTX *d = hmac_pnew(L);
-- *d = *c;
-+ HMAC_CTX_copy(d, c);
- return 1;
- }
-
-@@ -352,12 +351,12 @@ static int hmac_tostring(lua_State *L) {
-
- static int hmac_gc(lua_State *L) {
- HMAC_CTX *c = hmac_pget(L, 1);
-- HMAC_CTX_cleanup(c);
-+ HMAC_CTX_free(c);
- return 1;
- }
-
- static int hmac_fdigest(lua_State *L) {
-- HMAC_CTX c;
-+ HMAC_CTX *c;
- unsigned char digest[EVP_MAX_MD_SIZE];
- unsigned int written = 0;
- unsigned int i;
-@@ -372,10 +371,11 @@ static int hmac_fdigest(lua_State *L) {
- return 0;
- }
-
-- HMAC_CTX_init(&c);
-- HMAC_Init_ex(&c, k, strlen(k), type, NULL);
-- HMAC_Update(&c, (unsigned char *)s, strlen(s));
-- HMAC_Final(&c, digest, &written);
-+ c = HMAC_CTX_new();
-+ HMAC_Init_ex(c, k, strlen(k), type, NULL);
-+ HMAC_Update(c, (unsigned char *)s, strlen(s));
-+ HMAC_Final(c, digest, &written);
-+ HMAC_CTX_free(c);
-
- if (lua_toboolean(L, 4)) {
- lua_pushlstring(L, (char *)digest, written);
-@@ -696,7 +696,7 @@ static ASN1_TIME *asn1_time_pget(lua_State *L, int i)
- }
-
- static int asn1_time_fnew(lua_State *L) {
-- ASN1_TIME *asn1time = M_ASN1_TIME_new();
-+ ASN1_TIME *asn1time = (ASN1_TIME *)ASN1_STRING_type_new(V_ASN1_UTCTIME);
- time_t t = time(NULL);
- ASN1_TIME_set(asn1time, t);
- lua_pushlightuserdata(L, asn1time);
-@@ -708,7 +708,7 @@ static int asn1_time_fnew(lua_State *L) {
-
- static int asn1_time_clone(lua_State *L) {
- ASN1_TIME *time = asn1_time_pget(L, 1);
-- ASN1_TIME *copy = M_ASN1_TIME_dup(time);
-+ ASN1_TIME *copy = ASN1_STRING_dup((const ASN1_STRING *)time);
-
- lua_pushlightuserdata(L, copy);
- luaL_getmetatable(L, LUACRYPTO_ASN1TIME);
-@@ -738,7 +738,7 @@ static int asn1_time_toasn1(lua_State *L) {
-
- static int asn1_time_gc(lua_State *L) {
- ASN1_TIME *time = asn1_time_pget(L, 1);
-- M_ASN1_TIME_free(time);
-+ ASN1_STRING_free((ASN1_STRING *)time);
- return 1;
- }
-
-@@ -763,8 +763,8 @@ static int dh_cb(int p, int n, BN_GENCB *cb) {
- c='\n';
- break;
- }
-- BIO_write(cb->arg,&c,1);
-- (void)BIO_flush(cb->arg);
-+ BIO_write(BN_GENCB_get_arg(cb),&c,1);
-+ (void)BIO_flush(BN_GENCB_get_arg(cb));
- return 1;
- }
-
-@@ -780,19 +780,26 @@ static int dh_fnew(lua_State *L) {
- int num = luaL_checknumber(L, 2);
- DH *dh = DH_new();
- BIO *bio_err;
-- BN_GENCB cb;
-+ BN_GENCB *cb;
-+ cb = BN_GENCB_new();
-+ if (!cb) {
-+ luaL_argerror(L, 1, "could not create BN_GENCB structure");
-+ return 1;
-+ }
- if ((bio_err = BIO_new(BIO_s_file())) != NULL) {
- BIO_set_fp(bio_err,stderr,BIO_NOCLOSE|BIO_FP_TEXT);
- }
-- BN_GENCB_set(&cb, dh_cb, bio_err);
-- if (!DH_generate_parameters_ex(dh, num, generator, &cb)) {
-+ BN_GENCB_set(cb, dh_cb, bio_err);
-+ if (!DH_generate_parameters_ex(dh, num, generator, cb)) {
- luaL_argerror(L, 1, "could not generate DH paramters");
-+ BN_GENCB_free(cb);
- return 1;
- }
- DH_generate_key(dh);
- lua_pushlightuserdata(L, dh);
- luaL_getmetatable(L, LUACRYPTO_DH);
- lua_setmetatable(L, -2);
-+ BN_GENCB_free(cb);
-
- return 1;
- }
-@@ -824,8 +831,8 @@ static int dh_get_prime(lua_State *L) {
- apr_pool_t *pool;
- DH *dh = dh_pget(L, 1);
- HT_POOL_CREATE(&pool);
-- s = apr_pcalloc(pool, BN_num_bytes(dh->p));
-- len = BN_bn2bin(dh->p, s);
-+ s = apr_pcalloc(pool, BN_num_bytes(DH_get0_p(dh)));
-+ len = BN_bn2bin(DH_get0_p(dh), s);
- lua_pushlstring(L, (char *)s, len);
- apr_pool_destroy(pool);
- return 1;
-@@ -837,8 +844,8 @@ static int dh_get_priv_key(lua_State *L) {
- apr_pool_t *pool;
- DH *dh = dh_pget(L, 1);
- HT_POOL_CREATE(&pool);
-- s = apr_pcalloc(pool, BN_num_bytes(dh->priv_key));
-- len = BN_bn2bin(dh->priv_key, s);
-+ s = apr_pcalloc(pool, BN_num_bytes(DH_get0_priv_key(dh)));
-+ len = BN_bn2bin(DH_get0_priv_key(dh), s);
- lua_pushlstring(L, (char *)s, len);
- apr_pool_destroy(pool);
- return 1;
-@@ -850,8 +857,8 @@ static int dh_get_pub_key(lua_State *L) {
- apr_pool_t *pool;
- DH *dh = dh_pget(L, 1);
- HT_POOL_CREATE(&pool);
-- s = apr_pcalloc(pool, BN_num_bytes(dh->pub_key));
-- len = BN_bn2bin(dh->pub_key, s);
-+ s = apr_pcalloc(pool, BN_num_bytes(DH_get0_pub_key(dh)));
-+ len = BN_bn2bin(DH_get0_pub_key(dh), s);
- lua_pushlstring(L, (char *)s, len);
- apr_pool_destroy(pool);
- return 1;
diff --git a/www/httest/files/patch-src_ssl__module.c b/www/httest/files/patch-src_ssl__module.c
deleted file mode 100644
index eb74d82629d8..000000000000
--- a/www/httest/files/patch-src_ssl__module.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/ssl_module.c.orig 2016-12-28 15:28:18 UTC
-+++ src/ssl_module.c
-@@ -350,7 +350,7 @@ static void ssl_message_trace(int write_
- case DTLS1_VERSION:
- str_version = "DTLS 1.0";
- break;
--#if (OPENSSL_VERSION_NUMBER >= 0x1000100fL)
-+#if OPENSSL_VERSION_NUMBER >= 0x1000100fL && defined(DTLS1_BAD_VER)
- case DTLS1_BAD_VER:
- str_version = "DTLS 1.0 (bad)";
- break;
-@@ -422,7 +422,7 @@ static void ssl_message_trace(int write_
- version == TLS1_1_VERSION ||
- #endif
- version == DTLS1_VERSION
--#if (OPENSSL_VERSION_NUMBER >= 0x1000100fL)
-+#if OPENSSL_VERSION_NUMBER >= 0x1000100fL && defined(DTLS1_BAD_VER)
- || version == DTLS1_BAD_VER
- #endif
- ) {
-@@ -743,7 +743,7 @@ static int worker_set_client_method(work
- }
- #endif
- #endif
--#ifndef OPENSSL_NO_SSL3_METHOD
-+#ifndef OPENSSL_NO_SSL3
- else if (strcasecmp(sslstr, "SSL3") == 0) {
- is_ssl = 1;
- config->meth = SSLv3_client_method();
-@@ -794,7 +794,7 @@ static int worker_set_server_method(work
- }
- #endif
- #endif
--#ifndef OPENSSL_NO_SSL3_METHOD
-+#ifndef OPENSSL_NO_SSL3
- else if (strcasecmp(sslstr, "SSL3") == 0) {
- is_ssl = 1;
- config->meth = SSLv3_server_method();
diff --git a/www/httest/pkg-descr b/www/httest/pkg-descr
deleted file mode 100644
index 2e967ce70bd4..000000000000
--- a/www/httest/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-The htt provides a large variety of HTTP-related functionality, useful for
-implementing all kinds of HTTP-based tests:
-
-- Advanced HTTP protocol handling, including ne-grained timeout handling,
- request and response validation
-- Simulating clients and servers, including startup and shutdown of server
- daemons. This allows to create mock-ups of back-end systems in more complex
- test situations, for example when the tested application needs to interact
- with a 3rd-party back-end system which is not available in the testing
- environment.
-- Execution of external commandline tools, using their output as request
- or response data, or for validation purposes.
-- Copying stream data (e.g. from a response) and re-using it in variables.
diff --git a/www/httest/pkg-plist b/www/httest/pkg-plist
deleted file mode 100644
index e84129ca6ea8..000000000000
--- a/www/httest/pkg-plist
+++ /dev/null
@@ -1,13 +0,0 @@
-bin/htntlm
-bin/htproxy
-bin/htremote
-bin/httest
-include/htt/dso.h
-lib/libhello.a
-lib/libhello.so
-lib/libhello.so.0
-lib/libhello.so.0.0.0
-share/man/man1/htntlm.1.gz
-share/man/man1/htproxy.1.gz
-share/man/man1/htremote.1.gz
-share/man/man1/httest.1.gz