aboutsummaryrefslogtreecommitdiff
path: root/www/httest
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-12-28 15:56:44 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-12-28 15:56:44 +0000
commitd74f3bafcc47ddba1ce7c896f5bcc104bcb2f933 (patch)
tree43c498ef8698cbda73b69cb2049ffdc0db7e9026 /www/httest
parentbf250e828d4528bd544bd40b35edbfc7a37c781a (diff)
- Update to 2.4.18
- Port is now make jobs safe
Notes
Notes: svn path=/head/; revision=429787
Diffstat (limited to 'www/httest')
-rw-r--r--www/httest/Makefile4
-rw-r--r--www/httest/distinfo6
-rw-r--r--www/httest/files/patch-src_ssl__module.c28
3 files changed, 14 insertions, 24 deletions
diff --git a/www/httest/Makefile b/www/httest/Makefile
index a209585d91f7..eb7c10879756 100644
--- a/www/httest/Makefile
+++ b/www/httest/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= httest
-PORTVERSION= 2.4.17
+PORTVERSION= 2.4.18
CATEGORIES= www
MASTER_SITES= SF/htt/htt${PORTVERSION:R}/${PORTNAME}-${PORTVERSION}
@@ -34,8 +34,6 @@ PORTEXAMPLES= *
INSTALL_TARGET= install-strip
-MAKE_JOBS_UNSAFE= yes
-
post-patch:
@${REINPLACE_CMD} -e 's|`$$APR_CONFIG --cflags`||; s|-llua|-llua-${LUA_VER}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/generate_modules_c.sh
diff --git a/www/httest/distinfo b/www/httest/distinfo
index fa1176d491cc..3993e1b50623 100644
--- a/www/httest/distinfo
+++ b/www/httest/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1474725916
-SHA256 (httest-2.4.17.tar.gz) = 937434334979adde83fd83a98dfe656d5f493b4ee69098994ff6ef189df338b2
-SIZE (httest-2.4.17.tar.gz) = 555423
+TIMESTAMP = 1482936528
+SHA256 (httest-2.4.18.tar.gz) = ac615f68dafa7ba53a545ba1fc285924aab2b575dc9a05515c1efea334873fe5
+SIZE (httest-2.4.18.tar.gz) = 556389
diff --git a/www/httest/files/patch-src_ssl__module.c b/www/httest/files/patch-src_ssl__module.c
index d48f481b427e..eb74d82629d8 100644
--- a/www/httest/files/patch-src_ssl__module.c
+++ b/www/httest/files/patch-src_ssl__module.c
@@ -1,6 +1,6 @@
---- src/ssl_module.c.orig 2015-03-16 15:46:05 UTC
+--- src/ssl_module.c.orig 2016-12-28 15:28:18 UTC
+++ src/ssl_module.c
-@@ -349,7 +349,7 @@ static void ssl_message_trace(int write_
+@@ -350,7 +350,7 @@ static void ssl_message_trace(int write_
case DTLS1_VERSION:
str_version = "DTLS 1.0";
break;
@@ -9,7 +9,7 @@
case DTLS1_BAD_VER:
str_version = "DTLS 1.0 (bad)";
break;
-@@ -421,7 +421,7 @@ static void ssl_message_trace(int write_
+@@ -422,7 +422,7 @@ static void ssl_message_trace(int write_
version == TLS1_1_VERSION ||
#endif
version == DTLS1_VERSION
@@ -17,30 +17,22 @@
+#if OPENSSL_VERSION_NUMBER >= 0x1000100fL && defined(DTLS1_BAD_VER)
|| version == DTLS1_BAD_VER
#endif
- ) {
-@@ -740,10 +740,12 @@ static int worker_set_client_method(work
- config->meth = SSLv2_client_method();
+ ) {
+@@ -743,7 +743,7 @@ static int worker_set_client_method(work
}
#endif
+ #endif
+-#ifndef OPENSSL_NO_SSL3_METHOD
+#ifndef OPENSSL_NO_SSL3
else if (strcasecmp(sslstr, "SSL3") == 0) {
is_ssl = 1;
config->meth = SSLv3_client_method();
- }
-+#endif
- else if (strcasecmp(sslstr, "TLS1") == 0) {
- is_ssl = 1;
- config->meth = TLSv1_client_method();
-@@ -787,10 +789,12 @@ static int worker_set_server_method(work
- config->meth = SSLv2_server_method();
+@@ -794,7 +794,7 @@ static int worker_set_server_method(work
}
#endif
+ #endif
+-#ifndef OPENSSL_NO_SSL3_METHOD
+#ifndef OPENSSL_NO_SSL3
else if (strcasecmp(sslstr, "SSL3") == 0) {
is_ssl = 1;
config->meth = SSLv3_server_method();
- }
-+#endif
- else if (strcasecmp(sslstr, "TLS1") == 0) {
- is_ssl = 1;
- config->meth = TLSv1_server_method();