aboutsummaryrefslogtreecommitdiff
path: root/www/httpasyncclient
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-02-28 13:13:09 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-02-28 13:13:09 +0000
commit41df6f9f7cd44c68aec42652e5eabc800e0a9ac5 (patch)
tree696202a665949aeebfafb1715a2c13c3ae4fbe34 /www/httpasyncclient
parentc260e8de259871d9183896361d9b9b36e08a5ad4 (diff)
downloadports-41df6f9f7cd44c68aec42652e5eabc800e0a9ac5.tar.gz
ports-41df6f9f7cd44c68aec42652e5eabc800e0a9ac5.zip
Asynch HttpClient is a HTTP/1.1 compliant HTTP agent implementation based
on HttpCore NIO and HttpClient components. It is a complementary module to Apache HttpClient intended for special cases where ability to handle a great number of concurrent connections is more important than performance in terms of a raw data throughput. WWW: http://hc.apache.org/httpcomponents-asyncclient-4.0.x/
Notes
Notes: svn path=/head/; revision=346507
Diffstat (limited to 'www/httpasyncclient')
-rw-r--r--www/httpasyncclient/Makefile56
-rw-r--r--www/httpasyncclient/distinfo2
-rw-r--r--www/httpasyncclient/pkg-descr7
3 files changed, 65 insertions, 0 deletions
diff --git a/www/httpasyncclient/Makefile b/www/httpasyncclient/Makefile
new file mode 100644
index 000000000000..e0e1bc2dfb12
--- /dev/null
+++ b/www/httpasyncclient/Makefile
@@ -0,0 +1,56 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= httpasyncclient
+DISTVERSION= 4.0.1
+CATEGORIES= www java
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= httpcomponents/${PORTNAME}/binary
+DISTNAME= httpcomponents-asyncclient-${DISTVERSION}-bin
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= Java components implementing an asynchronous HTTP client
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${JAVAJARDIR}/httpclient.jar:${PORTSDIR}/www/httpclient
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/httpcomponents-asyncclient-${DISTVERSION}
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar \
+ %%JAVAJARDIR%%/${PORTNAME}-cache.jar
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR file as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}-${DISTVERSION}.jar \
+ ${STAGEDIR}/${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [DONE]"
+ @${ECHO_MSG} -n ">> Installing JAR file as ${JAVAJARDIR}/${PORTNAME}-cache.jar..."
+ @${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}-cache-${DISTVERSION}.jar \
+ ${STAGEDIR}/${JAVAJARDIR}/${PORTNAME}-cache.jar
+ @${ECHO_MSG} " [DONE]"
+.if ${PORT_OPTIONS:MDOCS}
+ @${ECHO_MSG} -n ">> Installing documentation..."
+ @${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/RELEASE_NOTES.txt ${STAGEDIR}/${DOCSDIR}/
+ @${ECHO_MSG} " [DONE]"
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${ECHO_MSG} -n ">> Installing examples..."
+ @${MKDIR} ${STAGEDIR}/${EXAMPLESDIR}
+ @cd ${WRKSRC}/examples && ${FIND} . \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}/${EXAMPLESDIR} > /dev/null 2>&1
+ @${ECHO_MSG} " [DONE]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/httpasyncclient/distinfo b/www/httpasyncclient/distinfo
new file mode 100644
index 000000000000..66a4e68ad463
--- /dev/null
+++ b/www/httpasyncclient/distinfo
@@ -0,0 +1,2 @@
+SHA256 (httpcomponents-asyncclient-4.0.1-bin.tar.gz) = f04e59f71ffa70f008bb30e3e64b87e1bdf3c20d878b9816c5744393ded6f826
+SIZE (httpcomponents-asyncclient-4.0.1-bin.tar.gz) = 1636887
diff --git a/www/httpasyncclient/pkg-descr b/www/httpasyncclient/pkg-descr
new file mode 100644
index 000000000000..8f6aa9025bc3
--- /dev/null
+++ b/www/httpasyncclient/pkg-descr
@@ -0,0 +1,7 @@
+Asynch HttpClient is a HTTP/1.1 compliant HTTP agent implementation based
+on HttpCore NIO and HttpClient components. It is a complementary module
+to Apache HttpClient intended for special cases where ability to handle a
+great number of concurrent connections is more important than performance
+in terms of a raw data throughput.
+
+WWW: http://hc.apache.org/httpcomponents-asyncclient-4.0.x/