aboutsummaryrefslogtreecommitdiff
path: root/www/interchange
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 10:01:59 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 10:01:59 +0000
commit8a51784050c568375753e5dca2173d7f8f1b3eb6 (patch)
treea09a16b1600a6515e11db81862fcd0fe5c5afc97 /www/interchange
parent1049b2122eb03747cff97e5cd116cde947a1ffc7 (diff)
downloadports-8a51784050c568375753e5dca2173d7f8f1b3eb6.tar.gz
ports-8a51784050c568375753e5dca2173d7f8f1b3eb6.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=319846
Diffstat (limited to 'www/interchange')
-rw-r--r--www/interchange/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/www/interchange/Makefile b/www/interchange/Makefile
index 083e6c878367..f9348c3d2c51 100644
--- a/www/interchange/Makefile
+++ b/www/interchange/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: interchange
-# Date created: 2 July 2002
-# Whom: Seth Kingsley <sethk@meowfishies.com>
-#
+# Created by: Seth Kingsley <sethk@meowfishies.com>
# $FreeBSD$
-#
PORTNAME= interchange
PORTVERSION= 5.6.1
@@ -24,18 +20,18 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
USE_BZIP2= yes
PERL_CONFIGURE= yes
-OPTIONS= MYSQL "Add MySQL support" on \
- PGSQL "Add PostgreSQL support" off
+OPTIONS_DEFINE= MYSQL PGSQL
+OPTIONS_DEFAULT= MYSQL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
USE_RC_SUBR= interchange
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
.endif
@@ -117,4 +113,4 @@ post-install:
.endfor
@PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>