aboutsummaryrefslogtreecommitdiff
path: root/www/interchange
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-07-08 09:44:13 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-07-08 09:44:13 +0000
commita3a50c68e45eb1c7003ebe4588b192a8798d84d5 (patch)
tree89d2188e4b0ae2a4a1d71e6c60cf3044cfc2e185 /www/interchange
parentc5beb65fa5ab0b51d32b1b4ea6a1ade0f30fd5cc (diff)
downloadports-a3a50c68e45eb1c7003ebe4588b192a8798d84d5.tar.gz
ports-a3a50c68e45eb1c7003ebe4588b192a8798d84d5.zip
Override do-configure with our own.
We install most of interchange's files into ${PREFIX}/interchange. This does not play well with Uses/perl5.mk, since it appends some values to CONFIGURE_ARGS that do not work with a custom prefix (it overrides PREFIX, INSTALLARCHLIB and INSTALLPRIVLIB). Since the right paths are necessary at the configure stage, we have to implement do-configure ourselves with a custom INTERCH_CONFIGURE_ARGS with the values we want. Additionally, set only the required values in INTERCH_CONFIGURE_ARGS and MAKE_ARGS, based on what upstream's RPM spec file does. Submitted by: loader@freebsdmall.com
Notes
Notes: svn path=/head/; revision=361207
Diffstat (limited to 'www/interchange')
-rw-r--r--www/interchange/Makefile25
1 files changed, 17 insertions, 8 deletions
diff --git a/www/interchange/Makefile b/www/interchange/Makefile
index e49673f1ac29..37cd670f3002 100644
--- a/www/interchange/Makefile
+++ b/www/interchange/Makefile
@@ -3,12 +3,12 @@
PORTNAME= interchange
PORTVERSION= 5.6.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www perl5
MASTER_SITES= http://ftp.icdevgroup.org/interchange/5.6/tar/
MAINTAINER= ports@FreeBSD.org
-COMMENT= RedHat's database-enabled e-commerce server
+COMMENT= RedHat\'s database-enabled e-commerce server
RUN_DEPENDS= p5-Safe-Hole>=0.10:${PORTSDIR}/security/p5-Safe-Hole \
p5-URI>=1.37:${PORTSDIR}/net/p5-URI \
@@ -31,18 +31,27 @@ USE_RC_SUBR= interchange
INTERCH_PREFIX= ${PREFIX}/interchange
-CONFIGURE_ARGS= INTERCHANGE_USER=interch \
- force=1
-MAKE_ARGS= INSTALLARCHLIB=${INTERCH_PREFIX} \
- INSTALLPRIVLIB=${INTERCH_PREFIX}/lib \
- INSTALLMAN1DIR=${PREFIX}/man/man1 \
- NOCPANINSTALL=1
+# Basically the parts of CONFIGURE_ARGS that interest us without
+# Uses/perl5.mk's overriding of PREFIX, INSTALLARCHLIB and INSTALLPRIVLIB,
+# since we install into a custom location.
+INTERCH_CONFIGURE_ARGS= INSTALLDIRS=site \
+ INTERCHANGE_USER=interch \
+ PREFIX=${INTERCH_PREFIX} \
+ force=1
+MAKE_ARGS= NOCPANINSTALL=1
pre-install:
# This directory must exist before the installation happens, otherwise _uid (a
# file) will be copied to a file called ${STAGEDIR}${INTERCH_PREFIX}.
${MKDIR} ${STAGEDIR}${INTERCH_PREFIX}
+do-configure:
+# The same as the do-configure stage in Uses/perl5.mk, except we use
+# INTERCH_CONFIGURE_ARGS instead of CONFIGURE_ARGS.
+ @cd ${CONFIGURE_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} \
+ ${PERL5} ./${CONFIGURE_SCRIPT} ${INTERCH_CONFIGURE_ARGS}
+
post-install:
# This directory has to be created here for check-plist to pass, otherwise it
# complains the @dirrmtry /var/run/interchange entry does not have a matching