aboutsummaryrefslogtreecommitdiff
path: root/www/kf5-kdewebkit
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-08 22:14:10 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-09 17:36:35 +0000
commitc0f139b89306c012b33bdd4d676b107305ba3e06 (patch)
tree02588523ca26bd83647873708e04d2c1bdd56495 /www/kf5-kdewebkit
parentba93bcdc15399175b77e3ae109a6ed37807b1364 (diff)
downloadports-c0f139b89306c012b33bdd4d676b107305ba3e06.tar.gz
ports-c0f139b89306c012b33bdd4d676b107305ba3e06.zip
*/kf5-*: (KDE Frameworks) lighten dependencies
- ECM (extra-cmake-modules) is only ever a build-dep and was missing in some places where it was previously pulled in implicitly - Qt testlib is only a build-dep While here - conventionally, the _build and _run items in USE_KDE and USE_QT are sorted to the end, and they start a new line in the Makefile - remove tcberner's created-line (confirmed on IRC) - use DISTVERSION everywhere - reduce inter-framework dependencies using the tooling proposed by tcberner in https://reviews.freebsd.org/D27304 Some PORTREVISION may have jumped by more than 1, since this commit is a squash of a long string of updates where I may have bumped a port once for ecm_build, and a second time for other lightening-up.
Diffstat (limited to 'www/kf5-kdewebkit')
-rw-r--r--www/kf5-kdewebkit/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/www/kf5-kdewebkit/Makefile b/www/kf5-kdewebkit/Makefile
index e93cc5912b43..1816995dbb38 100644
--- a/www/kf5-kdewebkit/Makefile
+++ b/www/kf5-kdewebkit/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kdewebkit
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= www kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -7,9 +8,10 @@ COMMENT= KF5 library providing integration of QtWebKit
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons \
- ecm i18n jobwidgets kio parts service sonnet textwidgets \
- wallet widgetsaddons xmlgui
-USE_QT= buildtools_build concurrent core dbus gui network qmake_build webkit \
- widgets xml
+ i18n jobwidgets kio parts service sonnet textwidgets \
+ wallet widgetsaddons xmlgui \
+ ecm_build
+USE_QT= concurrent core dbus gui network webkit widgets xml \
+ buildtools_build qmake_build
.include <bsd.port.mk>