aboutsummaryrefslogtreecommitdiff
path: root/www/libapreq2
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2007-10-03 10:14:17 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2007-10-03 10:14:17 +0000
commit904832cafe4c01cad2f731e3ecc0003ef2779f48 (patch)
treed3a154df9be85553911a42bfcc6f307d6f48c4c4 /www/libapreq2
parent70b842c6a99369d51882863432739ba76efe9079 (diff)
downloadports-904832cafe4c01cad2f731e3ecc0003ef2779f48.tar.gz
ports-904832cafe4c01cad2f731e3ecc0003ef2779f48.zip
Merge back changes from 1.2 which were lost with the recent autoconf changes.
Approved by: linimon
Notes
Notes: svn path=/head/; revision=200723
Diffstat (limited to 'www/libapreq2')
-rw-r--r--www/libapreq2/files/patch-glue-perl-Makefile.PL29
1 files changed, 24 insertions, 5 deletions
diff --git a/www/libapreq2/files/patch-glue-perl-Makefile.PL b/www/libapreq2/files/patch-glue-perl-Makefile.PL
index 04c6c6233788..2e6a571fc098 100644
--- a/www/libapreq2/files/patch-glue-perl-Makefile.PL
+++ b/www/libapreq2/files/patch-glue-perl-Makefile.PL
@@ -1,17 +1,36 @@
---- glue/perl/Makefile.PL.orig 2006-08-08 21:26:45.000000000 -0700
-+++ glue/perl/Makefile.PL 2007-09-22 20:12:05.000000000 -0700
-@@ -71,2 +71,3 @@
+--- glue/perl/Makefile.PL.orig Wed Aug 9 06:26:45 2006
++++ glue/perl/Makefile.PL Wed Oct 3 11:48:26 2007
+@@ -69,6 +69,7 @@
+ $config =~ /^s,\@APR_INCLUDES\@,([^,]+)/m or
+ die "Can't find apache include directory";
$apache_includes .= " $1";
+ $apache_includes =~ s,\|\#_!!_\#\|,,g;
-@@ -84,3 +85,3 @@
+ # $config =~ m/^s,\@APR_LDFLAGS\@,([^,]+)/m or
+ # die "Can't find apr ldflags";
+@@ -82,12 +83,11 @@
+
+ $config =~ m/^s,\@APREQ_LIBNAME\@,([^,]+)/m or
die "Can't find apreq libname";
- $apreq_libname = $1;
+ $apreq_libname = $1; $apreq_libname =~ s,^\|\#_!!_\#\|,,;
-@@ -88,4 +89,3 @@
+ $config =~ m/^s,\@PACKAGE_VERSION\@,([^,]+)/m or
die "Can't find package version";
- $version = $1;
-
+ $version = $1; $version =~ s,^\|\#_!!_\#\|,,;
}
+
+ my $apreq_libs = WIN32 ?
+@@ -415,8 +415,8 @@
+ 'NAME' => '$class',
+ 'VERSION' => '$version',
+ 'TYPEMAPS' => [qw(@$mp2_typemaps $typemap)],
+- 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes",
+- 'LIBS' => "$apreq_libs $apr_libs",
++ 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes -I\\\$(PREFIX)/%%APACHEINCLUDEDIR%%/modules/perl",
++ 'LIBS' => "$apreq_libs $apr_libs -L\\\$(PREFIX)/lib",
+ } ;
+ $txt .= "'depend' => $deps,\n" if ($deps) ;
+ $txt .= qq{