aboutsummaryrefslogtreecommitdiff
path: root/www/libecap/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-02-24 00:10:06 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-02-24 00:10:06 +0000
commit9b4627929caeb7f98d1755121bf8149070e3f0e5 (patch)
treeb32d681f45732c0f7fd1d73a3bbcfb5a32d76c35 /www/libecap/Makefile
parentf44bea615ce0c8551f2daf7fa7eff6e2d6222085 (diff)
downloadports-9b4627929caeb7f98d1755121bf8149070e3f0e5.tar.gz
ports-9b4627929caeb7f98d1755121bf8149070e3f0e5.zip
Notes
Diffstat (limited to 'www/libecap/Makefile')
-rw-r--r--www/libecap/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/www/libecap/Makefile b/www/libecap/Makefile
index f8cbf17c53a3..13636cd132ac 100644
--- a/www/libecap/Makefile
+++ b/www/libecap/Makefile
@@ -3,29 +3,30 @@
PORTNAME= libecap
PORTVERSION= 0.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www security
MASTER_SITES= http://www.measurement-factory.com/tmp/ecap/
MAINTAINER= tmseck@FreeBSD.org
COMMENT= Library for module based network content analysis
+LICENSE= BSD2CLAUSE
+
+OPTIONS_DEFINE= DOCS
+
+USES= libtool
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GCC= 4.2+
-
-LICENSE= BSD
-LICENSE_FILE= ${WRKSRC}/LICENSE
+USE_GCC= any
+INSTALL_TARGET= install-strip
PORTDOCS= CREDITS LICENSE NOTICE README
CONFIGURE_ARGS+=--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>