aboutsummaryrefslogtreecommitdiff
path: root/www/libjwt/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2016-09-23 06:08:42 +0000
committerKevin Lo <kevlo@FreeBSD.org>2016-09-23 06:08:42 +0000
commit4af9a265b315473704e2d7d9faed8d86e953c50b (patch)
treea9ea8ffabd4270f28607646f83a2c7d9b2c1b6d9 /www/libjwt/Makefile
parent7217d1a248e6e1984dd2e36c0815139003dfef66 (diff)
downloadports-4af9a265b315473704e2d7d9faed8d86e953c50b.tar.gz
ports-4af9a265b315473704e2d7d9faed8d86e953c50b.zip
Notes
Diffstat (limited to 'www/libjwt/Makefile')
-rw-r--r--www/libjwt/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/libjwt/Makefile b/www/libjwt/Makefile
new file mode 100644
index 000000000000..5e92683dd0d7
--- /dev/null
+++ b/www/libjwt/Makefile
@@ -0,0 +1,27 @@
+# Created by: Kevin Lo <kevlo@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libjwt
+PORTVERSION= 1.3.1
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= JSON Web Token implementation in C
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING.LIB
+
+LIB_DEPENDS= libcheck.so:devel/libcheck \
+ libjansson.so:devel/jansson
+
+USE_GITHUB= yes
+GH_ACCOUNT= benmcollins
+
+USES= libtool pkgconfig ssl
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-openssl=${OPENSSLBASE}
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>