aboutsummaryrefslogtreecommitdiff
path: root/www/libnghttp2/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 23:22:34 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 23:43:45 +0000
commit0c5c50aacfb407a93575f2f104523055f4c839fa (patch)
tree4e7e81bfe3a1ab74e694c6de4b00a86eef11ec72 /www/libnghttp2/Makefile
parent19497bfc4c10a4b7124fe94a82ee8348b2d3bf1a (diff)
downloadports-0c5c50aacfb407a93575f2f104523055f4c839fa.tar.gz
ports-0c5c50aacfb407a93575f2f104523055f4c839fa.zip
Diffstat (limited to 'www/libnghttp2/Makefile')
-rw-r--r--www/libnghttp2/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/www/libnghttp2/Makefile b/www/libnghttp2/Makefile
index e9e7c1cbaef6..4f4f4911e5d8 100644
--- a/www/libnghttp2/Makefile
+++ b/www/libnghttp2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= nghttp2
-DISTVERSION= 1.52.0
+PORTVERSION= 1.53.0
CATEGORIES= www net
-MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
+MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
@@ -11,12 +11,12 @@ WWW= https://nghttp2.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
-USE_LDCONFIG= yes
+USES= compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
-CMAKE_OFF= ENABLE_DOC \
- ENABLE_HTTP3
-CMAKE_ON= ENABLE_LIB_ONLY \
- ENABLE_STATIC_LIB
+CONFIGURE_ARGS= --enable-lib-only
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_CXXSTD= c++14
+USE_LDCONFIG= yes
.include <bsd.port.mk>