aboutsummaryrefslogtreecommitdiff
path: root/www/libnghttp2
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-31 16:30:37 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-31 16:39:52 +0000
commit173bceae508309f9d688abcb984eb1c3bfdb5063 (patch)
treedde4f7cbbdfd9b0d357d49b9ea334050311e014c /www/libnghttp2
parentd5bb4d46846e390d8763c18640d9e81eea3aa9a6 (diff)
downloadports-173bceae508309f9d688abcb984eb1c3bfdb5063.tar.gz
ports-173bceae508309f9d688abcb984eb1c3bfdb5063.zip
Diffstat (limited to 'www/libnghttp2')
-rw-r--r--www/libnghttp2/Makefile30
-rw-r--r--www/libnghttp2/distinfo2
-rw-r--r--www/libnghttp2/files/patch-CMakeLists.txt20
-rw-r--r--www/libnghttp2/files/patch-Makefile.in16
4 files changed, 28 insertions, 40 deletions
diff --git a/www/libnghttp2/Makefile b/www/libnghttp2/Makefile
index 8e821abe0472..41e571e46bbd 100644
--- a/www/libnghttp2/Makefile
+++ b/www/libnghttp2/Makefile
@@ -1,32 +1,24 @@
PORTNAME= nghttp2
-DISTVERSION= 1.55.1
+PORTVERSION= 1.55.1
+PORTREVISION= 1
CATEGORIES= www net
-MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
+MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= HTTP/2.0 C Library
-WWW= https://nghttp2.org/
+WWW= https://nghttp2.org/ \
+ https://github.com/nghttp2/nghttp2
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake compiler:c++14-lang cpe pathfix pkgconfig tar:xz
-USE_LDCONFIG= yes
+USES= compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
-CMAKE_OFF= ENABLE_DOC \
- ENABLE_FAILMALLOC \
- ENABLE_HTTP3
-CMAKE_ON= ENABLE_LIB_ONLY \
- ENABLE_STATIC_LIB \
- CMAKE_DISABLE_FIND_PACKAGE_Jansson \
- CMAKE_DISABLE_FIND_PACKAGE_Jemalloc \
- CMAKE_DISABLE_FIND_PACKAGE_Libcares \
- CMAKE_DISABLE_FIND_PACKAGE_Libev \
- CMAKE_DISABLE_FIND_PACKAGE_Libevent \
- CMAKE_DISABLE_FIND_PACKAGE_Libnghttp3 \
- CMAKE_DISABLE_FIND_PACKAGE_Libngtcp2 \
- CMAKE_DISABLE_FIND_PACKAGE_Libngtcp2_crypto_openssl \
- CMAKE_DISABLE_FIND_PACKAGE_LibXml2
+CONFIGURE_ARGS= --enable-lib-only
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_CXXSTD= c++14
+USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/www/libnghttp2/distinfo b/www/libnghttp2/distinfo
index 5c2a011d8ae6..fbc587139d05 100644
--- a/www/libnghttp2/distinfo
+++ b/www/libnghttp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1689456353
+TIMESTAMP = 1689398795
SHA256 (nghttp2-1.55.1.tar.xz) = 19490b7c8c2ded1cf7c3e3a54ef4304e3a7876ae2d950d60a81d0dc6053be419
SIZE (nghttp2-1.55.1.tar.xz) = 1541884
diff --git a/www/libnghttp2/files/patch-CMakeLists.txt b/www/libnghttp2/files/patch-CMakeLists.txt
deleted file mode 100644
index 9eb3864499c1..000000000000
--- a/www/libnghttp2/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,20 +0,0 @@
---- CMakeLists.txt.orig 2022-12-24 08:18:29 UTC
-+++ CMakeLists.txt
-@@ -503,7 +503,7 @@ include_directories(
- set(PKGDATADIR "${CMAKE_INSTALL_FULL_DATADIR}/${CMAKE_PROJECT_NAME}")
- set(PKGLIBDIR "${CMAKE_INSTALL_FULL_LIBDIR}/${CMAKE_PROJECT_NAME}")
-
--install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
-+#install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
-
- add_subdirectory(lib)
- #add_subdirectory(lib/includes)
-@@ -519,7 +519,7 @@ if(ENABLE_DOC)
- add_subdirectory(doc)
- endif()
- add_subdirectory(contrib)
--add_subdirectory(script)
-+#add_subdirectory(script)
- add_subdirectory(bpf)
-
-
diff --git a/www/libnghttp2/files/patch-Makefile.in b/www/libnghttp2/files/patch-Makefile.in
new file mode 100644
index 000000000000..d4174dca7bda
--- /dev/null
+++ b/www/libnghttp2/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- Makefile.in.orig 2023-02-13 12:02:52 UTC
++++ Makefile.in
+@@ -448,11 +448,10 @@ top_srcdir = @top_srcdir@
+ # LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+ # OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+ # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+-SUBDIRS = lib third-party src bpf examples tests integration-tests \
+- doc contrib script
++SUBDIRS = lib
+
+ ACLOCAL_AMFLAGS = -I m4
+-dist_doc_DATA = README.rst
++dist_doc_DATA =
+ EXTRA_DIST = nghttpx.conf.sample proxy.pac.sample android-config android-env \
+ Dockerfile.android \
+ cmakeconfig.h.in \