aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-05-09 20:06:42 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-05-09 20:06:42 +0000
commit4b7b0c6d526683fb370aff150e67263f456148e6 (patch)
treea7d787cf638a2b3816777dd20ea98afe4b098d9a /www/lighttpd
parentc42ea9673625a08451314ccd2931fcca965aa138 (diff)
downloadports-4b7b0c6d526683fb370aff150e67263f456148e6.tar.gz
ports-4b7b0c6d526683fb370aff150e67263f456148e6.zip
www/lighttpd: fix WEBDAV option
It looks like it was missed in cmake migration.
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 46d3a7ba347b..a4e18618dd76 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -80,6 +80,10 @@ NSS_LIB_DEPENDS= libnss3.so:security/nss
OPENSSL_USES= ssl
OPENSSL_CMAKE_BOOL= WITH_OPENSSL
SPAWNFCGI_RUN_DEPENDS= spawn-fcgi:www/spawn-fcgi
+WEBDAV_CMAKE_BOOL= WITH_WEBDAV_LOCKS \
+ WITH_WEBDAV_PROPS
+WEBDAV_LIB_DEPENDS= libxml2.so:textproc/libxml2 \
+ libsqlite3.so:databases/sqlite3
WOLFSSL_CMAKE_BOOL= WITH_WOLFSSL
WOLFSSL_LIB_DEPENDS= libwolfssl.so:security/wolfssl
ZSTD_CMAKE_BOOL= WITH_ZSTD