aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2016-12-26 20:45:42 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2016-12-26 20:45:42 +0000
commit557416713cfd738fe8415c1a9657b17f981ceec3 (patch)
treefeaf6623a3f3734e45fcd0eb1b6c5a09eacf39f3 /www/lighttpd
parenta6698662a22f83e483d280ba9ce886c5daae2cf5 (diff)
downloadports-557416713cfd738fe8415c1a9657b17f981ceec3.tar.gz
ports-557416713cfd738fe8415c1a9657b17f981ceec3.zip
www/lighttpd: Update to version 1.4.44.
- Removed mod_cgi patch, because upstream now correctly recognizes when pipe(2) isn't available. While here, modernize and simplify. - Use OPT_ when possible. - Remove variables that are not referenced or only referenced once. PR: 215536 Submitted by: pkubaj@anongoth.pl (maintainer) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D8900
Notes
Notes: svn path=/head/; revision=429570
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile51
-rw-r--r--www/lighttpd/distinfo6
-rw-r--r--www/lighttpd/files/patch-src_mod__cgi.c13
-rw-r--r--www/lighttpd/pkg-plist2
4 files changed, 19 insertions, 53 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 223297105ba4..616f91013f97 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME?= lighttpd
-PORTVERSION= 1.4.43
-PORTREVISION= 2
+PORTVERSION= 1.4.44
CATEGORIES?= www
MASTER_SITES?= http://download.lighttpd.net/lighttpd/releases-1.4.x/
@@ -29,7 +28,10 @@ CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/lighttpd
INSTALL_TARGET= install-strip
.if !defined(_BUILDING_LIGHTTPD_MODULE)
+PORTDOCS= AUTHORS COPYING INSTALL NEWS README
+
USE_RC_SUBR= lighttpd
+REQUIRE= DAEMON
OPTIONS_DEFINE= ATTR BZIP2 DOCS FAM GDBM GEOIP IPV6 KRB5 LIBEV LUA MEMCACHED \
MYSQL LDAP OPENSSL SPAWNFCGI VALGRIND WEBDAV
@@ -65,6 +67,9 @@ KRB5_CPPFLAGS= ${GSSAPICPPFLAGS}
KRB5_LDFLAGS= ${GSSAPILDFLAGS}
KRB5_LIBS= ${GSSAPILIBS}
KRB5_USES= gssapi:mit
+LDAP_CONFIGURE_WITH= ldap
+LDAP_USE= openldap=yes
+LDAP_VARS= REQUIRE+=slapd
LIBEV_CONFIGURE_WITH= libev=${LOCALBASE}
LIBEV_LIB_DEPENDS= libev.so:devel/libev
LUA_USES= lua
@@ -72,6 +77,9 @@ LUA_CONFIGURE_WITH= lua
LUA_CONFIGURE_ENV= LUA_CFLAGS="-I${LUA_INCDIR}" LUA_LIBS="-L${LUA_LIBDIR} -llua-${LUA_VER}"
MEMCACHED_LIB_DEPENDS= libmemcached.so:databases/libmemcached
MEMCACHED_CONFIGURE_WITH=memcached
+MYSQL_CONFIGURE_WITH= mysql
+MYSQL_USES= mysql
+MYSQL_VARS= REQUIRE+=mysql
OPENSSL_USES= ssl
OPENSSL_CONFIGURE_WITH= openssl
OPENSSL_CONFIGURE_ON= --with-openssl-includes=${OPENSSLINC} --with-openssl-libs=${OPENSSLLIB}
@@ -95,43 +103,16 @@ LIGHTTPD_CONF_D_FILES= access_log.conf \
simple_vhost.conf ssi.conf status.conf \
trigger_b4_dl.conf userdir.conf webdav.conf
-LIGHTTPD_LOGROOT?= /var/log/lighttpd
-LIGHTTPD_WEBROOT?= ${PREFIX}/www/data
-LIGHTTPD_USER?= www
-LIGHTTPD_GROUP?= www
-
-PLIST_SUB+= LOGROOT="${LIGHTTPD_LOGROOT}" \
- USER="${LIGHTTPD_USER}" \
- GROUP="${LIGHTTPD_GROUP}" \
- MKDIR="${MKDIR}" \
- CHOWN="${CHOWN}"
+LOGROOT= /var/log/lighttpd
+PLIST_SUB= LOGROOT="${LOGROOT}"
.endif # !defined(_BUILDING_LIGHTTPD_MODULE)
.include <bsd.port.options.mk>
.if !defined(_BUILDING_LIGHTTPD_MODULE)
-# Default REQUIRE to rc.d script
-_REQUIRE= DAEMON
-
-.if ${PORT_OPTIONS:MDOCS}
-DOCS= AUTHORS COPYING INSTALL NEWS README
-PORTDOCS= ${DOCS}
-.endif
-
-.if ${PORT_OPTIONS:MMYSQL}
-USES+= mysql
-CONFIGURE_ARGS+= --with-mysql
-_REQUIRE+= mysql
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-USE_OPENLDAP= yes
-CONFIGURE_ARGS+= --with-ldap
-_REQUIRE+= slapd
-.endif
-SUB_LIST+= REQUIRE="${_REQUIRE}"
+SUB_LIST= REQUIRE="${REQUIRE}"
post-patch:
@${REINPLACE_CMD} -e 's|-std=gnu99||' \
@@ -170,13 +151,11 @@ post-install:
.endfor
${INSTALL_DATA} ${WRKSRC}/doc/config/vhosts.d/vhosts.template \
${STAGEDIR}${PREFIX}/etc/lighttpd/vhosts.d/vhosts.template
- @${MKDIR} -m 0700 ${STAGEDIR}${LIGHTTPD_LOGROOT}
+ @${MKDIR} -m 0700 ${STAGEDIR}${LOGROOT}
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-. for FILE in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}/${FILE}
-. endfor
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
test: build
@cd ${WRKSRC}/tests && ${SETENV} ${MAKE_ENV} ${MAKE} \
diff --git a/www/lighttpd/distinfo b/www/lighttpd/distinfo
index 42ef63be8933..8493215f1339 100644
--- a/www/lighttpd/distinfo
+++ b/www/lighttpd/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1477993209
-SHA256 (lighttpd-1.4.43.tar.xz) = fe0c4a06dd2408a83ee7a2bfedc45e09597f3313cbda82485507573ae8fa948a
-SIZE (lighttpd-1.4.43.tar.xz) = 656248
+TIMESTAMP = 1482580986
+SHA256 (lighttpd-1.4.44.tar.xz) = adb66ca985651957feb209c91c55ebbf917d23630bfc3a216a2f70043c7b5422
+SIZE (lighttpd-1.4.44.tar.xz) = 660304
SHA256 (lighttpd-1.4.26_mod_h264_streaming-2.2.9.patch) = 716cd4f8d371e12c115a2204e649aafe2ebad42d0099777b1361c0e2cc8a1612
SIZE (lighttpd-1.4.26_mod_h264_streaming-2.2.9.patch) = 242456
diff --git a/www/lighttpd/files/patch-src_mod__cgi.c b/www/lighttpd/files/patch-src_mod__cgi.c
deleted file mode 100644
index 1348c04026bb..000000000000
--- a/www/lighttpd/files/patch-src_mod__cgi.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/mod_cgi.c.orig 2016-10-31 13:16:40 UTC
-+++ src/mod_cgi.c
-@@ -35,8 +35,9 @@
-
- #include <stdio.h>
- #include <fcntl.h>
-+#include <sys/param.h>
-
--#if defined(O_CLOEXEC) && (!defined(__FreeBSD__) || defined(F_DUPFD_CLOEXEC))
-+#if defined(O_CLOEXEC) && (!defined(__FreeBSD__) || __FreeBSD_version >= 1000032)
- #define pipe_cloexec(pipefd) pipe2((pipefd), O_CLOEXEC)
- #elif defined FD_CLOEXEC
- #define pipe_cloexec(pipefd) \
diff --git a/www/lighttpd/pkg-plist b/www/lighttpd/pkg-plist
index c5d3824363a1..197ef4631c38 100644
--- a/www/lighttpd/pkg-plist
+++ b/www/lighttpd/pkg-plist
@@ -67,4 +67,4 @@ man/man8/lighttpd.8.gz
%%KRB5%%man/man8/lighttpd-angel.8.gz
sbin/lighttpd
sbin/lighttpd-angel
-@dir(%%USER%%,%%GROUP%%,700) %%LOGROOT%%
+@dir(www,www,700) %%LOGROOT%%