aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2013-09-28 08:20:40 +0000
committerMartin Matuska <mm@FreeBSD.org>2013-09-28 08:20:40 +0000
commitbda237617bdfe266f40601e915ff5c176d1ab13d (patch)
tree1560b7502629ea367b216592bb0b9fbfd86b2a8d /www/lighttpd
parent69f2f43a9b2ccd47ebd6c1e19ca57289691bd725 (diff)
downloadports-bda237617bdfe266f40601e915ff5c176d1ab13d.tar.gz
ports-bda237617bdfe266f40601e915ff5c176d1ab13d.zip
Notes
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile11
-rw-r--r--www/lighttpd/distinfo5
-rw-r--r--www/lighttpd/files/extra-patch-remoteuser64
3 files changed, 5 insertions, 75 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 20af0dede7d9..65125cb4d373 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME?= lighttpd
-PORTVERSION= 1.4.32
-PORTREVISION= 1
+PORTVERSION= 1.4.33
CATEGORIES?= www
MASTER_SITES?= http://download.lighttpd.net/lighttpd/releases-1.4.x/
@@ -41,7 +40,7 @@ USE_RC_SUBR= lighttpd
MAN8= lighttpd.8
OPTIONS_DEFINE= BZIP2 FAM GDBM IPV6 LIBEV LUA MEMCACHE MYSQL MYSQLAUTH \
- NODELAY LDAP OPENSSL SPAWNFCGI VALGRIND WEBDAV REMOTEUSER
+ NODELAY LDAP OPENSSL SPAWNFCGI VALGRIND WEBDAV
OPTIONS_DEFAULT= IPV6 OPENSSL
@@ -56,7 +55,6 @@ NODELAY_DESC= Set TCP_NODELAY on listening sockets
SPAWNFCGI_DESC= Depend on spawn-fcgi utility
VALGRIND_DESC= valgrind support
WEBDAV_DESC= WebDAV support
-REMOTEUSER_DESC= Add remote-user to conditionals
LIGHTTPD_CONF_FILES= lighttpd.conf modules.conf
@@ -178,11 +176,6 @@ LIB_DEPENDS+= uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid \
CONFIGURE_ARGS+= --with-webdav-props --with-webdav-locks
.endif
-# 3rd party remoteuser patch (lighttpd feature request #2415)
-.if ${PORT_OPTIONS:MREMOTEUSER}
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-remoteuser
-.endif
-
SUB_LIST+= REQUIRE="${_REQUIRE}"
post-patch:
diff --git a/www/lighttpd/distinfo b/www/lighttpd/distinfo
index ac8aec665e16..d5dabdf00f52 100644
--- a/www/lighttpd/distinfo
+++ b/www/lighttpd/distinfo
@@ -1,6 +1,7 @@
-SHA256 (lighttpd-1.4.32.tar.bz2) = 60691b2dcf3ad2472c06b23d75eb0c164bf48a08a630ed3f308f61319104701f
-SIZE (lighttpd-1.4.32.tar.bz2) = 681065
+SHA256 (lighttpd-1.4.33.tar.bz2) = 2ff2324658c0f90e7d39afd40f08f11ca230903b9019c31a2bbecd8f087f235e
+SIZE (lighttpd-1.4.33.tar.bz2) = 664850
SHA256 (lighttpd-1.4.26_mod_h264_streaming-2.2.9.patch.gz) = d7c3704d5253c4f3c18459f89059063b311e50096cd2c38fc982cec683c32e61
SIZE (lighttpd-1.4.26_mod_h264_streaming-2.2.9.patch.gz) = 44695
SHA256 (lighttpd-1.4.26_mod_geoip.patch.gz) = db43cc0ed7c808b5eed3185d97346e70dea0f1ef4fa9ed436d08e4faff7f97e7
SIZE (lighttpd-1.4.26_mod_geoip.patch.gz) = 3267
+
diff --git a/www/lighttpd/files/extra-patch-remoteuser b/www/lighttpd/files/extra-patch-remoteuser
deleted file mode 100644
index 18bd6faf569d..000000000000
--- a/www/lighttpd/files/extra-patch-remoteuser
+++ /dev/null
@@ -1,64 +0,0 @@
-diff -urN src/array.h src/array.h
---- src/array.h 2010-02-01 18:28:20.000000000 -0500
-+++ src/array.h 2012-04-22 13:25:16.000000000 -0400
-@@ -96,6 +96,7 @@
- COMP_HTTP_QUERY_STRING,
- COMP_HTTP_SCHEME,
- COMP_HTTP_REQUEST_METHOD,
-+ COMP_HTTP_REMOTE_USER,
-
- COMP_LAST_ELEMENT
- } comp_key_t;
-diff -urN src/configfile-glue.c src/configfile-glue.c
---- src/configfile-glue.c 2010-08-17 05:04:38.000000000 -0400
-+++ src/configfile-glue.c 2012-04-22 13:25:16.000000000 -0400
-@@ -455,6 +455,14 @@
- }
- break;
- }
-+ case COMP_HTTP_REMOTE_USER: {
-+ if (NULL != con->authed_user) {
-+ l = con->authed_user;
-+ } else {
-+ l = srv->empty_string;
-+ }
-+ break;
-+ }
- default:
- return COND_RESULT_FALSE;
- }
-diff -urN src/configparser.c src/configparser.c
---- src/configparser.c 2011-12-18 09:54:21.000000000 -0500
-+++ src/configparser.c 2012-04-22 13:25:16.000000000 -0400
-@@ -1221,6 +1221,8 @@
- { COMP_HTTP_QUERY_STRING, CONST_STR_LEN("HTTP[\"query-string\"]") },
- { COMP_HTTP_REQUEST_METHOD, CONST_STR_LEN("HTTP[\"request-method\"]") },
- { COMP_HTTP_SCHEME, CONST_STR_LEN("HTTP[\"scheme\"]" ) },
-+ { COMP_HTTP_REMOTE_USER, CONST_STR_LEN("HTTP[\"remoteuser\"]" ) },
-+ { COMP_HTTP_REMOTE_USER, CONST_STR_LEN("HTTP[\"remote-user\"]" ) },
- { COMP_UNSET, NULL, 0 },
- };
- size_t i;
-diff -urN src/configparser.y src/configparser.y
---- src/configparser.y 2010-02-01 18:28:20.000000000 -0500
-+++ src/configparser.y 2012-04-22 13:25:16.000000000 -0400
-@@ -435,6 +435,8 @@
- { COMP_HTTP_QUERY_STRING, CONST_STR_LEN("HTTP[\"query-string\"]") },
- { COMP_HTTP_REQUEST_METHOD, CONST_STR_LEN("HTTP[\"request-method\"]") },
- { COMP_HTTP_SCHEME, CONST_STR_LEN("HTTP[\"scheme\"]" ) },
-+ { COMP_HTTP_REMOTE_USER, CONST_STR_LEN("HTTP[\"remoteuser\"]" ) },
-+ { COMP_HTTP_REMOTE_USER, CONST_STR_LEN("HTTP[\"remote-user\"]" ) },
- { COMP_UNSET, NULL, 0 },
- };
- size_t i;
-diff -urN src/response.c src/response.c
---- src/response.c 2010-08-17 05:04:38.000000000 -0400
-+++ src/response.c 2012-04-22 13:25:30.000000000 -0400
-@@ -280,6 +280,7 @@
- config_patch_connection(srv, con, COMP_HTTP_LANGUAGE); /* Accept-Language: */
- config_patch_connection(srv, con, COMP_HTTP_COOKIE); /* Cookie: */
- config_patch_connection(srv, con, COMP_HTTP_REQUEST_METHOD); /* REQUEST_METHOD */
-+ config_patch_connection(srv, con, COMP_HTTP_REMOTE_USER); /* REMOTE_USER */
-
- /** their might be a fragment which has to be cut away */
- if (NULL != (qstr = strchr(con->request.uri->ptr, '#'))) {