aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-11-03 16:14:10 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-11-03 16:14:10 +0000
commitfa7be879273c1b2cfd7a35b3157680b4164143d7 (patch)
tree58fe6c1e7db98ac6a808b5a8bed95fc3a60f7761 /www/lighttpd
parent16df9d66691008f653a6b11048b94c0f8ac1f7b8 (diff)
downloadports-fa7be879273c1b2cfd7a35b3157680b4164143d7.tar.gz
ports-fa7be879273c1b2cfd7a35b3157680b4164143d7.zip
- Modify patch to check is we are on FreeBSD before checking
__FreeBSD_version. [1] - Explicitly include param.h Suggested by: marino@ [1]
Notes
Notes: svn path=/head/; revision=425245
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile2
-rw-r--r--www/lighttpd/files/patch-src_mod__cgi.c10
2 files changed, 7 insertions, 5 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 39dc81db39eb..223297105ba4 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= lighttpd
PORTVERSION= 1.4.43
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= www
MASTER_SITES?= http://download.lighttpd.net/lighttpd/releases-1.4.x/
diff --git a/www/lighttpd/files/patch-src_mod__cgi.c b/www/lighttpd/files/patch-src_mod__cgi.c
index 8561d57d65d3..1348c04026bb 100644
--- a/www/lighttpd/files/patch-src_mod__cgi.c
+++ b/www/lighttpd/files/patch-src_mod__cgi.c
@@ -1,11 +1,13 @@
---- src/mod_cgi.c.orig 2016-11-02 13:53:21 UTC
+--- src/mod_cgi.c.orig 2016-10-31 13:16:40 UTC
+++ src/mod_cgi.c
-@@ -36,7 +36,7 @@
+@@ -35,8 +35,9 @@
+
#include <stdio.h>
#include <fcntl.h>
-
++#include <sys/param.h>
+
-#if defined(O_CLOEXEC) && (!defined(__FreeBSD__) || defined(F_DUPFD_CLOEXEC))
-+#if defined(O_CLOEXEC) && __FreeBSD_version >= 1000032
++#if defined(O_CLOEXEC) && (!defined(__FreeBSD__) || __FreeBSD_version >= 1000032)
#define pipe_cloexec(pipefd) pipe2((pipefd), O_CLOEXEC)
#elif defined FD_CLOEXEC
#define pipe_cloexec(pipefd) \