aboutsummaryrefslogtreecommitdiff
path: root/www/linux-opera/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-08-03 00:38:32 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-08-03 00:38:32 +0000
commitee6cb7774c1148951783a791cbf199ab0225e284 (patch)
treea0704b75323a7146874503d693f9ef48c2e61299 /www/linux-opera/Makefile
parent8daf64e0f0c9e5a7b57b072c5178b4c3e4a86f41 (diff)
downloadports-ee6cb7774c1148951783a791cbf199ab0225e284.tar.gz
ports-ee6cb7774c1148951783a791cbf199ab0225e284.zip
Notes
Diffstat (limited to 'www/linux-opera/Makefile')
-rw-r--r--www/linux-opera/Makefile49
1 files changed, 16 insertions, 33 deletions
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index 81014e9ecace..707758b15a91 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -7,58 +7,41 @@
PORTNAME= opera
PORTVERSION= ${OPERA_VER}.${OPERA_DATE}
-PORTREVISION= 2
CATEGORIES= www linux
-MASTER_SITES= ftp://ftp.opera.com/pub/opera/linux/${OPERA_VER:S/.//}0/final/en/i386/static/ \
- ftp://ftp.sunet.se/pub/www/clients/Opera/linux/${OPERA_VER:S/.//}0/final/en/i386/static/ \
- ftp://sunsite.cnlab-switch.ch/mirror/opera/linux/${OPERA_VER:S/.//}0/final/en/i386/static/ \
- ftp://ftp.tiscali.nl/pub/mirrors/opera/linux/${OPERA_VER:S/.//}0/final/en/i386/static/ \
- ftp://ftp.ntua.gr/pub/www/Opera/linux/${OPERA_VER:S/.//}0/final/en/i386/static/ \
- http://mirrors.pmmf.hu/mirror/opera/linux/${OPERA_VER:S/.//}0/final/en/i386/static/ \
- ftp://ftp.task.gda.pl/pub/opera/linux/${OPERA_VER:S/.//}0/final/en/i386/static/ \
- ftp://ftp.planetmirror.com/pub/opera/linux/${OPERA_VER:S/.//}0/final/en/i386/static/ \
- http://gd.tuwien.ac.at/infosys/browsers/opera/linux/${OPERA_VER:S/.//}0/final/en/i386/static/ \
- ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/www/opera/linux/${OPERA_VER:S/.//}0/final/en/i386/static/&,}
+MASTER_SITES= ftp://ftp.opera.com/pub/opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
+ ftp://ftp.sunet.se/pub/www/clients/Opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
+ ftp://sunsite.cnlab-switch.ch/mirror/opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
+ ftp://ftp.tiscali.nl/pub/mirrors/opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
+ ftp://ftp.ntua.gr/pub/www/Opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
+ http://mirrors.pmmf.hu/mirror/opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
+ ftp://ftp.task.gda.pl/pub/opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
+ ftp://ftp.planetmirror.com/pub/opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
+ http://gd.tuwien.ac.at/infosys/browsers/opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/ \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/www/opera/linux/${OPERA_VER:S/.//}/final/en/i386/static/&,}
PKGNAMEPREFIX= linux-
DISTNAME= ${PORTNAME}-${OPERA_VER}-${OPERA_DATE}.1-static-qt.i386-en
MAINTAINER= mezz@FreeBSD.org
COMMENT= A blazingly fast, full-featured, standards-compliant browser
-RUN_DEPENDS= \
- ${LINUXBASE}/usr/lib/libaspell.so.15:${PORTSDIR}/textproc/linux-aspell
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libaspell.so.15:${PORTSDIR}/textproc/linux-aspell
WRKSRC= ${WRKDIR}/${DISTNAME}-${OPERA_BUILD}
+USE_XLIB= yes
USE_BZIP2= yes
-WANT_GNOME= yes
USE_LINUX= yes
-USE_X_PREFIX= yes
ONLY_FOR_ARCHS= i386 amd64
NO_BUILD= yes
-OPERA_VER= 9.0
-OPERA_DATE= 20060616
-OPERA_BUILD= 344
+OPERA_VER= 9.01
+OPERA_DATE= 20060728
+OPERA_BUILD= 400
DATADIR= ${PREFIX}/share/${UNIQUENAME}
DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
MAN1= linux-opera.1
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_GNOME:Mgnomehier}!=""
-PLIST_SUB+= GNOME:=""
-.else
-PLIST_SUB+= GNOME:="@comment "
-.endif
-
-.if exists(${LOCALBASE}/bin/kde-config)
-PLIST_SUB+= KDE:=""
-.else
-PLIST_SUB+= KDE:="@comment "
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%X11BASE%%|${X11BASE}|g' \
@@ -77,4 +60,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>