aboutsummaryrefslogtreecommitdiff
path: root/www/linuxpluginwrapper
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-11-13 19:35:14 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-11-13 19:35:14 +0000
commit9e8d00728d81f15cb5c2df24ce7a3639b26d587d (patch)
tree67bc8cf5f09570e75fc8d43004efc7c0404befb2 /www/linuxpluginwrapper
parent18cf29fea730d98de3b995869d189511b0d3d4b8 (diff)
downloadports-9e8d00728d81f15cb5c2df24ce7a3639b26d587d.tar.gz
ports-9e8d00728d81f15cb5c2df24ce7a3639b26d587d.zip
Notes
Diffstat (limited to 'www/linuxpluginwrapper')
-rw-r--r--www/linuxpluginwrapper/Makefile35
-rw-r--r--www/linuxpluginwrapper/distinfo1
-rw-r--r--www/linuxpluginwrapper/files/pkg-message.in19
-rw-r--r--www/linuxpluginwrapper/pkg-comment1
-rw-r--r--www/linuxpluginwrapper/pkg-descr7
-rw-r--r--www/linuxpluginwrapper/pkg-plist1
6 files changed, 64 insertions, 0 deletions
diff --git a/www/linuxpluginwrapper/Makefile b/www/linuxpluginwrapper/Makefile
new file mode 100644
index 000000000000..2ad449543a7f
--- /dev/null
+++ b/www/linuxpluginwrapper/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: flashpluginwrapper
+# Date Created: 13 November 2002
+# Whom: Pete Fritchman <petef@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flashpluginwrapper
+PORTVERSION= 0.20021113
+CATEGORIES= www linux
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://absolutbsd.org/~petef/
+MASTER_SITE_SUBDIR= petef
+
+MAINTAINER= petef@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/flash/libflashplayer.so:${PORTSDIR}/www/linux-flashplugin \
+ mozilla:${PORTSDIR}/www/mozilla
+
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},' \
+ -e 's,/usr/local,${PREFIX},' ${WRKSRC}/Makefile
+
+post-install:
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},' \
+ -e 's,%%LOCALBASE%%,${LOCALBASE},' \
+ -e 's,%%X11BASE%%,${X11BASE},' \
+ < ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/linuxpluginwrapper/distinfo b/www/linuxpluginwrapper/distinfo
new file mode 100644
index 000000000000..72d9515311c5
--- /dev/null
+++ b/www/linuxpluginwrapper/distinfo
@@ -0,0 +1 @@
+MD5 (flashpluginwrapper-0.20021113.tar.gz) = 500f35313a34e4db865104e306f48431
diff --git a/www/linuxpluginwrapper/files/pkg-message.in b/www/linuxpluginwrapper/files/pkg-message.in
new file mode 100644
index 000000000000..1e8e666ca9a2
--- /dev/null
+++ b/www/linuxpluginwrapper/files/pkg-message.in
@@ -0,0 +1,19 @@
+To use the flash plugin wrapper, you first need to copy the linux flash
+plugin into your mozilla directory:
+
+# cp %%LOCALBASE%%/lib/flash/libflashplayer.so \
+ %%X11BASE%%/lib/mozilla/plugins/libflashplayer_linux.so
+# cp %%LOCALBASE%%/lib/flash/ShockwaveFlash.class \
+ %%X11BASE%%/lib/mozilla/plugins/
+
+(Note, if you are using mozilla-devel, the destination directories will be
+different)
+
+Next, change the Mozilla startup script, %%X11BASE%%/bin/mozilla
+to have:
+
+LD_PRELOAD=%%PREFIX%%/lib/libflashplayer.so.1
+export LD_PRELOAD
+
+at the top of it (but after #!/bin/sh). Now start mozilla and go to
+'about:plugins' and the flash plugin is enabled!
diff --git a/www/linuxpluginwrapper/pkg-comment b/www/linuxpluginwrapper/pkg-comment
new file mode 100644
index 000000000000..e90b8ebc66a9
--- /dev/null
+++ b/www/linuxpluginwrapper/pkg-comment
@@ -0,0 +1 @@
+A wrapper allowing use of linux-flashplugin with native mozilla
diff --git a/www/linuxpluginwrapper/pkg-descr b/www/linuxpluginwrapper/pkg-descr
new file mode 100644
index 000000000000..e680e3ce5317
--- /dev/null
+++ b/www/linuxpluginwrapper/pkg-descr
@@ -0,0 +1,7 @@
+A wrapper that allows the use of the Linux flash plugin to work with
+a FreeBSD-native binary of mozilla.
+
+WWW: http://tmp.ninth-nine.com/FlashPluginWrapper/
+
+- Pete
+petef@FreeBSD.org
diff --git a/www/linuxpluginwrapper/pkg-plist b/www/linuxpluginwrapper/pkg-plist
new file mode 100644
index 000000000000..b0efcdfe7ec3
--- /dev/null
+++ b/www/linuxpluginwrapper/pkg-plist
@@ -0,0 +1 @@
+lib/libflashplayer.so.1