aboutsummaryrefslogtreecommitdiff
path: root/www/logtools
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2002-01-24 15:08:41 +0000
committerSADA Kenji <sada@FreeBSD.org>2002-01-24 15:08:41 +0000
commite7d263357f29c8177351d572535434653324c7ea (patch)
tree93cd573ec5cf4c703c4c7aedd85af4af9e08313a /www/logtools
parentca8c81f24a6b40e8c07663baa8dcc8d9cf7fdff8 (diff)
Notes
Diffstat (limited to 'www/logtools')
-rw-r--r--www/logtools/Makefile19
-rw-r--r--www/logtools/distinfo1
-rw-r--r--www/logtools/files/patch-aa11
-rw-r--r--www/logtools/files/patch-ab11
-rw-r--r--www/logtools/pkg-comment1
-rw-r--r--www/logtools/pkg-descr2
-rw-r--r--www/logtools/pkg-plist6
7 files changed, 51 insertions, 0 deletions
diff --git a/www/logtools/Makefile b/www/logtools/Makefile
new file mode 100644
index 000000000000..803d62842a1c
--- /dev/null
+++ b/www/logtools/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: logtools
+# Date created: 8 January 2002
+# Whom: Mark Huizer; Eindhoven
+#
+# $FreeBSD$
+#
+
+PORTNAME= logtools
+PORTVERSION= 0.13a
+CATEGORIES= www
+MASTER_SITES= http://www.coker.com.au/logtools/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= xaa+ports@timewasters.nl
+
+GNU_CONFIGURE= yes
+MAN1= clfmerge.1 logprn.1 funnel.1 clfsplit.1 clfdomainsplit.1
+
+.include <bsd.port.mk>
diff --git a/www/logtools/distinfo b/www/logtools/distinfo
new file mode 100644
index 000000000000..f2df334ecba6
--- /dev/null
+++ b/www/logtools/distinfo
@@ -0,0 +1 @@
+MD5 (logtools-0.13a.tgz) = 1314bc118a9f60ff1b349ec38f5e964b
diff --git a/www/logtools/files/patch-aa b/www/logtools/files/patch-aa
new file mode 100644
index 000000000000..396944cd5a03
--- /dev/null
+++ b/www/logtools/files/patch-aa
@@ -0,0 +1,11 @@
+--- clfmerge.cpp.orig Tue Jan 8 17:15:37 2002
++++ clfmerge.cpp Tue Jan 8 17:14:06 2002
+@@ -201,7 +201,7 @@
+ unsigned int map_items = 0;
+ bool set_map_items = false, domain_mangling = false;
+ int int_c;
+- optind = 0;
++ optind = 1;
+ while(-1 != (int_c = getopt(argc, argv, "b:hd")) )
+ {
+ switch(char(int_c))
diff --git a/www/logtools/files/patch-ab b/www/logtools/files/patch-ab
new file mode 100644
index 000000000000..3bc487017665
--- /dev/null
+++ b/www/logtools/files/patch-ab
@@ -0,0 +1,11 @@
+--- clfsplit.cpp.orig Tue Jan 8 17:41:53 2002
++++ clfsplit.cpp Tue Jan 8 17:41:18 2002
+@@ -199,7 +199,7 @@
+ MAP m;
+ FILE *input = stdin;
+ bool new_input = false;
+- optind = 0;
++ optind = 1;
+ while(-1 != (int_c = getopt(argc, argv, "d:i:f:s:")) )
+ {
+ switch(char(int_c))
diff --git a/www/logtools/pkg-comment b/www/logtools/pkg-comment
new file mode 100644
index 000000000000..5b07413c9c96
--- /dev/null
+++ b/www/logtools/pkg-comment
@@ -0,0 +1 @@
+Useful tools to deal with CLF files (Common Log File format)
diff --git a/www/logtools/pkg-descr b/www/logtools/pkg-descr
new file mode 100644
index 000000000000..44156cc55e63
--- /dev/null
+++ b/www/logtools/pkg-descr
@@ -0,0 +1,2 @@
+Tools like clfmerge, clfsplit etc to simplify working with access log files
+e.g. with virtual hosts
diff --git a/www/logtools/pkg-plist b/www/logtools/pkg-plist
new file mode 100644
index 000000000000..f7310d7be012
--- /dev/null
+++ b/www/logtools/pkg-plist
@@ -0,0 +1,6 @@
+bin/clfmerge
+bin/clfsplit
+bin/clfdomainsplit
+bin/logprn
+bin/funnel
+etc/clfdomainsplit.cfg