aboutsummaryrefslogtreecommitdiff
path: root/www/lynx-current
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2012-06-15 10:36:45 +0000
committerJohan van Selst <johans@FreeBSD.org>2012-06-15 10:36:45 +0000
commitffcd529c2a13fc2e60004667bf9884f56caad412 (patch)
tree46930c4e81d1e1f188e2c23c35094f323bd715d3 /www/lynx-current
parent26282da30cbc5cefa25976767a20a13fabeb8162 (diff)
downloadports-ffcd529c2a13fc2e60004667bf9884f56caad412.tar.gz
ports-ffcd529c2a13fc2e60004667bf9884f56caad412.zip
- Register conflict with japanese/lynx
- Use new style OPTIONS
Notes
Notes: svn path=/head/; revision=299336
Diffstat (limited to 'www/lynx-current')
-rw-r--r--www/lynx-current/Makefile24
1 files changed, 9 insertions, 15 deletions
diff --git a/www/lynx-current/Makefile b/www/lynx-current/Makefile
index 8fa97fb10f1e..ea37bb9c3ab5 100644
--- a/www/lynx-current/Makefile
+++ b/www/lynx-current/Makefile
@@ -15,17 +15,18 @@ DISTNAME= ${PORTNAME}2.8.8dev.12
MAINTAINER= johans@FreeBSD.org
COMMENT= A non-graphical, text-based World-Wide Web client
-LIB_DEPENDS= idn.17:${PORTSDIR}/dns/libidn
+LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn
RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
-CONFLICTS= lynx-2.8.[0-7].*
+CONFLICTS= lynx-2.8.[0-7].* ja-lynx-[0-9]*
WRKSRC= ${WRKDIR}/${PORTNAME}2-8-8
USE_BZIP2= yes
USE_ICONV= yes
+USE_OPENSSL= yes
NO_LATEST_LINK= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-zlib --libdir="${L_LIB}" \
+CONFIGURE_ARGS= --with-zlib --libdir="${L_LIB}" \
--enable-nsl-fork --with-bzlib \
--enable-nested-tables --enable-default-colors \
--enable-addrlist-page \
@@ -34,19 +35,12 @@ CONFIGURE_ARGS= --with-zlib --libdir="${L_LIB}" \
--enable-ipv6 \
--with-mime-libdir=${PREFIX}/etc \
--with-libiconv-prefix=${LOCALBASE} \
- --with-screen=ncursesw
+ --with-screen=ncursesw \
+ --with-ssl=${OPENSSLBASE}
MAKE_JOBS_UNSAFE= yes
-.ifndef NO_OPENSSL
-USE_OPENSSL= yes
-.endif
-
-.include <bsd.port.pre.mk>
-
-.ifdef USE_OPENSSL
-CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
-.endif
+.include <bsd.port.options.mk>
MAKE_FLAGS= helpdir=${L_HELP} docdir=${L_DOC} -f
MAKEFILE= makefile
@@ -57,7 +51,7 @@ L_LIB= ${PREFIX}/etc
L_DOC= ${PREFIX}/share/doc/lynx
L_HELP= ${PREFIX}/share/lynx_help
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
CONFIGURE_ARGS+= --enable-nls
@@ -71,4 +65,4 @@ post-install:
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${L_HELP}
${CHOWN} ${SHAREOWN}:${SHAREGRP} ${L_LIB}/lynx.cfg* ${L_LIB}/lynx.lss*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>