aboutsummaryrefslogtreecommitdiff
path: root/www/lynx
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2007-07-05 11:44:11 +0000
committerMikhail Teterin <mi@FreeBSD.org>2007-07-05 11:44:11 +0000
commite79389466a52f5cefbdd19a6c832096120e486c5 (patch)
tree0b03c9a0343a8bc18c20c304271e6d352a668f40 /www/lynx
parentfc9e35a68938de89e7d6aa652b194fdb6527aafa (diff)
downloadports-e79389466a52f5cefbdd19a6c832096120e486c5.tar.gz
ports-e79389466a52f5cefbdd19a6c832096120e486c5.zip
Add a patch, which makes sure, that lynx' own internal entities.h is
included, instead of one possibly installed by other software such as gd. Remove "non-functional comments". Check WITHOUT_IPV6 in addition to NO_INET6. Suggested by: timur
Notes
Notes: svn path=/head/; revision=195008
Diffstat (limited to 'www/lynx')
-rw-r--r--www/lynx/Makefile4
-rw-r--r--www/lynx/files/patch-LYCharSets9
2 files changed, 11 insertions, 2 deletions
diff --git a/www/lynx/Makefile b/www/lynx/Makefile
index 5dc2239693fa..2656694cbeff 100644
--- a/www/lynx/Makefile
+++ b/www/lynx/Makefile
@@ -33,7 +33,7 @@ USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
.endif
-.if defined(NO_INET6)
+.if defined(NO_INET6) || defined(WITHOUT_IPV6)
CONFIGURE_ARGS+=--disable-ipv6
.else
CONFIGURE_ARGS+=--enable-ipv6
@@ -43,7 +43,7 @@ CONFIGURE_ARGS+=--enable-ipv6
CONFIGURE_ARGS+=--enable-default-colors
.endif
-MAKE_ARGS= helpdir=${L_HELP} docdir=${DOCSDIR} #-j`${SYSCTL} -n hw.ncpu`
+MAKE_ARGS= helpdir=${L_HELP} docdir=${DOCSDIR}
MAKEFILE= makefile
INSTALL_TARGET= install-full
MAN1= lynx.1
diff --git a/www/lynx/files/patch-LYCharSets b/www/lynx/files/patch-LYCharSets
new file mode 100644
index 000000000000..ece2c04421b8
--- /dev/null
+++ b/www/lynx/files/patch-LYCharSets
@@ -0,0 +1,9 @@
+--- src/LYCharSets.c Sun Dec 18 17:52:30 2005
++++ src/LYCharSets.c Mon Jul 2 16:10:40 2007
+@@ -871,5 +871,5 @@
+ UCode_t HTMLGetEntityUCValue(const char *name)
+ {
+-#include <entities.h>
++#include "chrtrans/entities.h"
+
+ UCode_t value = 0;