aboutsummaryrefslogtreecommitdiff
path: root/www/middleman
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-04-29 17:35:56 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-04-29 17:35:56 +0000
commit35554e7a78581199f75254f6f716ebd57a716165 (patch)
tree5319c010631741b824135ef98fbb3fa2da09e8d8 /www/middleman
parent9962d2013954e18a2a1c4a5194d6a9692242008b (diff)
downloadports-35554e7a78581199f75254f6f716ebd57a716165.tar.gz
ports-35554e7a78581199f75254f6f716ebd57a716165.zip
Notes
Diffstat (limited to 'www/middleman')
-rw-r--r--www/middleman/Makefile46
-rw-r--r--www/middleman/distinfo1
-rw-r--r--www/middleman/files/patch-aa14
-rw-r--r--www/middleman/pkg-descr12
-rw-r--r--www/middleman/pkg-plist6
5 files changed, 79 insertions, 0 deletions
diff --git a/www/middleman/Makefile b/www/middleman/Makefile
new file mode 100644
index 000000000000..5798f0807886
--- /dev/null
+++ b/www/middleman/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: middleman
+# Date created: Sun Apr 27 15:48:16 CEST 2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= middleman
+PORTVERSION= 1.5.2
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= middle-man
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Middleman is a robust proxy server
+
+WRKSRC= ${WRKDIR}/middleman
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+.if defined(WITH_SYSLOG)
+CONFIGURE_ARGS+= --enable-syslog
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mman ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/config.xml ${PREFIX}/etc/mman.xml
+ ${INSTALL_DATA} ${WRKSRC}/scripts/mman.init ${PREFIX}/etc/rc.d/mman.sh.sample
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/middleman
+ ${INSTALL_DATA} ${WRKSRC}/scripts/filter.pl ${PREFIX}/share/doc/middleman/
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${PREFIX}/share/doc/middleman/
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/middleman/distinfo b/www/middleman/distinfo
new file mode 100644
index 000000000000..71c8b84464f7
--- /dev/null
+++ b/www/middleman/distinfo
@@ -0,0 +1 @@
+MD5 (middleman-1.5.2.tgz) = d118bf0e9521b729b7d87e31d76ddd26
diff --git a/www/middleman/files/patch-aa b/www/middleman/files/patch-aa
new file mode 100644
index 000000000000..0efef10d0024
--- /dev/null
+++ b/www/middleman/files/patch-aa
@@ -0,0 +1,14 @@
+--- scripts/mman.init.orig Sun Apr 27 18:38:32 2003
++++ scripts/mman.init Sun Apr 27 18:38:54 2003
+@@ -1,9 +1,9 @@
+ #!/bin/sh
+
+-PROGRAM=/usr/bin/mman
++PROGRAM=/usr/local/bin/mman
+ PIDFILE=/var/run/mman.pid
+ LOGFILE=/var/log/mman.log
+-CONFIG=/etc/mman/config.xml
++CONFIG=/usr/local/etc/mman.xml
+ LOGLEVEL=2047
+ case "$1" in
+ start|--start)
diff --git a/www/middleman/pkg-descr b/www/middleman/pkg-descr
new file mode 100644
index 000000000000..36620fe51674
--- /dev/null
+++ b/www/middleman/pkg-descr
@@ -0,0 +1,12 @@
+Middleman is a robust proxy server with many features designed
+to remove unwanted content, increase privacy, and to simply
+make surfing the Web a more pleasant experience. Some of the
+highlights of Middleman include banner and popup blocking, HTTP
+and FTP content caching, NTLM and Basic authentication when
+forwarding through another proxy server, regular expression
+substitution in downloaded files and HTTP headers, complete
+support for HTTP/1.1 including persistent connections and gzip
+encoding, and an intutive Web interface for configuring the
+proxy.
+
+WWW: http://sourceforge.net/projects/middle-man
diff --git a/www/middleman/pkg-plist b/www/middleman/pkg-plist
new file mode 100644
index 000000000000..b64b6cd0a1af
--- /dev/null
+++ b/www/middleman/pkg-plist
@@ -0,0 +1,6 @@
+bin/mman
+etc/rc.d/mman.sh.sample
+etc/mman.xml
+%%PORTDOCS%%share/doc/middleman/README.html
+%%PORTDOCS%%share/doc/middleman/filter.pl
+@dirrm %%PORTDOCS%%share/doc/middleman