aboutsummaryrefslogtreecommitdiff
path: root/www/midori/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-04-20 16:39:53 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-04-20 16:39:53 +0000
commitd7165d173a0532e4fa4b158d370aff47d0d12f3e (patch)
treee689e1eda1fa3746ce984d091ef508501c06ab0e /www/midori/Makefile
parentc726dd5df1cd1691b5bd7d445b8e6585b5ada4b7 (diff)
- Update to 0.5.10
- Adjust dependencies - Remove GRANITE option (appearance seems broken) - Remove support of WebKit2 API (still experimental) [1] Requested by: <phryk@commander1024.de> (via freebsd-xfce@ list, in February 2015 thread) [1]
Notes
Notes: svn path=/head/; revision=384366
Diffstat (limited to 'www/midori/Makefile')
-rw-r--r--www/midori/Makefile42
1 files changed, 10 insertions, 32 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index c154d2991391..29208a189c4f 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= midori
-PORTVERSION= 0.5.9
-PORTREVISION= 3
+PORTVERSION= 0.5.10
CATEGORIES= www xfce
MASTER_SITES= http://www.midori-browser.org/downloads/
DISTNAME= ${PORTNAME}_${PORTVERSION}_all_
@@ -18,15 +17,17 @@ LICENSE_COMB= multi
BUILD_DEPENDS= rsvg-convert:${PORTSDIR}/graphics/librsvg2 \
valac:${PORTSDIR}/lang/vala
LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify \
- libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome
+ libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome \
+ libgcr-3.so:${PORTSDIR}/security/gcr
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -Wno-return-type
-CMAKE_ARGS= -DUSE_APIDOCS:BOOL=OFF
+CMAKE_ARGS= -DUSE_APIDOCS:BOOL=OFF \
+ -DUSE_GRANITE:BOOL=OFF
-WRKSRC= ${WRKDIR}/${DISTNAME:C/([a-z]*)_([0-9\.]*)(_all_)/\1-\2/}
+#WRKSRC= ${WRKDIR}/${DISTNAME:C/([a-z]*)_([0-9\.]*)(_all_)/\1-\2/}
NO_WRKSUBDIR= yes
USE_GNOME= glib20 intltool libxml2
USE_XORG= xscrnsaver
@@ -37,14 +38,11 @@ USE_SQLITE= yes
PLIST_SUB= VERSION="${PORTVERSION:R}"
-OPTIONS_DEFINE= GIR GRANITE ZEITGEIST
+OPTIONS_DEFINE= GIR ZEITGEIST
OPTIONS_SINGLE= GTK
OPTIONS_SINGLE_GTK= GTK2 GTK3
OPTIONS_DEFAULT= GTK2
-# Need x11-toolkits/granite >= 0.3 (Granite.Widgets.LightWindow is deprecated)
-OPTIONS_EXCLUDE= GRANITE
GIR_DESC= GObject Introspection
-GRANITE_DESC= Additional GTK widgets (require GTK3)
ZEITGEIST_DESC= User logs activities
.include <bsd.port.options.mk>
@@ -52,34 +50,14 @@ ZEITGEIST_DESC= User logs activities
.if ${PORT_OPTIONS:MGTK2}
LIB_DEPENDS+= libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
USE_GNOME+= gtk20
-CMAKE_ARGS+= -DUSE_GTK3:BOOL=OFF \
- -DUSE_GCR:BOOL=OFF
-PLIST_SUB+= ONLY_WEBKIT1=""
+CMAKE_ARGS+= -DUSE_GTK3:BOOL=OFF
.endif
.if ${PORT_OPTIONS:MGTK3}
-LIB_DEPENDS+= libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3 \
- libgcr-3.so:${PORTSDIR}/security/gcr
+LIB_DEPENDS+= libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3
USE_GNOME+= gtk30
CMAKE_ARGS+= -DUSE_GTK3:BOOL=ON \
- -DUSE_GCR:BOOL=ON
-
-# Support the new WebKit2 API (>= 1.11.91)
-.if exists(${LOCALBASE}/libdata/pkgconfig/webkit2gtk-3.0.pc)
-CMAKE_ARGS+= -DHALF_BRO_INCOM_WEBKIT2:BOOL=ON
-# Some extensions are not yet ported to the new API (WebKit2)
-PLIST_SUB+= ONLY_WEBKIT1="@comment "
-.else
-CMAKE_ARGS+= -DHALF_BRO_INCOM_WEBKIT2:BOOL=OFF
-PLIST_SUB+= ONLY_WEBKIT1=""
-.endif
-
-.if ${PORT_OPTIONS:MGRANITE}
-LIB_DEPENDS+= libgranite.so:${PORTSDIR}/x11-toolkits/granite
-CMAKE_ARGS+= -DUSE_GRANITE:BOOL=ON
-.else
-CMAKE_ARGS+= -DUSE_GRANITE:BOOL=OFF
-.endif
+ -DHALF_BRO_INCOM_WEBKIT2:BOOL=OFF
.endif
.if ${PORT_OPTIONS:MZEITGEIST}