aboutsummaryrefslogtreecommitdiff
path: root/www/midori
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-07-22 17:31:58 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-07-22 17:31:58 +0000
commit023e321d6f2526d8d45e653b502145108f118f9c (patch)
tree541f7f7b014cec6f98de6c6ec2450d4cf0edbc7b /www/midori
parent6274ab1363bf2ddd36c6a4f322048350e63f66ca (diff)
downloadports-023e321d6f2526d8d45e653b502145108f118f9c.tar.gz
ports-023e321d6f2526d8d45e653b502145108f118f9c.zip
Fix PACKAGE_VERSION in gtk_about_dialog widget
Notes
Notes: svn path=/head/; revision=323484
Diffstat (limited to 'www/midori')
-rw-r--r--www/midori/Makefile1
-rw-r--r--www/midori/files/patch-wscript29
2 files changed, 30 insertions, 0 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index b57e4670feba..26969f0d7aaf 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -3,6 +3,7 @@
PORTNAME= midori
PORTVERSION= 0.5.4
+PORTREVISION= 1
CATEGORIES= www xfce
MASTER_SITES= http://www.midori-browser.org/downloads/
DISTNAME= ${PORTNAME}_${PORTVERSION}_all_
diff --git a/www/midori/files/patch-wscript b/www/midori/files/patch-wscript
new file mode 100644
index 000000000000..da84b9e23682
--- /dev/null
+++ b/www/midori/files/patch-wscript
@@ -0,0 +1,29 @@
+Fix PACKAGE_VERSION in gtk_about_dialog widget.
+https://bugs.launchpad.net/midori/+bug/1200903
+
+--- ./wscript.orig 2013-07-15 22:38:28.000000000 +0000
++++ ./wscript 2013-07-21 16:02:48.000000000 +0000
+@@ -29,7 +29,7 @@
+
+ APPNAME = 'midori'
+ VERSION = VERSION_FULL = '0.5.4'
+-VERSION_SUFFIX = ' (%s)' % VERSION
++#VERSION_SUFFIX = ' (%s)' % VERSION
+
+ try:
+ if os.path.isdir ('.git'):
+@@ -44,8 +44,12 @@
+ folder = os.getcwd ()
+ if VERSION in folder:
+ VERSION_FULL = os.path.basename (folder)
+- if VERSION in VERSION_FULL:
+- VERSION_SUFFIX = VERSION_FULL.replace (VERSION, '')
++ if VERSION_FULL.endswith ('_all_'):
++ VERSION_FULL = VERSION_FULL.replace('_all_', '')
++ if APPNAME in VERSION_FULL:
++ VERSION_FULL = VERSION_FULL.replace(APPNAME, '')[1:]
++
++ VERSION_SUFFIX = ' (%s)' % VERSION_FULL
+ except:
+ pass
+