aboutsummaryrefslogtreecommitdiff
path: root/www/midori
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2014-11-27 18:37:53 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2014-11-27 18:37:53 +0000
commitab836cd31299f6e4a4080ce3ccbed7d5d8ef3616 (patch)
tree1a84e564ca4e0755b42f15b1d79ff85669412823 /www/midori
parent1450e338deb1757aa11a287717cf46dcd34eafd1 (diff)
downloadports-ab836cd31299f6e4a4080ce3ccbed7d5d8ef3616.tar.gz
ports-ab836cd31299f6e4a4080ce3ccbed7d5d8ef3616.zip
Notes
Diffstat (limited to 'www/midori')
-rw-r--r--www/midori/Makefile24
-rw-r--r--www/midori/files/patch-cmake__GtkDoc.cmake11
-rw-r--r--www/midori/pkg-plist50
3 files changed, 9 insertions, 76 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index 01e76c7fb025..c154d2991391 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -3,7 +3,7 @@
PORTNAME= midori
PORTVERSION= 0.5.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www xfce
MASTER_SITES= http://www.midori-browser.org/downloads/
DISTNAME= ${PORTNAME}_${PORTVERSION}_all_
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_ro
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -Wno-return-type
-CMAKE_ARGS= -DUSE_GCR:BOOL=OFF
+CMAKE_ARGS= -DUSE_APIDOCS:BOOL=OFF
WRKSRC= ${WRKDIR}/${DISTNAME:C/([a-z]*)_([0-9\.]*)(_all_)/\1-\2/}
NO_WRKSUBDIR= yes
@@ -37,7 +37,7 @@ USE_SQLITE= yes
PLIST_SUB= VERSION="${PORTVERSION:R}"
-OPTIONS_DEFINE= DOCS GIR GRANITE ZEITGEIST
+OPTIONS_DEFINE= GIR GRANITE ZEITGEIST
OPTIONS_SINGLE= GTK
OPTIONS_SINGLE_GTK= GTK2 GTK3
OPTIONS_DEFAULT= GTK2
@@ -52,14 +52,17 @@ ZEITGEIST_DESC= User logs activities
.if ${PORT_OPTIONS:MGTK2}
LIB_DEPENDS+= libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
USE_GNOME+= gtk20
-CMAKE_ARGS+= -DUSE_GTK3:BOOL=OFF
+CMAKE_ARGS+= -DUSE_GTK3:BOOL=OFF \
+ -DUSE_GCR:BOOL=OFF
PLIST_SUB+= ONLY_WEBKIT1=""
.endif
.if ${PORT_OPTIONS:MGTK3}
-LIB_DEPENDS+= libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3
+LIB_DEPENDS+= libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3 \
+ libgcr-3.so:${PORTSDIR}/security/gcr
USE_GNOME+= gtk30
-CMAKE_ARGS+= -DUSE_GTK3:BOOL=ON
+CMAKE_ARGS+= -DUSE_GTK3:BOOL=ON \
+ -DUSE_GCR:BOOL=ON
# Support the new WebKit2 API (>= 1.11.91)
.if exists(${LOCALBASE}/libdata/pkgconfig/webkit2gtk-3.0.pc)
@@ -79,15 +82,6 @@ CMAKE_ARGS+= -DUSE_GRANITE:BOOL=OFF
.endif
.endif
-.if ${PORT_OPTIONS:MDOCS}
-BUILD_DEPENDS+= gtkdoc-scan:${PORTSDIR}/textproc/gtk-doc
-CMAKE_ARGS+= -DUSE_APIDOCS:BOOL=ON
-PLIST_SUB+= APIDOCS=""
-.else
-CMAKE_ARGS+= -DUSE_APIDOCS:BOOL=OFF
-PLIST_SUB+= APIDOCS="@comment "
-.endif
-
.if ${PORT_OPTIONS:MZEITGEIST}
LIB_DEPENDS+= libzeitgeist-1.0.so:${PORTSDIR}/sysutils/libzeitgeist
CMAKE_ARGS+= -DUSE_ZEITGEIST:BOOL=ON
diff --git a/www/midori/files/patch-cmake__GtkDoc.cmake b/www/midori/files/patch-cmake__GtkDoc.cmake
deleted file mode 100644
index f5bd09a6af33..000000000000
--- a/www/midori/files/patch-cmake__GtkDoc.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./cmake/GtkDoc.cmake.orig 2013-11-20 01:26:52.000000000 +0000
-+++ ./cmake/GtkDoc.cmake 2013-11-21 16:30:38.000000000 +0000
-@@ -52,7 +52,7 @@
- file (MAKE_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/${module}/html")
- gtkdoc_build (${module})
-
-- set (DOC_DIR "html/midori-${MIDORI_MAJOR_VERSION}-${MIDORI_MINOR_VERSION}")
-+ set (DOC_DIR "html/midori-${MIDORI_MAJOR_VERSION}.${MIDORI_MINOR_VERSION}")
- install (DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/${module}/html/"
- DESTINATION "${CMAKE_INSTALL_DATADIR}/gtk-doc/${DOC_DIR}/${module}"
- PATTERN "html/*"
diff --git a/www/midori/pkg-plist b/www/midori/pkg-plist
index 3dd3f2032fbf..b410cc1ae0e7 100644
--- a/www/midori/pkg-plist
+++ b/www/midori/pkg-plist
@@ -46,56 +46,6 @@ share/applications/midori.desktop
%%DOCSDIR%%/faq.html
%%GIR%%share/gir-1.0/Katze-%%VERSION%%.gir
%%GIR%%share/gir-1.0/Midori-%%VERSION%%.gir
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/annotation-glossary.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/api-index-full.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/ch01.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/deprecated-api-index.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/home.png
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/index.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-KatzeArray.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-KatzeCellRendererComboBoxText.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-KatzeItem.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-KatzePreferences.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-gtk3-compat.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-katze-arrayaction.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-katze-http-auth.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze-katze-utils.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/katze.devhelp2
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/left.png
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/right.png
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/style.css
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/up.png
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/annotation-glossary.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/api-index-full.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/ch01.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/deprecated-api-index.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/home.png
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/index.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/left.png
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-MidoriBrowser.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-MidoriExtension.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-MidoriPreferences.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-MidoriViewable.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-app.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-array.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-bookmarks-db.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-frontend.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-history.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-locationaction.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-panel.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-platform.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-privatedata.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-searchaction.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-session.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-stock.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-view.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori-websettings.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-midori.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori-sokoke.html
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/midori.devhelp2
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/right.png
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/style.css
-%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/up.png
share/icons/hicolor/16x16/apps/midori.png
share/icons/hicolor/16x16/categories/extension.png
share/icons/hicolor/16x16/status/internet-news-reader.png