aboutsummaryrefslogtreecommitdiff
path: root/www/midori
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2014-04-04 21:11:58 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2014-04-04 21:11:58 +0000
commitd009a4fbb2bc684a461a7a7416311fb79791002a (patch)
tree9fe09ea3817a1865b5c4a76885564001079c1513 /www/midori
parenta22c18c8967fcbc8fccd4879d8b1be6703d4e66c (diff)
downloadports-d009a4fbb2bc684a461a7a7416311fb79791002a.tar.gz
ports-d009a4fbb2bc684a461a7a7416311fb79791002a.zip
- Update to 0.5.8
- Remove unneeded patches - Add GRANITE (additional GTK+ toolkits) and GIR (GObject introspection) options
Notes
Notes: svn path=/head/; revision=350169
Diffstat (limited to 'www/midori')
-rw-r--r--www/midori/Makefile34
-rw-r--r--www/midori/distinfo4
-rw-r--r--www/midori/files/patch-CMakeLists.txt10
-rw-r--r--www/midori/files/patch-extensions__CMakeLists.txt14
-rw-r--r--www/midori/pkg-plist24
5 files changed, 51 insertions, 35 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index 3b84250f780a..316661ffd084 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= midori
-PORTVERSION= 0.5.7
+PORTVERSION= 0.5.8
CATEGORIES= www xfce
MASTER_SITES= http://www.midori-browser.org/downloads/
DISTNAME= ${PORTNAME}_${PORTVERSION}_all_
@@ -21,25 +21,26 @@ LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CMAKE_ARGS= -DUSE_GRANITE:BOOL=OFF \
- -DUSE_GCR:BOOL=OFF
+CMAKE_ARGS= -DUSE_GCR:BOOL=OFF
-WRKSRC= ${WRKDIR}/${DISTNAME:C/([a-z]*)_([0-9\.]*)(_all_)/\1-\2/}
-USE_BZIP2= yes
+#WRKSRC= ${WRKDIR}/${DISTNAME:C/([a-z]*)_([0-9\.]*)(_all_)/\1-\2/}
+NO_WRKSUBDIR= yes
USE_GNOME= glib20 intltool libxml2
USE_XORG= xscrnsaver
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USES= desktop-file-utils pkgconfig cmake gettext
+USES= desktop-file-utils pkgconfig cmake gettext tar:bzip2
PLIST_SUB= VERSION="${PORTVERSION:R}"
-OPTIONS_DEFINE= DOCS ZEITGEIST
+OPTIONS_DEFINE= DOCS GIR GRANITE ZEITGEIST
OPTIONS_SINGLE= GTK
OPTIONS_SINGLE_GTK= GTK2 GTK3
OPTIONS_DEFAULT= GTK2
+GIR_DESC= GObject Introspection
+GRANITE_DESC= Additional GTK widgets (require GTK3)
ZEITGEIST_DESC= User logs activities
.include <bsd.port.options.mk>
@@ -61,6 +62,13 @@ CMAKE_ARGS+= -DHALF_BRO_INCOM_WEBKIT2:BOOL=ON
.else
CMAKE_ARGS+= -DHALF_BRO_INCOM_WEBKIT2:BOOL=OFF
.endif
+
+.if ${PORT_OPTIONS:MGRANITE}
+LIB_DEPENDS+= libgranite.so:${PORTSDIR}/x11-toolkits/granite
+CMAKE_ARGS+= -DUSE_GRANITE:BOOL=ON
+.else
+CMAKE_ARGS+= -DUSE_GRANITE:BOOL=OFF
+.endif
.endif
.if ${PORT_OPTIONS:MDOCS}
@@ -79,9 +87,17 @@ CMAKE_ARGS+= -DUSE_ZEITGEIST:BOOL=ON
CMAKE_ARGS+= -DUSE_ZEITGEIST:BOOL=OFF
.endif
+.if ${PORT_OPTIONS:MGIR}
+USE_GNOME+= introspection:build
+CMAKE_ARGS+= -DUSE_GIR:BOOL=ON
+PLIST_SUB+= GIR=""
+.else
+CMAKE_ARGS+= -DUSE_GIR:BOOL=OFF
+PLIST_SUB+= GIR="@comment "
+.endif
+
post-patch:
# Avoid errors with CMake
- @${RM} ${WRKSRC}/*.orig
.for dir in config extensions
@${RM} ${WRKSRC}/${dir}/*.orig
.endfor
diff --git a/www/midori/distinfo b/www/midori/distinfo
index b1862f9b36d7..2fe9ef38419f 100644
--- a/www/midori/distinfo
+++ b/www/midori/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/midori_0.5.7_all_.tar.bz2) = 2875bb2aa8a8a0cce342178f04700d4ebccd13bf1b2ad4cb3ba9fec7e2bd0b4d
-SIZE (xfce4/midori_0.5.7_all_.tar.bz2) = 1191260
+SHA256 (xfce4/midori_0.5.8_all_.tar.bz2) = af19135fd4c4b04345df4d3592e7939c20f9b40eaca24550e6cb619751aa9381
+SIZE (xfce4/midori_0.5.8_all_.tar.bz2) = 1267130
diff --git a/www/midori/files/patch-CMakeLists.txt b/www/midori/files/patch-CMakeLists.txt
deleted file mode 100644
index ee8d46a82733..000000000000
--- a/www/midori/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./CMakeLists.txt.orig 2014-01-15 20:43:34.000000000 +0000
-+++ ./CMakeLists.txt 2014-01-15 22:50:54.000000000 +0000
-@@ -100,6 +100,7 @@
- string(FIND ${CMAKE_SYSTEM_NAME} "BSD" BEGIN)
- if (${BEGIN} GREATER 0)
- string(SUBSTRING ${CMAKE_SYSTEM_NAME} ${BEGIN} 3 BSD)
-+ set(BSD 1 CACHE INTERNAL BOOL FORCE)
- else()
- set(BSD 0)
- endif()
diff --git a/www/midori/files/patch-extensions__CMakeLists.txt b/www/midori/files/patch-extensions__CMakeLists.txt
deleted file mode 100644
index 59d061be1d55..000000000000
--- a/www/midori/files/patch-extensions__CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./extensions/CMakeLists.txt.orig 2014-01-15 20:43:34.000000000 +0000
-+++ ./extensions/CMakeLists.txt 2014-01-15 22:52:29.000000000 +0000
-@@ -24,6 +24,11 @@
- "nsplugin-manager.vala"
- )
- endif ()
-+if (BSD)
-+ list(REMOVE_ITEM EXTENSIONS
-+ "devpet.vala"
-+ )
-+endif ()
-
- foreach(UNIT_SRC ${EXTENSIONS})
- string(FIND ${UNIT_SRC} ".c" UNIT_EXTENSION)
diff --git a/www/midori/pkg-plist b/www/midori/pkg-plist
index 28630e413275..8030ed337991 100644
--- a/www/midori/pkg-plist
+++ b/www/midori/pkg-plist
@@ -12,6 +12,8 @@ lib/midori/libcookie-manager.so
lib/midori/libcookie-permissions.so
lib/midori/libcopy-tabs.so
lib/midori/libdelayed-load.so
+lib/midori/libdevpet.so
+lib/midori/libdomain-keys.so
lib/midori/libexternal-download-manager.so
lib/midori/libfeed-panel.so
lib/midori/libflummi.so
@@ -19,7 +21,9 @@ lib/midori/libformhistory.so
lib/midori/libhistory-list.so
lib/midori/libmouse-gestures.so
lib/midori/libnojs.so
+lib/midori/libnotes.so
lib/midori/libnsplugin-manager.so
+lib/midori/libopen-with.so
lib/midori/libshortcuts.so
lib/midori/libstatus-clock.so
lib/midori/libstatusbar-features.so
@@ -38,6 +42,9 @@ share/applications/midori.desktop
%%DOCSDIR%%/README
%%DOCSDIR%%/faq.css
%%DOCSDIR%%/faq.html
+%%GIR%%share/gir-1.0/Katze-%%VERSION%%.gir
+%%GIR%%share/gir-1.0/Midori-%%VERSION%%.gir
+%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/annotation-glossary.html
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/api-index-full.html
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/ch01.html
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/deprecated-api-index.html
@@ -56,6 +63,7 @@ share/applications/midori.desktop
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/right.png
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/style.css
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/katze/up.png
+%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/annotation-glossary.html
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/api-index-full.html
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/ch01.html
%%APIDOCS%%share/gtk-doc/html/midori-%%VERSION%%/midori/deprecated-api-index.html
@@ -95,12 +103,14 @@ share/icons/hicolor/22x22/status/internet-news-reader.png
share/icons/hicolor/scalable/apps/midori.svg
share/icons/hicolor/scalable/categories/extension.svg
share/icons/hicolor/scalable/status/internet-news-reader.svg
+share/locale/am/LC_MESSAGES/midori.mo
share/locale/ar/LC_MESSAGES/midori.mo
share/locale/ast/LC_MESSAGES/midori.mo
share/locale/be/LC_MESSAGES/midori.mo
share/locale/bg/LC_MESSAGES/midori.mo
share/locale/bs/LC_MESSAGES/midori.mo
share/locale/ca/LC_MESSAGES/midori.mo
+share/locale/ckb/LC_MESSAGES/midori.mo
share/locale/cs/LC_MESSAGES/midori.mo
share/locale/cy/LC_MESSAGES/midori.mo
share/locale/da/LC_MESSAGES/midori.mo
@@ -126,6 +136,7 @@ share/locale/id/LC_MESSAGES/midori.mo
share/locale/it/LC_MESSAGES/midori.mo
share/locale/ja/LC_MESSAGES/midori.mo
share/locale/kk/LC_MESSAGES/midori.mo
+share/locale/km/LC_MESSAGES/midori.mo
share/locale/ko/LC_MESSAGES/midori.mo
share/locale/ky/LC_MESSAGES/midori.mo
share/locale/lt/LC_MESSAGES/midori.mo
@@ -144,6 +155,7 @@ share/locale/ro/LC_MESSAGES/midori.mo
share/locale/ru/LC_MESSAGES/midori.mo
share/locale/sk/LC_MESSAGES/midori.mo
share/locale/sl/LC_MESSAGES/midori.mo
+share/locale/sq/LC_MESSAGES/midori.mo
share/locale/sr/LC_MESSAGES/midori.mo
share/locale/sr@latin/LC_MESSAGES/midori.mo
share/locale/sv/LC_MESSAGES/midori.mo
@@ -155,6 +167,11 @@ share/locale/vi/LC_MESSAGES/midori.mo
share/locale/zh_CN/LC_MESSAGES/midori.mo
share/locale/zh_TW/LC_MESSAGES/midori.mo
%%DATADIR%%/res/about.css
+%%DATADIR%%/res/adblock.list
+%%DATADIR%%/res/adblock/blocked.png
+%%DATADIR%%/res/adblock/disabled.png
+%%DATADIR%%/res/adblock/element_hider.js
+%%DATADIR%%/res/adblock/enabled.png
%%DATADIR%%/res/autosuggestcontrol.css
%%DATADIR%%/res/autosuggestcontrol.js
%%DATADIR%%/res/bookmarks/Create.sql
@@ -170,15 +187,18 @@ share/locale/zh_TW/LC_MESSAGES/midori.mo
%%DATADIR%%/res/nojs/nojs-statusicon-allowed.png
%%DATADIR%%/res/nojs/nojs-statusicon-denied.png
%%DATADIR%%/res/nojs/nojs-statusicon-mixed.png
+%%DATADIR%%/res/notes/Create.sql
%%DATADIR%%/res/speeddial-head.html
%%DATADIR%%/res/tabby/Create.sql
%%DATADIR%%/res/tabby/Update1.sql
@dirrm %%DATADIR%%/res/tabby
+@dirrm %%DATADIR%%/res/notes
@dirrm %%DATADIR%%/res/nojs
@dirrm %%DATADIR%%/res/history
@dirrm %%DATADIR%%/res/forms
@dirrm %%DATADIR%%/res/flummi
@dirrm %%DATADIR%%/res/bookmarks
+@dirrm %%DATADIR%%/res/adblock
@dirrm %%DATADIR%%/res
@dirrm %%DATADIR%%
@dirrmtry share/locale/ug/LC_MESSAGES
@@ -187,12 +207,16 @@ share/locale/zh_TW/LC_MESSAGES/midori.mo
@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/ky/LC_MESSAGES
@dirrmtry share/locale/ky
+@dirrmtry share/locale/km/LC_MESSAGES
+@dirrmtry share/locale/km
@dirrmtry share/locale/kk/LC_MESSAGES
@dirrmtry share/locale/kk
@dirrmtry share/locale/ia/LC_MESSAGES
@dirrmtry share/locale/ia
@dirrmtry share/locale/gd/LC_MESSAGES
@dirrmtry share/locale/gd
+@dirrmtry share/locale/ckb/LC_MESSAGES
+@dirrmtry share/locale/ckb
@dirrmtry share/locale/ast/LC_MESSAGES
@dirrmtry share/locale/ast
%%APIDOCS%%@dirrm share/gtk-doc/html/midori-%%VERSION%%/midori