aboutsummaryrefslogtreecommitdiff
path: root/www/midori
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-01-09 10:57:31 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-01-09 10:57:31 +0000
commiteb4c24d06d7992f7f34799949ff3ffa8654d2b74 (patch)
tree8884438a672a8624e873361f8c5afb2ba931d1eb /www/midori
parent0fcf8df9b4aa73de0cac2cabebc787b91d9e31a1 (diff)
downloadports-eb4c24d06d7992f7f34799949ff3ffa8654d2b74.tar.gz
ports-eb4c24d06d7992f7f34799949ff3ffa8654d2b74.zip
Notes
Diffstat (limited to 'www/midori')
-rw-r--r--www/midori/Makefile47
-rw-r--r--www/midori/distinfo5
-rw-r--r--www/midori/files/patch-CMakeLists.txt10
-rw-r--r--www/midori/files/patch-config__search15
-rw-r--r--www/midori/files/patch-extensions__external-download-manager.vala37
-rw-r--r--www/midori/files/patch-extensions_adblock_widgets.vala14
-rw-r--r--www/midori/files/patch-extensions_apps.vala14
-rw-r--r--www/midori/files/patch-extensions_history-list.vala14
-rw-r--r--www/midori/files/patch-extensions_notes.vala14
-rw-r--r--www/midori/files/patch-extensions_transfers.vala27
-rw-r--r--www/midori/files/patch-midori__midori-stock.h18
-rw-r--r--www/midori/files/patch-midori_midori-notebook.vala29
-rw-r--r--www/midori/pkg-plist89
13 files changed, 42 insertions, 291 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index 791fdee7ae92..d3324e21a35e 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -2,11 +2,8 @@
# $FreeBSD$
PORTNAME= midori
-PORTVERSION= 0.5.11
+PORTVERSION= 0.7.0
CATEGORIES= www xfce
-MASTER_SITES= https://launchpadlibrarian.net/215909491/ \
- https://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
-DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Lightweight web browser using WebKit browser engine
@@ -17,39 +14,39 @@ LICENSE_COMB= multi
BUILD_DEPENDS= rsvg-convert:graphics/librsvg2 \
valac:lang/vala
LIB_DEPENDS= libnotify.so:devel/libnotify \
+ libsoup-2.4.so:devel/libsoup \
libsoup-gnome-2.4.so:devel/libsoup-gnome \
- libgcr-3.so:security/gcr
+ libp11-kit.so:security/p11-kit \
+ libgcr-3.so:security/gcr \
+ libpeas-1.0.so:devel/libpeas \
+ libwebkit2gtk-4.0.so:www/webkit2-gtk3
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
+USES= cmake desktop-file-utils gettext gnome localbase:ldflags \
+ pkgconfig sqlite tar:bzip2
+USE_GNOME= cairo glib20 gtk30 intltool introspection libxml2
+USE_XORG= xscrnsaver
+
CFLAGS+= -Wno-return-type
-CMAKE_ARGS= -DUSE_APIDOCS:BOOL=OFF \
- -DUSE_GRANITE:BOOL=OFF
+CMAKE_ARGS= -DUSE_APIDOCS:BOOL=OFF
-USES= cmake desktop-file-utils gettext localbase:ldflags pkgconfig \
- sqlite tar:bzip2
-USE_GNOME= glib20 intltool libxml2
-USE_XORG= xscrnsaver
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
PLIST_SUB= VERSION="${PORTVERSION:R}"
-OPTIONS_DEFINE= GIR GTK3 ZEITGEIST
-OPTIONS_SUB= yes
-GIR_PREVENTS= GTK3
-GIR_USE= gnome=introspection:build
-GIR_CMAKE_ON= -DUSE_GIR:BOOL=ON
-GTK3_LIB_DEPENDS= libwebkitgtk-3.0.so:www/webkit-gtk3
-GTK3_USE= gnome=gtk30
-GTK3_CMAKE_ON= -DUSE_GTK3:BOOL=ON \
- -DHALF_BRO_INCOM_WEBKIT2:BOOL=OFF
-GTK3_LIB_DEPENDS_OFF= libwebkitgtk-1.0.so:www/webkit-gtk2
-GTK3_USE_OFF= gnome=gtk20
-GTK3_CMAKE_OFF= -DUSE_GTK3:BOOL=OFF
+USE_GITHUB= yes
+GH_ACCOUNT= midori-browser
+GH_PROJECT= core
+GH_TAGNAME= v7
+
+OPTIONS_DEFINE= ZEITGEIST
+OPTIONS_SUB= yes
+
+ZEITGEIST_DESC= User logs activities
+
ZEITGEIST_LIB_DEPENDS= libzeitgeist-2.0.so:sysutils/zeitgeist
ZEITGEIST_CMAKE_OFF= -DUSE_ZEITGEIST:BOOL=OFF
-GIR_DESC= Install GObject Introspection Reference manual
-ZEITGEIST_DESC= User logs activities
post-patch:
# Avoid errors with CMake
diff --git a/www/midori/distinfo b/www/midori/distinfo
index 1764fb5a2bae..892b22bab9c8 100644
--- a/www/midori/distinfo
+++ b/www/midori/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xfce4/midori-0.5.11.tar.bz2) = 96191a96be71144ae848a409fae5a1d6d52a00e583f33122081f47ead9c49c3d
-SIZE (xfce4/midori-0.5.11.tar.bz2) = 1428791
+TIMESTAMP = 1544775534
+SHA256 (midori-browser-core-0.7.0-v7_GH0.tar.gz) = ba9295e85e2eea45b07052413f50bab7d3b85c471a05ec653b6eb8a6286e3207
+SIZE (midori-browser-core-0.7.0-v7_GH0.tar.gz) = 1862369
diff --git a/www/midori/files/patch-CMakeLists.txt b/www/midori/files/patch-CMakeLists.txt
deleted file mode 100644
index 8280fae44c62..000000000000
--- a/www/midori/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- CMakeLists.txt.orig 2015-08-30 11:56:26 UTC
-+++ CMakeLists.txt
-@@ -263,7 +263,6 @@ if ((CMAKE_C_COMPILER_ID STREQUAL "GNU"
- OR (CMAKE_C_COMPILER_ID STREQUAL "Clang" AND CMAKE_C_COMPILER_VERSION VERSION_GREATER "3.0.0"))
- set(VALA_CFLAGS "${VALA_CFLAGS} -Werror=implicit-function-declaration")
- set(VALA_CFLAGS "${VALA_CFLAGS} -Wno-incompatible-pointer-types")
-- set(VALA_CFLAGS "${VALA_CFLAGS} -Wno-discarded-qualifiers")
- set(VALA_CFLAGS "${VALA_CFLAGS} -Wno-deprecated-declarations")
- else ()
- set(VALA_CFLAGS "${VALA_CFLAGS} -w")
diff --git a/www/midori/files/patch-config__search b/www/midori/files/patch-config__search
deleted file mode 100644
index 2b05de9684cc..000000000000
--- a/www/midori/files/patch-config__search
+++ /dev/null
@@ -1,15 +0,0 @@
---- config/search.orig 2015-08-30 11:56:26 UTC
-+++ config/search
-@@ -16,6 +16,12 @@ text=Web Search
- uri=http://www.google.com/search?q=%s
- token=g
-
-+[FreshPorts]
-+name=FreshPorts
-+text=The changes made to the FreeBSD ports tree
-+uri=http://www.freshports.org/search.php?query=%s
-+token=fp
-+
- [Wikipedia]
- name=Wikipedia
- text=The free encyclopedia
diff --git a/www/midori/files/patch-extensions__external-download-manager.vala b/www/midori/files/patch-extensions__external-download-manager.vala
deleted file mode 100644
index e4d4cc526fee..000000000000
--- a/www/midori/files/patch-extensions__external-download-manager.vala
+++ /dev/null
@@ -1,37 +0,0 @@
---- extensions/external-download-manager.vala.orig 2015-08-30 11:56:26 UTC
-+++ extensions/external-download-manager.vala
-@@ -10,7 +10,7 @@
- */
-
- namespace EDM {
--#if !HAVE_WIN32
-+#if !HAVE_WIN32 || HAVE_GTK3
- [DBus (name = "net.launchpad.steadyflow.App")]
- interface SteadyflowInterface : GLib.Object {
- public abstract void AddFile (string url) throws IOError;
-@@ -203,6 +203,7 @@ namespace EDM {
- }
- }
-
-+#if HAVE_GTK3
- private class SteadyFlow : ExternalDownloadManager {
- public override bool download (DownloadRequest dlReq) {
- try {
-@@ -230,6 +231,7 @@ namespace EDM {
- }
- }
- #endif
-+#endif
-
- private class CommandLinePreferences : Gtk.Dialog {
- protected Gtk.Entry input;
-@@ -359,7 +361,9 @@ public Katze.Array extension_init () {
- var extensions = new Katze.Array( typeof (Midori.Extension));
- #if !HAVE_WIN32
- extensions.add_item (new EDM.Aria2 ());
-+ #if HAVE_GTK3
- extensions.add_item (new EDM.SteadyFlow ());
-+ #endif
- #endif
- extensions.add_item (new EDM.CommandLine ());
- return extensions;
diff --git a/www/midori/files/patch-extensions_adblock_widgets.vala b/www/midori/files/patch-extensions_adblock_widgets.vala
deleted file mode 100644
index 1b0a81e2bbc5..000000000000
--- a/www/midori/files/patch-extensions_adblock_widgets.vala
+++ /dev/null
@@ -1,14 +0,0 @@
---- extensions/adblock/widgets.vala.orig 2015-08-30 11:56:26 UTC
-+++ extensions/adblock/widgets.vala
-@@ -227,7 +227,11 @@ namespace Adblock {
- liststore.get (iter, 0, out sub);
- if (sub.mutable) {
- config.remove (sub);
-+#if VALA_0_36
-+ liststore.remove (ref iter);
-+#else
- liststore.remove (iter);
-+#endif
- return true;
- }
- }
diff --git a/www/midori/files/patch-extensions_apps.vala b/www/midori/files/patch-extensions_apps.vala
deleted file mode 100644
index 4e87e8823443..000000000000
--- a/www/midori/files/patch-extensions_apps.vala
+++ /dev/null
@@ -1,14 +0,0 @@
---- extensions/apps.vala.orig 2015-08-30 11:56:26 UTC
-+++ extensions/apps.vala
-@@ -265,7 +265,11 @@ namespace Apps {
- store.get (iter, 0, out launcher);
- try {
- launcher.file.trash (null);
-+#if VALA_0_36
-+ store.remove (ref iter);
-+#else
- store.remove (iter);
-+#endif
-
- string filename = Midori.Download.clean_filename (launcher.name);
- #if HAVE_WIN32
diff --git a/www/midori/files/patch-extensions_history-list.vala b/www/midori/files/patch-extensions_history-list.vala
deleted file mode 100644
index 604d312f9836..000000000000
--- a/www/midori/files/patch-extensions_history-list.vala
+++ /dev/null
@@ -1,14 +0,0 @@
---- extensions/history-list.vala.orig 2015-08-30 11:56:26 UTC
-+++ extensions/history-list.vala
-@@ -223,7 +223,11 @@ namespace HistoryList {
- FixMe: the retrun value of `Gtk.ListStore.remove` should be checked
- Note: in some cases the return value of `Gtk.ListStore.remove` is wrong
- */
-+#if VALA_0_36
-+ model.remove (ref iter);
-+#else
- model.remove (iter);
-+#endif
- this.browser.close_tab (view);
- if (length > 2)
- this.resize_treeview ();
diff --git a/www/midori/files/patch-extensions_notes.vala b/www/midori/files/patch-extensions_notes.vala
deleted file mode 100644
index bf3265cb10b0..000000000000
--- a/www/midori/files/patch-extensions_notes.vala
+++ /dev/null
@@ -1,14 +0,0 @@
---- extensions/notes.vala.orig 2015-08-30 11:56:26 UTC
-+++ extensions/notes.vala
-@@ -116,7 +116,11 @@ namespace ClipNotes {
- if (current_note == note) {
- current_note = null;
- }
-+#if VALA_0_36
-+ notes_list_store.remove (ref iter);
-+#else
- notes_list_store.remove (iter);
-+#endif
- break;
- }
- } while (notes_list_store.iter_next (ref iter));
diff --git a/www/midori/files/patch-extensions_transfers.vala b/www/midori/files/patch-extensions_transfers.vala
deleted file mode 100644
index 619410857c48..000000000000
--- a/www/midori/files/patch-extensions_transfers.vala
+++ /dev/null
@@ -1,27 +0,0 @@
---- extensions/transfers.vala.orig 2015-08-30 11:56:26 UTC
-+++ extensions/transfers.vala
-@@ -275,7 +275,11 @@ namespace Transfers {
- Transfer found;
- store.get (iter, 0, out found);
- if (transfer == found) {
-+#if VALA_0_36
-+ store.remove (ref iter);
-+#else
- store.remove (iter);
-+#endif
- break;
- }
- } while (store.iter_next (ref iter));
-@@ -455,7 +459,11 @@ namespace Transfers {
- if (notifications.length () == 1)
- msg = _("The file '<b>%s</b>' has been downloaded.").printf (filename);
- else
-- msg = _("'<b>%s</b>' and %d other files have been downloaded.").printf (filename, notifications.length ());
-+#if VALA_0_36
-+ msg = _("'<b>%s</b>' and %d other files have been downloaded.").printf (filename, (int) notifications.length ());
-+#else
-+ msg = _("'<b>%s</b>' and %d other files have been downloaded.").printf (filename, notifications.length ());
-+#endif
- get_app ().send_notification (_("Transfer completed"), msg);
- notifications = new GLib.List<string> ();
- }
diff --git a/www/midori/files/patch-midori__midori-stock.h b/www/midori/files/patch-midori__midori-stock.h
deleted file mode 100644
index 66bf069f6503..000000000000
--- a/www/midori/files/patch-midori__midori-stock.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- midori/midori-stock.h.orig 2015-08-30 11:56:26 UTC
-+++ midori/midori-stock.h
-@@ -20,12 +20,12 @@
- #define MIDORI_STOCK_WEB_BROWSER "web-browser"
- #define STOCK_NEWS_FEED "internet-news-reader"
- #define STOCK_STYLE "preferences-desktop-theme"
--#define MIDORI_STOCK_TRANSFER "package"
--#define MIDORI_STOCK_PLUGINS "application-x-shockwave-flash"
-+#define MIDORI_STOCK_TRANSFER "package-x-generic"
-+#define MIDORI_STOCK_PLUGINS "application-x-addon"
- #define STOCK_BOOKMARK_ADD "bookmark-new"
- #define STOCK_IMAGE "image-x-generic"
- #define STOCK_NETWORK_OFFLINE "network-offline"
--#define STOCK_SCRIPT "text-x-javascript"
-+#define STOCK_SCRIPT "text-x-script"
- #define STOCK_SEND "mail-send"
- #define STOCK_TAB_NEW "tab-new"
- #define STOCK_USER_TRASH "user-trash"
diff --git a/www/midori/files/patch-midori_midori-notebook.vala b/www/midori/files/patch-midori_midori-notebook.vala
deleted file mode 100644
index 9462f2083fa0..000000000000
--- a/www/midori/files/patch-midori_midori-notebook.vala
+++ /dev/null
@@ -1,29 +0,0 @@
---- midori/midori-notebook.vala.orig 2015-08-30 11:56:26 UTC
-+++ midori/midori-notebook.vala
-@@ -10,7 +10,7 @@
- */
-
- namespace Midori {
-- protected class Tally : Gtk.EventBox {
-+ internal class Tally : Gtk.EventBox {
- public Midori.Tab tab { get; set; }
- Gtk.Spinner spinner;
- public Gtk.Label label;
-@@ -22,7 +22,7 @@ namespace Midori {
- public bool close_button_left { get; set; default = false; }
- public bool close_button_visible { get; set; default = false; }
-
-- protected Tally (Midori.Tab tab) {
-+ internal Tally (Midori.Tab tab) {
- this.tab = tab;
- box = new Gtk.HBox (false, 1);
- add (box);
-@@ -155,7 +155,7 @@ namespace Midori {
- int last_tab_size = 0;
-
- #if !HAVE_GTK3
-- static const string style_fixup = """
-+ const string style_fixup = """
- style "midori-close-button-style"
- {
- GtkWidget::focus-padding = 0
diff --git a/www/midori/pkg-plist b/www/midori/pkg-plist
index 82edb3820d13..c79281df55d3 100644
--- a/www/midori/pkg-plist
+++ b/www/midori/pkg-plist
@@ -1,69 +1,33 @@
bin/midori
-etc/xdg/midori/extensions/adblock/config
-etc/xdg/midori/search
-%%GIR%%lib/girepository-1.0/Katze-%%VERSION%%.typelib
-%%GIR%%lib/girepository-1.0/Midori-%%VERSION%%.typelib
+lib/girepository-1.0/Midori-0.6.typelib
lib/libmidori-core.so
-lib/libmidori-core.so.0.0.0
-lib/libmidori-core.so.1
-lib/midori/libabout.so
+lib/libmidori-core.so.0
+lib/libmidori-core.so.0.6
+lib/midori/adblock.plugin
+lib/midori/bookmarks.plugin
+lib/midori/colorful-tabs.plugin
+lib/midori/libactivatable.so
lib/midori/libadblock.so
-lib/midori/libaddons.so
-lib/midori/libapps.so
+lib/midori/libbookmarks.so
lib/midori/libcolorful-tabs.so
-lib/midori/libcookie-manager.so
-lib/midori/libcookie-permissions.so
-lib/midori/libcopy-tabs.so
-lib/midori/libdelayed-load.so
-lib/midori/libdevpet.so
-lib/midori/libdomain-keys.so
-lib/midori/libexternal-download-manager.so
-lib/midori/libfeed-panel.so
-lib/midori/libflummi.so
-lib/midori/libformhistory.so
-lib/midori/libhistory-list.so
-lib/midori/libmouse-gestures.so
-lib/midori/libnojs.so
-lib/midori/libnotes.so
-lib/midori/libnsplugin-manager.so
-lib/midori/libopen-with.so
-lib/midori/libshortcuts.so
+lib/midori/libsession.so
lib/midori/libstatus-clock.so
lib/midori/libstatusbar-features.so
-lib/midori/libtab-panel.so
-lib/midori/libtabby.so
-lib/midori/libtabs-minimized.so
-lib/midori/libtoolbar-editor.so
-lib/midori/libtransfers.so
-lib/midori/libwebmedia-now-playing.so
+lib/midori/session.plugin
+lib/midori/status-clock.plugin
+lib/midori/statusbar-features.plugin
share/appdata/midori.appdata.xml
-share/applications/midori-private.desktop
-share/applications/midori.desktop
-%%DOCSDIR%%/AUTHORS
+share/applications/org.midori_browser.Midori.desktop
%%DOCSDIR%%/COPYING
-%%DOCSDIR%%/ChangeLog
-%%DOCSDIR%%/EXPAT
-%%DOCSDIR%%/README
-%%DOCSDIR%%/faq.css
-%%DOCSDIR%%/faq.html
-%%GIR%%share/gir-1.0/Katze-%%VERSION%%.gir
-%%GIR%%share/gir-1.0/Midori-%%VERSION%%.gir
+share/gir-1.0/Midori-0.6.gir
share/icons/hicolor/16x16/apps/midori.png
-share/icons/hicolor/16x16/categories/extension.png
-share/icons/hicolor/16x16/status/internet-news-reader.png
share/icons/hicolor/22x22/apps/midori.png
-share/icons/hicolor/22x22/categories/extension.png
-share/icons/hicolor/22x22/status/internet-news-reader.png
-share/icons/hicolor/24x24/status/adblock-blocked.svg
-share/icons/hicolor/24x24/status/adblock-disabled.svg
-share/icons/hicolor/24x24/status/adblock-enabled.svg
share/icons/hicolor/scalable/apps/midori.svg
-share/icons/hicolor/scalable/categories/extension.svg
-share/icons/hicolor/scalable/status/internet-news-reader.svg
share/locale/af/LC_MESSAGES/midori.mo
share/locale/am/LC_MESSAGES/midori.mo
share/locale/ar/LC_MESSAGES/midori.mo
share/locale/ast/LC_MESSAGES/midori.mo
+share/locale/az/LC_MESSAGES/midori.mo
share/locale/be/LC_MESSAGES/midori.mo
share/locale/bg/LC_MESSAGES/midori.mo
share/locale/bn/LC_MESSAGES/midori.mo
@@ -123,9 +87,11 @@ share/locale/sq/LC_MESSAGES/midori.mo
share/locale/sr/LC_MESSAGES/midori.mo
share/locale/sr@latin/LC_MESSAGES/midori.mo
share/locale/sv/LC_MESSAGES/midori.mo
+share/locale/szl/LC_MESSAGES/midori.mo
share/locale/ta/LC_MESSAGES/midori.mo
share/locale/te/LC_MESSAGES/midori.mo
share/locale/th/LC_MESSAGES/midori.mo
+share/locale/tl/LC_MESSAGES/midori.mo
share/locale/tr/LC_MESSAGES/midori.mo
share/locale/ug/LC_MESSAGES/midori.mo
share/locale/uk/LC_MESSAGES/midori.mo
@@ -135,24 +101,3 @@ share/locale/vi/LC_MESSAGES/midori.mo
share/locale/zh_CN/LC_MESSAGES/midori.mo
share/locale/zh_HK/LC_MESSAGES/midori.mo
share/locale/zh_TW/LC_MESSAGES/midori.mo
-%%DATADIR%%/res/about.css
-%%DATADIR%%/res/adblock.list
-%%DATADIR%%/res/adblock/element_hider.js
-%%DATADIR%%/res/autosuggestcontrol.css
-%%DATADIR%%/res/autosuggestcontrol.js
-%%DATADIR%%/res/bookmarks/Create.sql
-%%DATADIR%%/res/bookmarks/Import_old_db_bookmarks.sql
-%%DATADIR%%/res/error.html
-%%DATADIR%%/res/flummi/Create.sql
-%%DATADIR%%/res/forms/Create.sql
-%%DATADIR%%/res/gtk3.css
-%%DATADIR%%/res/history/Create.sql
-%%DATADIR%%/res/history/Day.sql
-%%DATADIR%%/res/logo-shade.png
-%%DATADIR%%/res/nojs/nojs-statusicon-allowed.png
-%%DATADIR%%/res/nojs/nojs-statusicon-denied.png
-%%DATADIR%%/res/nojs/nojs-statusicon-mixed.png
-%%DATADIR%%/res/notes/Create.sql
-%%DATADIR%%/res/speeddial-head.html
-%%DATADIR%%/res/tabby/Create.sql
-%%DATADIR%%/res/tabby/Update1.sql