aboutsummaryrefslogtreecommitdiff
path: root/www/mimetex/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2012-09-17 20:47:33 +0000
committerNicola Vitale <nivit@FreeBSD.org>2012-09-17 20:47:33 +0000
commitc329eaad28ec813f4eda6ef574968f596d3bbc68 (patch)
treefc23100a41472458badd6815b1bce0a4b931efa8 /www/mimetex/Makefile
parente5bc77843a079d9de42e04bde8cc119effcfda88 (diff)
downloadports-c329eaad28ec813f4eda6ef574968f596d3bbc68.tar.gz
ports-c329eaad28ec813f4eda6ef574968f596d3bbc68.zip
Notes
Diffstat (limited to 'www/mimetex/Makefile')
-rw-r--r--www/mimetex/Makefile60
1 files changed, 20 insertions, 40 deletions
diff --git a/www/mimetex/Makefile b/www/mimetex/Makefile
index ef8a1b63e884..55addfbe01e2 100644
--- a/www/mimetex/Makefile
+++ b/www/mimetex/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: mimetex
-# Date created: 2006-02-03
-# Whom: Nicola Vitale <nivit@email.it>
-#
+# Created by: Nicola Vitale <nivit@email.it>
# $FreeBSD$
-#
PORTNAME= mimetex
-PORTVERSION= 20080906.1.70
-PORTREVISION= 4
+PORTVERSION= 20120331.1.74
+PORTREVISION= 0
CATEGORIES= www math
-MASTER_SITES= http://nivi.interfree.it/distfiles/${DIST_SUBDIR}/ \
+MASTER_SITES= LOCAL/nivit/${PORTNAME}/${PORTVERSION}/ \
http://www.forkosh.com/
DISTNAME= ${PORTNAME}
DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
@@ -17,38 +13,28 @@ DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= nivit@FreeBSD.org
COMMENT= A CGI script that lets you embed LaTeX math in your HTML pages
+LICENSE= GPLv3
+
NO_WRKSUBDIR= yes
-USE_APACHE= 22+
USE_ZIP= yes
-.include <bsd.port.pre.mk>
-
-FETCH_ARGS= -rR # see PR bin/76134
-LN_OPTS= -sf
-
-CGI_BIN= ${WWWDIR}/cgi-bin
-CGI_PRG= ${PORTNAME}.cgi
-WWW_DIR= ${WWWDIR}/data
-
-PLIST_DIRSTRY+= www/cgi-bin www/data
-
-PLIST_SUB= CGI_BIN="${CGI_BIN:S,^${PREFIX}/,,}" \
- WWW_DIR="${WWW_DIR:S,^${PREFIX}/,,}"
+OPTIONS_DEFINE= ANTIALIASING DOCS STATIC
+OPTIONS_DEFAULT= ANTIALIASING
+DESC_ANTIALIASING= Use image format with anti-aliasing
+DESC_STATIC= Possible use of mimetex on another machine
PORTDOCS= ${PORTNAME}.html
-SUB_FILES= pkg-message
-SUB_LIST= PORTDOCS=${PORTDOCS} WWW_DIR=${WWW_DIR}
-
+.include <bsd.port.options.mk>
# usefull if you run mimetex on another machine
-.if defined(WITH_STATIC)
+.if ${PORT_OPTIONS:MSTATIC}
STATIC_MIMETEX= -static
.endif
# anti-aliasing no/yes
-.if defined(WITHOUT_ANTIALIASING)
-IMAGES_TYPE= -DGIF
-.else
+.if ${PORT_OPTIONS:MANTIALIASING}
IMAGES_TYPE= -DAA
+.else
+IMAGES_TYPE= -DGIF
.endif
# other options (see mimetex.c or online documentation)
# example: make install USER_OPTIONS='-DCACHEPATH=\"/tmp\" -DDISPLAYSIZE=10'
@@ -56,19 +42,13 @@ USER_OPTIONS?=
do-build:
cd ${WRKDIR};\
- ${CC} ${CFLAGS} ${STATIC_MIMETEX} ${IMAGES_TYPE} ${USER_OPTIONS} mimetex.c gifsave.c -lm -o ${CGI_PRG}
-
+ ${CC} ${CFLAGS} ${STATIC_MIMETEX} ${IMAGES_TYPE} ${USER_OPTIONS} mimetex.c gifsave.c -lm -o mimetex.cgi
do-install:
- ${MKDIR} ${CGI_BIN}
- ${INSTALL_PROGRAM} ${WRKSRC}/${CGI_PRG} ${CGI_BIN}/${CGI_PRG}
-.if !defined(NOPORTDOCS)
+ ${MKDIR} ${WWWDIR}/cgi-bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/mimetex.cgi ${WWWDIR}/cgi-bin/mimetex.cgi
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
- ${MKDIR} ${WWW_DIR}
- ${LN} ${LN_OPTS} ${DOCSDIR}/${PORTDOCS} ${WWW_DIR}/index.html
-
-post-install:
- ${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>