aboutsummaryrefslogtreecommitdiff
path: root/www/mini_httpd
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2002-07-30 12:39:01 +0000
committerStefan Eßer <se@FreeBSD.org>2002-07-30 12:39:01 +0000
commit04df79274960e81297f5f6b5f771d453fef7abdf (patch)
tree7a5cf377c8749443aa757a6b1142b9098ddd5516 /www/mini_httpd
parent3180eb89e49010af3b0859918533760dca8c81c2 (diff)
downloadports-04df79274960e81297f5f6b5f771d453fef7abdf.tar.gz
ports-04df79274960e81297f5f6b5f771d453fef7abdf.zip
Notes
Diffstat (limited to 'www/mini_httpd')
-rw-r--r--www/mini_httpd/Makefile36
-rw-r--r--www/mini_httpd/distinfo2
-rw-r--r--www/mini_httpd/files/patch-Makefile26
-rw-r--r--www/mini_httpd/pkg-comment1
-rw-r--r--www/mini_httpd/pkg-descr19
-rw-r--r--www/mini_httpd/pkg-plist5
6 files changed, 89 insertions, 0 deletions
diff --git a/www/mini_httpd/Makefile b/www/mini_httpd/Makefile
new file mode 100644
index 000000000000..3fcfaae8e323
--- /dev/null
+++ b/www/mini_httpd/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mini_httpd
+# Date created: 24 July 2002
+# Whom: se
+#
+# $FreeBSD$
+#
+
+PORTNAME= mini_httpd
+PORTVERSION= 1.17b1
+CATEGORIES= www
+MASTER_SITES= http://www.acme.com/software/mini_httpd/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/beta/}
+
+MAINTAINER= se@FreeBSD.org
+
+.ifndef NO_SSL
+USE_OPENSSL= YES
+.endif
+
+MAN8= mini_httpd.8 htpasswd.8
+
+post-build:
+ -${MV} ${WRKSRC}/htpasswd.1 ${WRKSRC}/htpasswd.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mini_httpd ${PREFIX}/sbin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/htpasswd ${PREFIX}/sbin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/mini_httpd_wrapper ${PREFIX}/sbin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/mini_httpd.sh ${PREFIX}/etc/rc.d/
+ @for file in ${MAN8}; \
+ do \
+ ${INSTALL_MAN} ${WRKSRC}/$$file ${MAN8PREFIX}/man/man8/; \
+ done
+ ${INSTALL_DATA} ${WRKSRC}/mini_httpd.cnf ${PREFIX}/etc/mini_httpd.cnf.sample
+
+.include <bsd.port.mk>
diff --git a/www/mini_httpd/distinfo b/www/mini_httpd/distinfo
new file mode 100644
index 000000000000..cb2d34c9b751
--- /dev/null
+++ b/www/mini_httpd/distinfo
@@ -0,0 +1,2 @@
+MD5 (mini_httpd-1.17beta1.tar.gz) = ec4374b4c91b6e787f8ba2fed615e60f
+SIZE (mini_httpd-1.17beta1.tar.gz) = 40172
diff --git a/www/mini_httpd/files/patch-Makefile b/www/mini_httpd/files/patch-Makefile
new file mode 100644
index 000000000000..fba62eb16c69
--- /dev/null
+++ b/www/mini_httpd/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.orig Thu Jan 3 00:07:27 2002
++++ Makefile Tue Jul 30 13:38:04 2002
+@@ -14,17 +14,18 @@
+ # http://www.openssl.org/ Make sure the SSL_TREE definition points to the
+ # tree with your OpenSSL installation - depending on how you installed it,
+ # it may be in /usr/local instead of /usr/local/ssl.
++.ifndef NO_OPENSSL
+ #SSL_TREE = /usr/local/ssl
+-#SSL_DEFS = -DUSE_SSL
++SSL_DEFS = -DUSE_SSL
+ #SSL_INC = -I${SSL_TREE}/include
+-#SSL_LIBS = -L${SSL_TREE}/lib -lssl -lcrypto
+-
++SSL_LIBS = -lssl -lcrypto
++.endif
+
+ BINDIR = /usr/local/sbin
+ MANDIR = /usr/local/man
+-CC = gcc
++#CC = gcc
+ CDEFS = ${SSL_DEFS} ${SSL_INC}
+-CFLAGS = -O ${CDEFS}
++CFLAGS += ${CDEFS}
+ #CFLAGS = -g ${CDEFS}
+ LDFLAGS = -s
+ #LDFLAGS = -g
diff --git a/www/mini_httpd/pkg-comment b/www/mini_httpd/pkg-comment
new file mode 100644
index 000000000000..aa8f1422966f
--- /dev/null
+++ b/www/mini_httpd/pkg-comment
@@ -0,0 +1 @@
+Small HTTP server with support for GET, HEAD, POST, CGI, SSL, IPv6
diff --git a/www/mini_httpd/pkg-descr b/www/mini_httpd/pkg-descr
new file mode 100644
index 000000000000..95ff316beb86
--- /dev/null
+++ b/www/mini_httpd/pkg-descr
@@ -0,0 +1,19 @@
+Mini_httpd is a small HTTP server. Its performance is not great, but
+for low or medium traffic sites it's quite adequate. It implements
+all the basic features of an HTTP server, including:
+
+ - GET, HEAD, and POST methods.
+ - CGI.
+ - Basic authentication.
+ - Security against ".." filename snooping.
+ - The common MIME types.
+ - Trailing-slash redirection.
+ - index.html, index.htm, index.cgi
+ - Directory listings.
+ - Multihoming / virtual hosting.
+ - Standard logging.
+ - Custom error pages.
+
+It can also be configured to do SSL/HTTPS and IPv6.
+
+WWW: http://www.acme.com/software/mini_httpd/
diff --git a/www/mini_httpd/pkg-plist b/www/mini_httpd/pkg-plist
new file mode 100644
index 000000000000..b42c50ec2261
--- /dev/null
+++ b/www/mini_httpd/pkg-plist
@@ -0,0 +1,5 @@
+etc/mini_httpd.cnf.sample
+etc/rc.d/mini_httpd.sh
+sbin/htpasswd
+sbin/mini_httpd
+sbin/mini_httpd_wrapper