aboutsummaryrefslogtreecommitdiff
path: root/www/minio/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-03-27 15:55:37 +0000
committerSteve Wills <swills@FreeBSD.org>2020-03-27 15:55:37 +0000
commitdeb85cc35d2351b1dc312d39cb5e8bbec92566ff (patch)
tree3c605baea084325971cbd45558b005f7eec0e9c9 /www/minio/Makefile
parentada94293c816df3fd5414dec4b6d94116eff2165 (diff)
downloadports-deb85cc35d2351b1dc312d39cb5e8bbec92566ff.tar.gz
ports-deb85cc35d2351b1dc312d39cb5e8bbec92566ff.zip
www/minio: Update to RELEASE.2020-03-19T21-49-00Z
PR: 244386 Submitted by: Dmitry Wagin <dmitry.wagin@ya.ru>
Notes
Notes: svn path=/head/; revision=529265
Diffstat (limited to 'www/minio/Makefile')
-rw-r--r--www/minio/Makefile37
1 files changed, 21 insertions, 16 deletions
diff --git a/www/minio/Makefile b/www/minio/Makefile
index 6116eb828b88..c4f537ea58cd 100644
--- a/www/minio/Makefile
+++ b/www/minio/Makefile
@@ -2,7 +2,6 @@
PORTNAME= minio
PORTVERSION= ${GH_TAGNAME:S/RELEASE.//:S/Z//:S/T/-/:S/-/./g}
-PORTREVISION= 1
CATEGORIES= www
MAINTAINER= swills@FreeBSD.org
@@ -13,8 +12,8 @@ LICENSE= APACHE20
USES= compiler go:modules
USE_GITHUB= yes
-GHTAG= RELEASE.2020-01-03T19-12-21Z
-COMMIT_ID= b00cda8ad49ed0defa9df5e7230f8b536b8ccb17
+GHTAG= RELEASE.2020-03-19T21-49-00Z
+COMMIT_ID= b1a2169dcc5b4febc4edf1f82407e28b6f695475
GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
Azure:azure-pipeline-go:v0.2.1:azure_azure_pipeline_go/vendor/github.com/Azure/azure-pipeline-go \
Azure:azure-storage-blob-go:v0.8.0:azure_azure_storage_blob_go/vendor/github.com/Azure/azure-storage-blob-go \
@@ -22,12 +21,13 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
StackExchange:wmi:cbe66965904d:stackexchange_wmi/vendor/github.com/StackExchange/wmi \
alecthomas:participle:v0.2.1:alecthomas_participle/vendor/github.com/alecthomas/participle \
aliyun:aliyun-oss-go-sdk:86c17b95fcd5:aliyun_aliyun_oss_go_sdk/vendor/github.com/aliyun/aliyun-oss-go-sdk \
- apache:thrift:v0.12.0:apache_thrift/vendor/git.apache.org/thrift.git \
+ apache:thrift:v0.13.0:apache_thrift/vendor/git.apache.org/thrift.git \
aws:aws-sdk-go:v1.20.21:aws_aws_sdk_go/vendor/github.com/aws/aws-sdk-go \
bcicen:jstream:16c1f8af81c2:bcicen_jstream/vendor/github.com/bcicen/jstream \
beevik:ntp:v0.2.0:beevik_ntp/vendor/github.com/beevik/ntp \
beorn7:perks:3a771d992973:beorn7_perks/vendor/github.com/beorn7/perks \
census-instrumentation:opencensus-go:v0.21.0:census_instrumentation_opencensus_go/vendor/go.opencensus.io \
+ cespare:xxhash:v2.1.1:cespare_xxhash/vendor/github.com/cespare/xxhash/v2 \
cheggaaa:pb:v1.0.28:cheggaaa_pb/vendor/github.com/cheggaaa/pb \
coredns:coredns:v1.4.0:coredns_coredns/vendor/github.com/coredns/coredns \
coreos:etcd:v3.3.12:coreos_etcd/vendor/github.com/coreos/etcd \
@@ -51,13 +51,14 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
gogo:protobuf:v1.2.1:gogo_protobuf/vendor/github.com/gogo/protobuf \
golang:appengine:v1.6.0:golang_appengine/vendor/google.golang.org/appengine \
golang:crypto:497ca9f6d64f:golang_crypto/vendor/golang.org/x/crypto \
- golang:net:83d349e8ac1a:golang_net/vendor/golang.org/x/net \
+ golang:net:aa69164e4478:golang_net/vendor/golang.org/x/net \
golang:oauth2:9f3314589c9a:golang_oauth2/vendor/golang.org/x/oauth2 \
golang:protobuf:v1.3.2:golang_protobuf/vendor/github.com/golang/protobuf \
golang:snappy:v0.0.1:golang_snappy/vendor/github.com/golang/snappy \
- golang:sys:33540a1f6037:golang_sys/vendor/golang.org/x/sys \
+ golang:sys:0a153f010e69:golang_sys/vendor/golang.org/x/sys \
golang:text:v0.3.2:golang_text/vendor/golang.org/x/text \
golang:time:9d24e82272b4:golang_time/vendor/golang.org/x/time \
+ golang:tools:31e00f45c22e:golang_tools/vendor/golang.org/x/tools \
gomodule:redigo:v2.0.0:gomodule_redigo/vendor/github.com/gomodule/redigo \
google:go-genproto:d00d292a067c:google_go_genproto/vendor/google.golang.org/genproto \
googleapis:gax-go:v2.0.4:googleapis_gax_go/vendor/github.com/googleapis/gax-go \
@@ -76,7 +77,7 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
hashicorp:go-uuid:v1.0.1:hashicorp_go_uuid/vendor/github.com/hashicorp/go-uuid \
hashicorp:golang-lru:v0.5.1:hashicorp_golang_lru/vendor/github.com/hashicorp/golang-lru \
hashicorp:hcl:v1.0.0:hashicorp_hcl/vendor/github.com/hashicorp/hcl \
- hashicorp:vault:v1.3.1:hashicorp_vault/vendor/github.com/hashicorp/vault \
+ hashicorp:vault:v1.3.4:hashicorp_vault/vendor/github.com/hashicorp/vault \
inconshreveable:go-update:8152e7eb6ccf:inconshreveable_go_update/vendor/github.com/inconshreveable/go-update \
jcmturner:aescts:v1.0.1:jcmturner_aescts/vendor/gopkg.in/jcmturner/aescts.v1 \
jcmturner:dnsutils:v1.0.1:jcmturner_dnsutils/vendor/gopkg.in/jcmturner/dnsutils.v1 \
@@ -85,9 +86,9 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
jcmturner:gokrb5:v7.2.3:jcmturner_gokrb5/vendor/gopkg.in/jcmturner/gokrb5.v7 \
jcmturner:rpc:v1.1.0:jcmturner_rpc/vendor/gopkg.in/jcmturner/rpc.v1 \
jmespath:go-jmespath:c2b33e8439af:jmespath_go_jmespath/vendor/github.com/jmespath/go-jmespath \
- json-iterator:go:v1.1.7:json_iterator_go/vendor/github.com/json-iterator/go \
- klauspost:compress:v1.9.4:klauspost_compress/vendor/github.com/klauspost/compress \
- klauspost:cpuid:v1.2.1:klauspost_cpuid/vendor/github.com/klauspost/cpuid \
+ json-iterator:go:v1.1.9:json_iterator_go/vendor/github.com/json-iterator/go \
+ klauspost:compress:v1.10.3:klauspost_compress/vendor/github.com/klauspost/compress \
+ klauspost:cpuid:v1.2.2:klauspost_cpuid/vendor/github.com/klauspost/cpuid \
klauspost:pgzip:v1.2.1:klauspost_pgzip/vendor/github.com/klauspost/pgzip \
klauspost:readahead:v1.3.1:klauspost_readahead/vendor/github.com/klauspost/readahead \
klauspost:reedsolomon:v1.9.3:klauspost_reedsolomon/vendor/github.com/klauspost/reedsolomon \
@@ -106,12 +107,14 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
minio:hdfs:v3.0.1:minio_hdfs/vendor/github.com/minio/hdfs/v3 \
minio:highwayhash:v1.0.0:minio_highwayhash/vendor/github.com/minio/highwayhash \
minio:lsync:v1.0.1:minio_lsync/vendor/github.com/minio/lsync \
- minio:minio-go:v6.0.44:minio_minio_go/vendor/github.com/minio/minio-go/v6 \
- minio:parquet-go:20b3c07bcd2c:minio_parquet_go/vendor/github.com/minio/parquet-go \
+ minio:minio-go:b882ba63d570:minio_minio_go/vendor/github.com/minio/minio-go/v6 \
+ minio:parquet-go:a1e49702e174:minio_parquet_go/vendor/github.com/minio/parquet-go \
minio:sha256-simd:v0.1.1:minio_sha256_simd/vendor/github.com/minio/sha256-simd \
+ minio:simdjson-go:b17fe061ea37:minio_simdjson_go/vendor/github.com/minio/simdjson-go \
minio:sio:v0.2.0:minio_sio/vendor/github.com/minio/sio \
mitchellh:go-homedir:v1.1.0:mitchellh_go_homedir/vendor/github.com/mitchellh/go-homedir \
mitchellh:mapstructure:v1.1.2:mitchellh_mapstructure/vendor/github.com/mitchellh/mapstructure \
+ mmcloughlin:avo:6df701fe672f:mmcloughlin_avo/vendor/github.com/mmcloughlin/avo \
modern-go:concurrent:bacd9c7ef1dd:modern_go_concurrent/vendor/github.com/modern-go/concurrent \
modern-go:reflect2:v1.0.1:modern_go_reflect2/vendor/github.com/modern-go/reflect2 \
nats-io:jwt:v0.3.2:nats_io_jwt/vendor/github.com/nats-io/jwt \
@@ -123,9 +126,9 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
ncw:directio:v1.0.5:ncw_directio/vendor/github.com/ncw/directio \
nsqio:go-nsq:v1.0.7:nsqio_go_nsq/vendor/github.com/nsqio/go-nsq \
olivere:elastic:v5.0.80:olivere_elastic/vendor/gopkg.in/olivere/elastic.v5 \
- pierrec:lz4:v2.2.6:pierrec_lz4/vendor/github.com/pierrec/lz4 \
+ philhofer:fwd:v1.0.0:philhofer_fwd/vendor/github.com/philhofer/fwd \
+ pierrec:lz4:v2.4.0:pierrec_lz4/vendor/github.com/pierrec/lz4 \
pkg:errors:v0.8.1:pkg_errors/vendor/github.com/pkg/errors \
- pkg:profile:v1.3.0:pkg_profile/vendor/github.com/pkg/profile \
prometheus:client_golang:3c4408c8b829:prometheus_client_golang/vendor/github.com/prometheus/client_golang \
prometheus:client_model:fd36f4220a90:prometheus_client_model/vendor/github.com/prometheus/client_model \
prometheus:common:v0.2.0:prometheus_common/vendor/github.com/prometheus/common \
@@ -135,7 +138,7 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
rs:cors:v1.6.0:rs_cors/vendor/github.com/rs/cors \
ryanuber:go-glob:v1.0.0:ryanuber_go_glob/vendor/github.com/ryanuber/go-glob \
secure-io:sio-go:v0.3.0:secure_io_sio_go/vendor/github.com/secure-io/sio-go \
- shirou:gopsutil:v2.20.1:shirou_gopsutil/vendor/github.com/shirou/gopsutil \
+ shirou:gopsutil:v2.18.12:shirou_gopsutil/vendor/github.com/shirou/gopsutil \
sirupsen:logrus:v1.4.2:sirupsen_logrus/vendor/github.com/sirupsen/logrus \
skyrings:skyring-common:d1c0bb1cbd5e:skyrings_skyring_common/vendor/github.com/skyrings/skyring-common \
square:go-jose:v2.3.1:square_go_jose/vendor/gopkg.in/square/go-jose.v2 \
@@ -144,9 +147,11 @@ GH_TUPLE= ${PORTNAME}:${PORTNAME}:${GHTAG}:DEFAULT \
tidwall:match:v1.0.1:tidwall_match/vendor/github.com/tidwall/match \
tidwall:pretty:v1.0.0:tidwall_pretty/vendor/github.com/tidwall/pretty \
tidwall:sjson:v1.0.4:tidwall_sjson/vendor/github.com/tidwall/sjson \
+ tinylib:msgp:v1.1.1:tinylib_msgp/vendor/github.com/tinylib/msgp \
uber-go:atomic:v1.3.2:uber_go_atomic/vendor/go.uber.org/atomic \
valyala:tcplisten:ceec8f93295a:valyala_tcplisten/vendor/github.com/valyala/tcplisten
-GO_BUILDFLAGS= -ldflags='\
+
+GO_BUILDFLAGS= -ldflags=' \
-X github.com/minio/minio/cmd.Version=${GH_TAGNAME:C/RELEASE\.//:C|(..)-(..)-(..)Z|\1:\2:\3Z|} \
-X github.com/minio/minio/cmd.ReleaseTag=${GH_TAGNAME} \
-X github.com/minio/minio/cmd.CommitID=${COMMIT_ID} \