aboutsummaryrefslogtreecommitdiff
path: root/www/miniserve/Makefile
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2021-03-25 08:53:38 +0000
committerMikael Urankar <mikael@FreeBSD.org>2021-03-25 08:53:38 +0000
commitdae2394d88d711c0bd6cc859240d6200c0863bdf (patch)
tree37ce5dbc15a9f43502c903e2551d451d77f85ad7 /www/miniserve/Makefile
parent4142b854b4c24a940a6ffcf87c6498b9d22c381c (diff)
downloadports-dae2394d88d711c0bd6cc859240d6200c0863bdf.tar.gz
ports-dae2394d88d711c0bd6cc859240d6200c0863bdf.zip
Notes
Diffstat (limited to 'www/miniserve/Makefile')
-rw-r--r--www/miniserve/Makefile94
1 files changed, 43 insertions, 51 deletions
diff --git a/www/miniserve/Makefile b/www/miniserve/Makefile
index 40ac710ad2f0..c4e82e0ac007 100644
--- a/www/miniserve/Makefile
+++ b/www/miniserve/Makefile
@@ -2,7 +2,7 @@
PORTNAME= miniserve
DISTVERSIONPREFIX= v
-DISTVERSION= 0.11.0
+DISTVERSION= 0.12.0
CATEGORIES= www
MAINTAINER= mikael@FreeBSD.org
@@ -33,21 +33,19 @@ CARGO_CRATES= actix-codec-0.3.0 \
actix-web-3.3.2 \
actix-web-codegen-0.4.0 \
actix-web-httpauth-0.5.0 \
- addr2line-0.14.1 \
- adler-1.0.2 \
adler32-1.2.0 \
ahash-0.3.8 \
aho-corasick-0.7.15 \
- alphanumeric-sort-1.4.0 \
+ alphanumeric-sort-1.4.1 \
ansi_term-0.11.0 \
+ ansi_term-0.12.1 \
assert_cmd-1.0.3 \
assert_fs-1.0.1 \
- async-trait-0.1.42 \
+ async-trait-0.1.48 \
atty-0.2.14 \
autocfg-0.1.7 \
autocfg-1.0.1 \
awc-2.0.3 \
- backtrace-0.3.56 \
base-x-0.2.8 \
base64-0.12.3 \
base64-0.13.0 \
@@ -61,7 +59,7 @@ CARGO_CRATES= actix-codec-0.3.0 \
bstr-0.2.15 \
buf-min-0.4.0 \
bumpalo-3.6.1 \
- byteorder-1.4.2 \
+ byteorder-1.4.3 \
bytes-0.5.6 \
bytes-1.0.1 \
bytesize-1.0.1 \
@@ -77,13 +75,14 @@ CARGO_CRATES= actix-codec-0.3.0 \
cloudabi-0.0.3 \
codemap-0.1.3 \
const_fn-0.4.5 \
- cookie-0.14.3 \
+ cookie-0.14.4 \
copyless-0.1.5 \
cpuid-bool-0.1.2 \
crc32fast-1.2.1 \
crossbeam-utils-0.8.3 \
ctor-0.1.19 \
derive_more-0.99.11 \
+ diff-0.1.12 \
difference-2.0.0 \
digest-0.9.0 \
discard-1.0.4 \
@@ -91,8 +90,6 @@ CARGO_CRATES= actix-codec-0.3.0 \
either-1.6.1 \
encoding_rs-0.8.28 \
enum-as-inner-0.3.3 \
- failure-0.1.8 \
- failure_derive-0.1.8 \
filetime-0.2.14 \
flate2-1.0.14 \
float-cmp-0.8.0 \
@@ -115,7 +112,6 @@ CARGO_CRATES= actix-codec-0.3.0 \
generic-array-0.14.4 \
getrandom-0.1.16 \
getrandom-0.2.2 \
- gimli-0.23.0 \
globset-0.4.6 \
globwalk-0.8.1 \
grass-0.10.4 \
@@ -125,30 +121,30 @@ CARGO_CRATES= actix-codec-0.3.0 \
hashbrown-0.9.1 \
heck-0.3.2 \
hermit-abi-0.1.18 \
- hex-0.4.2 \
+ hex-0.4.3 \
hostname-0.3.1 \
html5ever-0.25.1 \
http-0.2.3 \
- http-body-0.4.0 \
+ http-body-0.4.1 \
httparse-1.3.5 \
httpdate-0.3.2 \
hyper-0.14.4 \
hyper-rustls-0.22.1 \
idna-0.2.2 \
ignore-0.4.17 \
- indexmap-1.6.1 \
+ indexmap-1.6.2 \
instant-0.1.9 \
iovec-0.1.4 \
ipconfig-0.2.2 \
ipnet-2.3.0 \
itoa-0.4.7 \
- js-sys-0.3.48 \
+ js-sys-0.3.49 \
kernel32-sys-0.2.2 \
language-tags-0.2.2 \
lasso-0.3.1 \
lazy_static-1.4.0 \
- libc-0.2.86 \
- libflate-1.0.3 \
+ libc-0.2.90 \
+ libflate-1.0.4 \
libflate_lz77-1.0.0 \
linked-hash-map-0.5.4 \
lock_api-0.4.2 \
@@ -166,9 +162,8 @@ CARGO_CRATES= actix-codec-0.3.0 \
mime-0.3.16 \
mime_guess-2.0.3 \
miniz_oxide-0.3.7 \
- miniz_oxide-0.4.4 \
mio-0.6.23 \
- mio-0.7.9 \
+ mio-0.7.10 \
mio-uds-0.6.8 \
miow-0.2.2 \
miow-0.3.6 \
@@ -178,13 +173,12 @@ CARGO_CRATES= actix-codec-0.3.0 \
nom-4.2.3 \
normalize-line-endings-0.3.0 \
ntapi-0.3.6 \
- num-bigint-0.3.1 \
+ num-bigint-0.3.2 \
num-integer-0.1.44 \
num-rational-0.3.2 \
num-traits-0.2.14 \
num_cpus-1.13.0 \
- object-0.23.0 \
- once_cell-1.7.0 \
+ once_cell-1.7.2 \
opaque-debug-0.3.0 \
output_vt100-0.1.2 \
parking_lot-0.11.1 \
@@ -200,8 +194,8 @@ CARGO_CRATES= actix-codec-0.3.0 \
pin-project-1.0.5 \
pin-project-internal-0.4.27 \
pin-project-internal-1.0.5 \
- pin-project-lite-0.1.11 \
- pin-project-lite-0.2.4 \
+ pin-project-lite-0.1.12 \
+ pin-project-lite-0.2.6 \
pin-utils-0.1.0 \
pkg-config-0.3.19 \
port_check-0.1.5 \
@@ -210,7 +204,7 @@ CARGO_CRATES= actix-codec-0.3.0 \
predicates-1.0.7 \
predicates-core-1.0.2 \
predicates-tree-1.0.2 \
- pretty_assertions-0.6.1 \
+ pretty_assertions-0.7.1 \
proc-macro-error-1.0.4 \
proc-macro-error-attr-1.0.4 \
proc-macro-hack-0.5.19 \
@@ -240,16 +234,15 @@ CARGO_CRATES= actix-codec-0.3.0 \
rand_xorshift-0.1.1 \
rdrand-0.4.0 \
redox_syscall-0.2.5 \
- regex-1.4.3 \
+ regex-1.4.5 \
regex-automata-0.1.9 \
- regex-syntax-0.6.22 \
+ regex-syntax-0.6.23 \
remove_dir_all-0.5.3 \
- reqwest-0.11.1 \
+ reqwest-0.11.2 \
resolv-conf-0.7.0 \
ring-0.16.20 \
rle-decode-fast-1.0.1 \
rstest-0.6.4 \
- rustc-demangle-0.1.18 \
rustc_version-0.2.3 \
rustls-0.19.0 \
ryu-1.0.5 \
@@ -259,21 +252,21 @@ CARGO_CRATES= actix-codec-0.3.0 \
select-0.5.0 \
semver-0.9.0 \
semver-parser-0.7.0 \
- serde-1.0.123 \
- serde_derive-1.0.123 \
- serde_json-1.0.63 \
+ serde-1.0.124 \
+ serde_derive-1.0.124 \
+ serde_json-1.0.64 \
serde_urlencoded-0.7.0 \
sha-1-0.9.4 \
sha1-0.6.0 \
sha2-0.9.3 \
signal-hook-registry-1.3.0 \
simplelog-0.9.0 \
- siphasher-0.3.3 \
+ siphasher-0.3.5 \
slab-0.4.2 \
smallvec-1.6.1 \
socket2-0.3.19 \
spin-0.5.2 \
- standback-0.2.15 \
+ standback-0.2.16 \
stdweb-0.4.20 \
stdweb-derive-0.5.3 \
stdweb-internal-macros-0.2.9 \
@@ -285,8 +278,7 @@ CARGO_CRATES= actix-codec-0.3.0 \
structopt-derive-0.4.14 \
strum-0.20.0 \
strum_macros-0.20.1 \
- syn-1.0.60 \
- synstructure-0.12.4 \
+ syn-1.0.64 \
tar-0.4.33 \
tempfile-3.2.0 \
tendril-0.4.2 \
@@ -297,26 +289,26 @@ CARGO_CRATES= actix-codec-0.3.0 \
thread_local-1.1.3 \
threadpool-1.8.1 \
time-0.1.44 \
- time-0.2.25 \
+ time-0.2.26 \
time-macros-0.1.1 \
time-macros-impl-0.1.1 \
tinyvec-1.1.1 \
tinyvec_macros-0.1.0 \
tokio-0.2.25 \
- tokio-1.2.0 \
+ tokio-1.4.0 \
tokio-rustls-0.22.0 \
tokio-util-0.3.1 \
- tokio-util-0.6.3 \
+ tokio-util-0.6.5 \
tower-service-0.3.1 \
tracing-0.1.25 \
tracing-core-0.1.17 \
tracing-futures-0.2.5 \
treeline-0.1.0 \
- trust-dns-proto-0.19.6 \
- trust-dns-resolver-0.19.6 \
+ trust-dns-proto-0.19.7 \
+ trust-dns-resolver-0.19.7 \
try-lock-0.2.3 \
twoway-0.2.1 \
- typenum-1.12.0 \
+ typenum-1.13.0 \
unchecked-index-0.2.2 \
unicase-2.6.0 \
unicode-bidi-0.3.4 \
@@ -332,19 +324,19 @@ CARGO_CRATES= actix-codec-0.3.0 \
v_htmlescape-0.12.0 \
vec_map-0.8.2 \
version_check-0.1.5 \
- version_check-0.9.2 \
+ version_check-0.9.3 \
wait-timeout-0.2.0 \
walkdir-2.3.1 \
want-0.3.0 \
wasi-0.9.0+wasi-snapshot-preview1 \
wasi-0.10.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.71 \
- wasm-bindgen-backend-0.2.71 \
- wasm-bindgen-futures-0.4.21 \
- wasm-bindgen-macro-0.2.71 \
- wasm-bindgen-macro-support-0.2.71 \
- wasm-bindgen-shared-0.2.71 \
- web-sys-0.3.48 \
+ wasm-bindgen-0.2.72 \
+ wasm-bindgen-backend-0.2.72 \
+ wasm-bindgen-futures-0.4.22 \
+ wasm-bindgen-macro-0.2.72 \
+ wasm-bindgen-macro-support-0.2.72 \
+ wasm-bindgen-shared-0.2.72 \
+ web-sys-0.3.49 \
webpki-0.21.4 \
webpki-roots-0.21.0 \
widestring-0.4.3 \
@@ -360,7 +352,7 @@ CARGO_CRATES= actix-codec-0.3.0 \
xattr-0.2.2 \
xml5ever-0.16.1 \
yansi-0.5.0 \
- zip-0.5.10
+ zip-0.5.11
# maud_macros uses feature(proc_macro)
MAKE_ENV= RUSTC_BOOTSTRAP=1