aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_kerb2
diff options
context:
space:
mode:
authorGarrett Wollman <wollman@FreeBSD.org>2002-03-21 16:10:14 +0000
committerGarrett Wollman <wollman@FreeBSD.org>2002-03-21 16:10:14 +0000
commit3324b31e788f557da901fd559c820d65b7bf75b4 (patch)
tree49fc59bcf5a669caa1cee90a0da0767b9c333f6d /www/mod_auth_kerb2
parentbae39e4ddc20cd8c618838ef07425f220f55576a (diff)
downloadports-3324b31e788f557da901fd559c820d65b7bf75b4.tar.gz
ports-3324b31e788f557da901fd559c820d65b7bf75b4.zip
Notes
Diffstat (limited to 'www/mod_auth_kerb2')
-rw-r--r--www/mod_auth_kerb2/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index f8939c23f667..e7367ecbc99f 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -31,10 +31,12 @@ KRB5_HOME?= ${LOCALBASE}
do-build:
cd ${WRKSRC} && \
- ${APXS} -I${KRB5_HOME}/include -L${KRB5_HOME}/lib \
+ ${APXS} -I${KRB5_HOME}/include \
-DKRB5 -DKRB5_VERIFY_TICKET -DKRB5_SAVE_CREDENTIALS \
-DKRB5_DEFAULT_KEYTAB=\"\\\"file:${LOCALBASE}/etc/apache/keytab\\\"\" \
- -c ${PORTNAME}.c
+ -c ${PORTNAME}.c \
+ -L${KRB5_HOME}/lib -Wl,-rpath -Wl,${KRB5_HOME}/lib \
+ -lkrb5 -lk5crypto -lcom_err
do-install:
${APXS} -i -A -n ${PORTNAME:S/mod_//g} ${WRKSRC}/${PORTNAME}.so