aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_mysql2
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-09-10 16:04:57 +0000
committerClement Laforet <clement@FreeBSD.org>2005-09-10 16:04:57 +0000
commitd67de08be3276b05f57cb06afe8ce2632c88828f (patch)
tree3e356019b00f72f69a956e7bb483c333de7b0afe /www/mod_auth_mysql2
parent4b5e7c7f4a07e1376fdc436b5e7cb83f36f0796e (diff)
downloadports-d67de08be3276b05f57cb06afe8ce2632c88828f.tar.gz
ports-d67de08be3276b05f57cb06afe8ce2632c88828f.zip
Notes
Diffstat (limited to 'www/mod_auth_mysql2')
-rw-r--r--www/mod_auth_mysql2/Makefile37
-rw-r--r--www/mod_auth_mysql2/distinfo2
-rw-r--r--www/mod_auth_mysql2/pkg-descr5
3 files changed, 44 insertions, 0 deletions
diff --git a/www/mod_auth_mysql2/Makefile b/www/mod_auth_mysql2/Makefile
new file mode 100644
index 000000000000..bf7530e14c59
--- /dev/null
+++ b/www/mod_auth_mysql2/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mod_auth_mysql2
+# Date created: Sep 10 2005
+# Whom: Clement Laforet <clement@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_auth_mysql
+PORTVERSION= 1.5
+CATEGORIES= www
+MASTER_SITES= http://www.heuer.org/mod_auth_mysql/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= apache2
+
+MAINTAINER= apache@FreeBSD.org
+COMMENT= MySQL-based authentication module with VirtualHost support
+
+LATEST_LINK= mod_auth_mysql2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_MYSQL= YES
+WANT_APACHE= 2
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+AP_INC+= ${LOCALBASE}/include/mysql
+AP_LIB+= ${LOCALBASE}/lib/mysql -lmysqlclient
+
+PORTDOCS= INSTALL example_data.html htpasswd.sql
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_auth_mysql2/distinfo b/www/mod_auth_mysql2/distinfo
new file mode 100644
index 000000000000..485803d1445d
--- /dev/null
+++ b/www/mod_auth_mysql2/distinfo
@@ -0,0 +1,2 @@
+MD5 (apache2/mod_auth_mysql_1.5.tgz) = d52b83b22ec49bf915e19cbf6720bf7b
+SIZE (apache2/mod_auth_mysql_1.5.tgz) = 14844
diff --git a/www/mod_auth_mysql2/pkg-descr b/www/mod_auth_mysql2/pkg-descr
new file mode 100644
index 000000000000..fc3b866a666d
--- /dev/null
+++ b/www/mod_auth_mysql2/pkg-descr
@@ -0,0 +1,5 @@
+mod_auth_mysql provides an MySQL-based authentication for apache2.
+It's also designed to support multiple virtualhosts using only one
+database.
+
+WWW: http://www.heuer.org/mod_auth_mysql/