aboutsummaryrefslogtreecommitdiff
path: root/www/mod_auth_mysql_another
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2006-04-15 13:21:00 +0000
committerMartin Blapp <mbr@FreeBSD.org>2006-04-15 13:21:00 +0000
commit1f1d87779702123c14dbbb0329f2b1031c5c713f (patch)
tree3ea3a5cfeae4e3959de85bc6e8f999ee8517a08e /www/mod_auth_mysql_another
parentf9a407d1e617cc7c35ba51bdf957f78acc3f3184 (diff)
downloadports-1f1d87779702123c14dbbb0329f2b1031c5c713f.tar.gz
ports-1f1d87779702123c14dbbb0329f2b1031c5c713f.zip
Notes
Diffstat (limited to 'www/mod_auth_mysql_another')
-rw-r--r--www/mod_auth_mysql_another/Makefile26
-rw-r--r--www/mod_auth_mysql_another/files/Makefile10
-rw-r--r--www/mod_auth_mysql_another/pkg-plist6
3 files changed, 32 insertions, 10 deletions
diff --git a/www/mod_auth_mysql_another/Makefile b/www/mod_auth_mysql_another/Makefile
index 17cdb3800ba5..7ae4d9c28e46 100644
--- a/www/mod_auth_mysql_another/Makefile
+++ b/www/mod_auth_mysql_another/Makefile
@@ -6,6 +6,7 @@
PORTNAME= mod_auth_mysql
PORTVERSION= 3.0.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/_//g}
@@ -15,16 +16,34 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Allows users to use MySQL databases for user authentication
USE_MYSQL= YES
+USE_REINPLACE= YES
-SHORTMODNAME= mysql_auth
-AP_FAST_BUILD= YES
-AP_GENPLIST= YES
+SHORTMODNAME= mysql_auth
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
AP_INC= ${LOCALBASE}/include/mysql
AP_LIB= ${LOCALBASE}/lib/mysql
+.if defined(WITH_APACHE2)
+AP_EXTRAS= -lmysqlclient -lz -lm
+USE_APACHE= 20+
+.else
+USE_APACHE= 13+
AP_EXTRAS= -DAPACHE${AP_VER} -lmysqlclient -lz -lm
+.endif
.include <bsd.port.pre.mk>
+.if defined(WITH_APACHE2)
+post-patch:
+ ${REINPLACE_CMD} -e "s|APR_XtOffsetOf|APR_OFFSETOF|g" \
+ -e "s|APR_XtOffset|APR_OFFSET|g" ${WRKSRC}/mod_auth_mysql.c
+.else
+pre-build:
+ ${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e "s|%%APXS%%|${APXS}|g" \
+ -e "s|%%AP_INC%%|${AP_INC}|g" -e "s|%%AP_LIB%%|${AP_LIB}|g" ${WRKSRC}/Makefile
+.endif
+
.if !defined(NOPORTDOCS)
post-build:
@${ECHO} "%%PORTDOCS%%%%DOCSDIR%%/CONFIGURE" >> ${PLIST}
@@ -37,5 +56,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}
.endif
-.include "${PORTSDIR}/www/apache20/Makefile.modules.3rd"
.include <bsd.port.post.mk>
diff --git a/www/mod_auth_mysql_another/files/Makefile b/www/mod_auth_mysql_another/files/Makefile
new file mode 100644
index 000000000000..1e6b9086cd4e
--- /dev/null
+++ b/www/mod_auth_mysql_another/files/Makefile
@@ -0,0 +1,10 @@
+#
+# $FreeBSD$
+#
+all: build
+
+build:
+ %%APXS%% -c -L%%AP_LIB%% -I%%AP_INC%% -lmysqlclient -lm -lz mod_auth_mysql.c
+
+install:
+ %%APXS%% -i mod_auth_mysql.so
diff --git a/www/mod_auth_mysql_another/pkg-plist b/www/mod_auth_mysql_another/pkg-plist
deleted file mode 100644
index 96d0df8d7ad5..000000000000
--- a/www/mod_auth_mysql_another/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-libexec/apache%%VER%%/mod_auth_mysql.so
-@exec %D/sbin/apxs -e -a -n mysql_auth %f
-@unexec %D/sbin/apxs -e -A -n mysql_auth %f
-%%PORTDOCS%%share/doc/mod_auth_mysql_another/CONFIGURE
-%%PORTDOCS%%share/doc/mod_auth_mysql_another/CHANGES
-%%PORTDOCS%%@dirrm share/doc/mod_auth_mysql_another