aboutsummaryrefslogtreecommitdiff
path: root/www/mod_authn_otp/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-12-17 22:46:06 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-12-17 22:46:06 +0000
commit9ad7ffdb4ce1cb8cd43975cd77eaab69e580e139 (patch)
tree47c3427c6d58443c6705f14dc434f77e308459ff /www/mod_authn_otp/Makefile
parent16722f6be08fc7a743c913b1a6e9adc4773af02a (diff)
downloadports-9ad7ffdb4ce1cb8cd43975cd77eaab69e580e139.tar.gz
ports-9ad7ffdb4ce1cb8cd43975cd77eaab69e580e139.zip
Notes
Diffstat (limited to 'www/mod_authn_otp/Makefile')
-rw-r--r--www/mod_authn_otp/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/mod_authn_otp/Makefile b/www/mod_authn_otp/Makefile
index 0752a5c542b9..1a053dd75c80 100644
--- a/www/mod_authn_otp/Makefile
+++ b/www/mod_authn_otp/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mod_authn_otp
-PORTVERSION= 1.1.4
-PORTREVISION= 1
+PORTVERSION= 1.1.5
CATEGORIES= www
MASTER_SITES= http://mod-authn-otp.googlecode.com/files/ \
http://alex.bmg.gv.at/programs/
@@ -15,7 +14,7 @@ COMMENT= Apache module for one-time password authentication
MAKE_JOBS_SAFE= yes
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_APACHE= 22
MAN1= otptool.1
@@ -27,9 +26,13 @@ PORTEXAMPLES= users.sample
CONFIGURE_ARGS= --prefix=${PREFIX} \
--mandir=${MANPREFIX}/man
+post-configure:
+ @${REINPLACE_CMD} 's|CFLAGS =|CFLAGS ?=|' \
+ ${WRKSRC}/Makefile
+
post-install:
@${APXS} -e -A -n ${PORTNAME:S/mod_//} ${APACHEMODDIR}/${PORTNAME}.so
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}/
${INSTALL_DATA} ${WRKSRC}/users.sample ${EXAMPLESDIR}/
.endif