aboutsummaryrefslogtreecommitdiff
path: root/www/mod_frontpage
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2002-02-03 21:59:27 +0000
committerMartin Blapp <mbr@FreeBSD.org>2002-02-03 21:59:27 +0000
commit33d6650dcc9cfb8551fdd2632ee6aa2a89c0d1e4 (patch)
tree4b54377bda131602b8a865d1664c1ae151ba3691 /www/mod_frontpage
parent60f5079d3b4c40ddcb4c91a20edd43ea47fd8185 (diff)
downloadports-33d6650dcc9cfb8551fdd2632ee6aa2a89c0d1e4.tar.gz
ports-33d6650dcc9cfb8551fdd2632ee6aa2a89c0d1e4.zip
Notes
Diffstat (limited to 'www/mod_frontpage')
-rw-r--r--www/mod_frontpage/Makefile8
-rw-r--r--www/mod_frontpage/distinfo2
-rw-r--r--www/mod_frontpage/files/patch-Makefile.PL49
-rw-r--r--www/mod_frontpage/files/patch-fpexec.c26
-rw-r--r--www/mod_frontpage/files/patch-mod_frontpage.c21
-rw-r--r--www/mod_frontpage/pkg-descr5
-rw-r--r--www/mod_frontpage/pkg-message15
-rw-r--r--www/mod_frontpage/pkg-plist1
8 files changed, 18 insertions, 109 deletions
diff --git a/www/mod_frontpage/Makefile b/www/mod_frontpage/Makefile
index c88133474683..3ea8acfd75ad 100644
--- a/www/mod_frontpage/Makefile
+++ b/www/mod_frontpage/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= mod_frontpage
-PORTVERSION= 1.5.2
-PORTREVISION= 1
+PORTVERSION= 1.6
CATEGORIES= www
MASTER_SITES= http://people.freebsd.org/~mbr/distfiles/
@@ -19,7 +18,7 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/${AP_PORT}
.include <bsd.port.pre.mk>
-ONLY_FOR_ARCHS= i386
+PKGMESSAGE= pkg-message
INSTALL_FILE= ${INSTALL} -c -m 555 -o bin -g bin
PKG_PREFIX= ${PREFIX}
@@ -43,4 +42,7 @@ AP_LIBEXEC?= ${PREFIX}/libexec/apache
PERL_CONFIGURE= yes
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>
diff --git a/www/mod_frontpage/distinfo b/www/mod_frontpage/distinfo
index 267f4cb2eedc..d4013517ef5c 100644
--- a/www/mod_frontpage/distinfo
+++ b/www/mod_frontpage/distinfo
@@ -1 +1 @@
-MD5 (mod_frontpage-1.5.2.tar.gz) = b906d1b5804b87b92640197bca79fd6f
+MD5 (mod_frontpage-1.6.tar.gz) = 516870d6207f893ac37aaf463bf8f381
diff --git a/www/mod_frontpage/files/patch-Makefile.PL b/www/mod_frontpage/files/patch-Makefile.PL
deleted file mode 100644
index 70c675d0b01d..000000000000
--- a/www/mod_frontpage/files/patch-Makefile.PL
+++ /dev/null
@@ -1,49 +0,0 @@
---- Makefile.PL.orig Sun Dec 9 23:55:38 2001
-+++ Makefile.PL Sun Jan 20 17:22:36 2002
-@@ -41,23 +41,23 @@
- open(FILE,"$httpdconf") or die "Can't find $httpdconf!\n";
- print "Reading httpd.conf...\n";
- while(<FILE>) {
-- if (/^User (\w*)/) {
-+ if (!$user && /^User (\w*)/) {
- $user=$1;
- }
-- if (/^Group (\w*)/) {
-+ if (!$group && /^Group (\w*)/) {
- $group=$1;
- }
-- if (/^UserDir (\w*)/) {
-+ if (!$userdir && /^UserDir (\w*)/) {
- $userdir=$1;
- }
-- if (/^ServerRoot (\S*)/) {
-+ if (!$serverroot && /^ServerRoot (\S*)/) {
- $serverroot=$1;
- }
-- if (/^ErrorLog (\S*)/) {
-+ if (!$errorlog && /^ErrorLog (\S*)/) {
- $errorlog=$1;
- $errorlog=~ s/error_log/fpexec_log/;
- }
-- if (/^DocumentRoot (\S*)/) {
-+ if (!$documentroot && /^DocumentRoot (\S*)/) {
- $documentroot=$1;
- }
- }
-@@ -82,13 +82,13 @@
- print "Content uid, gid: $uid, $gid\n";
-
- #
--# User "apache" in Mandrake has user 48, gid 48
-+# User "www" in FreeBSD has user 80, gid 80
- #
--if ($uid < 48) {
-+if ($uid < 80) {
- print "UID too low! Using default value 100\n";
- $uid=100;
- }
--if ($gid < 48) {
-+if ($gid < 80) {
- print "GID too low! Using default value 100\n";
- $gid=100;
- }
diff --git a/www/mod_frontpage/files/patch-fpexec.c b/www/mod_frontpage/files/patch-fpexec.c
deleted file mode 100644
index a026fb84cfab..000000000000
--- a/www/mod_frontpage/files/patch-fpexec.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- fpexec.c.orig Sun Dec 9 23:35:39 2001
-+++ fpexec.c Wed Jan 23 20:10:14 2002
-@@ -247,6 +247,11 @@
- cidx++;
-
- for (ep = environ; *ep && cidx < AP_ENVBUF-1; ep++) {
-+ if (*ep == NULL) {
-+ log_err("HTTP header mismatch, stop\n");
-+ exit(120);
-+ }
-+
- if (!strncmp(*ep, "HTTP_", 5) || !strncmp(*ep,"HTTPS",5)
- || !strncmp(*ep,"SSL_",4)) {
- cleanenv[cidx] = *ep;
-@@ -327,6 +332,11 @@
- exit(103);
- }
- #endif /*_OSD_POSIX*/
-+
-+ if (target_uname == NULL) {
-+ log_err("invalid target user name: (NULL)\n");
-+ exit(105);
-+ }
-
- if (!strncmp("~", target_uname, 1)) {
- target_uname++;
diff --git a/www/mod_frontpage/files/patch-mod_frontpage.c b/www/mod_frontpage/files/patch-mod_frontpage.c
deleted file mode 100644
index 4291062e5902..000000000000
--- a/www/mod_frontpage/files/patch-mod_frontpage.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- mod_frontpage.c.orig Sun Dec 9 23:48:35 2001
-+++ mod_frontpage.c Mon Jan 21 13:02:01 2002
-@@ -110,7 +110,7 @@
-
- static void init (server_rec* s, pool* p)
- {
-- ap_add_version_component ("FrontPage/5.0.2.2510");
-+ ap_add_version_component ("FrontPage/5.0.2.2623");
- while (s != NULL) {
- conf* c = ap_get_module_config (s->module_config, &frontpage_module);
- if (c->disabled == -1)
-@@ -280,6 +280,9 @@
- return log_scripterror (r, c, NOT_FOUND, APLOG_NOERRNO,
- "unrecognized FrontPage request");
-
-+ if (strcmp(vti, SHTMLDLL) == 0)
-+ bcopy(SHTML, vti, strlen(SHTML));
-+
- ap_table_set (r->subprocess_env, "FPEXE", ap_pstrdup (r->pool, vti));
-
- webroot = ap_pstrndup (r->pool, r->filename, (vti - r->filename));
diff --git a/www/mod_frontpage/pkg-descr b/www/mod_frontpage/pkg-descr
index ce40265c682b..04869ffb96e4 100644
--- a/www/mod_frontpage/pkg-descr
+++ b/www/mod_frontpage/pkg-descr
@@ -7,8 +7,9 @@ with your Apache HTTP Server (e.g. creating FrontPage-extended subwebs using the
FrontPage client in contrast to creating them as user "root" with "fpinstall.sh"
or the "fpsrvadm.exe"-utility on the system's shell).
-WWW: http://home.edo.uni-dortmund.de/~chripo/
-FTP: ftp://ftp.edo.uni-dortmund.de/pub/mod_frontpage
+WWW: http://home.edo.uni-dortmund.de/~chripo # Old homepage with FAQ
+ http://people.freebsd.org/~mbr/distfiles # New source
+FTP: ftp://ftp.edo.uni-dortmund.de/pub/mod_frontpage # Old source
Copyright (C) 2001 Christof Pohl <chripo+frontpage@edo.uni-dortmund.de>
APXS install by Jean-Michel Dault <jmdault@mandrakesoft.com
diff --git a/www/mod_frontpage/pkg-message b/www/mod_frontpage/pkg-message
index 7655a6e228c9..d69e0fab0a5c 100644
--- a/www/mod_frontpage/pkg-message
+++ b/www/mod_frontpage/pkg-message
@@ -1,12 +1,13 @@
************************************************************************
-The BSDI FrontPage Extentions require that libcrypt.* be linked to the
-libdescrypt.* libraries. The fpsrvadm.exe program can only create DES
-passwords, but the Apache server is unable to use them when libcrypt.*
-are linked to the libscrypt.* libraries.
+mod_frontpage improved has been installed. You can turn off/on the
+extensions and the frontpage administration per site in httpd.conf
+and per virtual server. FrontPageAdminDisable is the default if no
+option is given.
-A new apache.sh.sample has been installed. Please replace your own
-apache.sh with this script. The frontpage suid key generation is
-needed by mod_frontpage. Without it it doesn't work.
+FrontPageEnable # Enable Frontpage Extensions
+FrontPageDisable # Disable Frontpage Extensions
+FrontPageAdminEnable # Enable Frontpage Extensions fpadmcgi.exe
+FrontPageAdminDisable # Disable Frontpage Extensions fpadmcgi.exe
************************************************************************
diff --git a/www/mod_frontpage/pkg-plist b/www/mod_frontpage/pkg-plist
index 6f36ca958a25..81923fffe62a 100644
--- a/www/mod_frontpage/pkg-plist
+++ b/www/mod_frontpage/pkg-plist
@@ -1,2 +1,3 @@
sbin/fpexec
+sbin/fpstatic
libexec/apache/mod_frontpage.so