aboutsummaryrefslogtreecommitdiff
path: root/www/mod_frontpage
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2001-08-31 11:42:17 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2001-08-31 11:42:17 +0000
commitf66ab99fbdf40fbf0f1e72bdc6f818a96a70e5e0 (patch)
treea6cb3f4ee0a849b1bdb05f64e0fdbf8e9f418767 /www/mod_frontpage
parent2f546fc008680684f3be24af6f1815b97d9aa2cd (diff)
downloadports-f66ab99fbdf40fbf0f1e72bdc6f818a96a70e5e0.tar.gz
ports-f66ab99fbdf40fbf0f1e72bdc6f818a96a70e5e0.zip
Notes
Diffstat (limited to 'www/mod_frontpage')
-rw-r--r--www/mod_frontpage/Makefile92
-rw-r--r--www/mod_frontpage/distinfo2
-rw-r--r--www/mod_frontpage/files/apache.sh.sample58
-rw-r--r--www/mod_frontpage/files/patch-aa64
-rw-r--r--www/mod_frontpage/files/patch-fa52
-rw-r--r--www/mod_frontpage/files/patch-fb293
-rw-r--r--www/mod_frontpage/files/patch-fn15
-rw-r--r--www/mod_frontpage/pkg-comment1
-rw-r--r--www/mod_frontpage/pkg-descr14
-rw-r--r--www/mod_frontpage/pkg-install39
-rw-r--r--www/mod_frontpage/pkg-message12
-rw-r--r--www/mod_frontpage/pkg-plist192
12 files changed, 834 insertions, 0 deletions
diff --git a/www/mod_frontpage/Makefile b/www/mod_frontpage/Makefile
new file mode 100644
index 000000000000..727498951205
--- /dev/null
+++ b/www/mod_frontpage/Makefile
@@ -0,0 +1,92 @@
+# New ports collection makefile for: apache mod_frontpage
+# Date created: 2001/07/24
+# Whom: mb@imp.ch
+#
+# $FreeBSD$
+
+PORTNAME= mod_frontpage
+PORTVERSION= 1.5.1mdk-1.3.19
+CATEGORIES= www
+MASTER_SITES= http://home.edo.uni-dortmund.de/~chripo/download/ \
+ ftp://ftp.edo.uni-dortmund.de/pub/mod_frontpage/ \
+ ftp://ftp.microsoft.com/products/frontpage/ \
+ ftp://www.westbend.net/Mirrors/ftp.microsoft.com/Products/frontpage/ \
+ http://officeupdate.microsoft.com/frontpage/wpp/serk/
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} ${FRONTPAGE}
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= mb@imp.ch
+
+AP_PORT?= apache13
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/${AP_PORT}
+RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/${AP_PORT}
+
+.include <bsd.port.pre.mk>
+
+ONLY_FOR_ARCHS= i386
+BATCH?= NO
+
+INSTALL_FILE= ${INSTALL} -c -m 555 -o bin -g bin
+PKG_PREFIX= ${PREFIX}
+FRONTPAGE= fp40.bsdi.tar.Z
+FP_REV= version4.0
+FPINSTALL= frontpage/${FP_REV}/fp_install.sh
+CHANGESERVER= frontpage/${FP_REV}/change_server.sh
+FPSETPERM= frontpage/${FP_REV}/set_default_perms.sh
+README= frontpage/${FP_REV}/readme.htm
+SERK= frontpage/${FP_REV}/serk
+AP_SHARE= ${PREFIX}/share/doc/apache
+MOD_FPDOCDIR= ${AP_SHARE}/manual/mod/mod_frontpage
+
+APXS= ${LOCALBASE}/sbin/apxs
+
+.if exists(${APXS})
+APXS_WORKS!= ${APXS} -q TARGET 2>/dev/null || ${ECHO} no
+.endif
+.if exists(${APXS}) && ${APXS_WORKS} != no
+AP_TARGET!= ${APXS} -q TARGET
+AP_SYSCONF!= ${APXS} -q SYSCONFDIR
+AP_INCLUDE!= ${APXS} -q INCLUDEDIR
+AP_LIBEXEC!= ${APXS} -q LIBEXECDIR
+.else
+AP_TARGET?= httpd
+AP_SYSCONF?= ${PREFIX}/etc/apache
+AP_INCLUDE?= ${PREFIX}/include/apache
+AP_LIBEXEC?= ${PREFIX}/libexec/apache
+.endif
+
+post-extract:
+ @${ECHO} "===> Extracting FrontPage install scripts"
+ cd ${WRKSRC} && \
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${FRONTPAGE} \
+ ${EXTRACT_AFTER_ARGS} ${FPINSTALL} ${CHANGESERVER} \
+ ${README} ${FPSETPERM}
+
+.if !defined(PATCH_DEBUG)
+post-patch:
+ @ cd ${WRKSRC} \
+ && find . -type f -name "*.orig" -print | xargs ${RM} -f
+.endif
+
+pre-configure:
+ @${CP} ${WRKSRC}/DSO/Makefile.* ${WRKSRC}/
+
+PERL_CONFIGURE= yes
+
+pre-install:
+ @(cd ${PREFIX} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
+ ${DISTDIR}/${FRONTPAGE} ${EXTRACT_AFTER_ARGS})
+ @${MKDIR} ${MOD_FPDOCDIR}
+ @${CP} ${PREFIX}/${README} ${MOD_FPDOCDIR}/index.html
+ @${LN} -fs ${PREFIX}/${SERK} ${MOD_FPDOCDIR}/serk
+ @${INSTALL_FILE} '${WRKSRC}/${FPINSTALL}' '${PREFIX}/${FPINSTALL}-dist'
+ @${INSTALL_FILE} '${WRKSRC}/${CHANGESERVER}' '${PREFIX}/${CHANGESERVER}-dist'
+ @${INSTALL_FILE} '${WRKSRC}/${FPSETPERM}' '${PREFIX}/${FPSETPERM}'
+ @PKG_PREFIX=${PREFIX} BATCH=${BATCH} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+post-install:
+ @${INSTALL_SCRIPT} -m 751 ${FILESDIR}/apache.sh.sample ${PREFIX}/etc/rc.d/apache.sh.sample
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_frontpage/distinfo b/www/mod_frontpage/distinfo
new file mode 100644
index 000000000000..58b3548b9709
--- /dev/null
+++ b/www/mod_frontpage/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_frontpage-1.5.1mdk-1.3.19.tar.gz) = ea8228a9306cf8043d6468fa82e71aba
+MD5 (fp40.bsdi.tar.Z) = f469ea85b69d69f80f32c58fb0d273c4
diff --git a/www/mod_frontpage/files/apache.sh.sample b/www/mod_frontpage/files/apache.sh.sample
new file mode 100644
index 000000000000..8b5a24f5e18a
--- /dev/null
+++ b/www/mod_frontpage/files/apache.sh.sample
@@ -0,0 +1,58 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+#
+# Create New FrontPage suidkey
+#
+
+new_key() {
+
+ CUR_UMASK=`umask`
+ skdir=${PREFIX}/frontpage/version4.0/apache-fp
+ PERL=PERL5
+
+ if [ -x ${PREFIX}/libexec/apache/mod_frontpage.so ]
+ then
+
+ #NOTE: We need Perl 5, to generate a new key
+ if [ -x ${PERL} ]
+ then
+ umask 077
+ ${PERL} -e '@a=(split(//, "abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789!@#$%^&*-=_+")); print((map {$a[rand(scalar @a)]} (1..128)), "\n");' > $skdir/suidkey
+ umask ${CUR_UMASK}
+ fi
+ fi
+
+}
+
+#
+# Main
+#
+
+case "$1" in
+
+start)
+ if [ -x ${PREFIX}/sbin/apachectl ]
+ then
+ new_key
+ ${PREFIX}/sbin/apachectl start && echo -n ' httpd'
+ fi
+ ;;
+
+stop)
+ if [ -r /var/run/httpd.pid ]
+ then
+ ${PREFIX}/sbin/apachectl stop && echo -n ' httpd'
+ fi
+ ;;
+
+*)
+ echo "usage: $0 {start|stop}" 1>&2
+ exit 64
+ ;;
+
+esac
diff --git a/www/mod_frontpage/files/patch-aa b/www/mod_frontpage/files/patch-aa
new file mode 100644
index 000000000000..499466005a49
--- /dev/null
+++ b/www/mod_frontpage/files/patch-aa
@@ -0,0 +1,64 @@
+--- DSO/Makefile.PL.orig Tue Jul 24 23:01:08 2001
++++ DSO/Makefile.PL Tue Jul 24 23:02:58 2001
+@@ -4,26 +4,7 @@
+ # You can use it according to the Apache licence
+ # Please send modifications to: <jmdault@mandrakesoft.com> so other
+ # modules can benefit from it!
+-
+-print "Enter the path of your httpd binary.\n";
+-print "It should be something like /usr/local/apache/bin).\n";
+-print "If you don't know, enter the word 'findit'. I will try to look\n";
+-print "for you... but it will take a few minutes.\n";
+-print "Your choice: ";
+-$thechoice=<STDIN>;
+-#$thechoice="/usr/sbin/httpd\n";
+-chop $thechoice;
+-
+-if ($thechoice eq "findit") {
+- print "\nTrying to find httpd.... please be patient!\n";
+- $thechoice=`find / -type f -iname httpd 2>/dev/null|grep bin| \
+- xargs -n 1 file|grep linked|cut -f1 -d: 2>/dev/null`;
+- chop $thechoice;
+- print "\nFound: $thechoice\n";
+- ($test1,$test2,@junk)=split(/\n/,$thechoice);
+- if ($test2) {die "\nSorry, found more than 1 potential httpd...\n"; }
+-}
+-
++$thechoice="/usr/local/sbin/httpd";
+ print "\nLet's see if it's a valid httpd...";
+ $_=`$thechoice -v`;
+ if (/Server version:/) { print " YES!\n";
+@@ -91,12 +72,10 @@
+ }
+ print "DocumentRoot: $documentroot\n";
+
+-#$_=`ls -dln $documentroot|cut -c 17-30`;
+-$_=`ls -dln /var/log|cut -c 17-30`;
+-if (/^(\d*)(\s*)(\d*)/) {
+- $uid=$1; $gid=$3;
+- print "Content uid $uid, gid $gid\n";
+-}
++$webdir = $documentroot;
++$webdir =~ s/"//g;
++($uid, $gid) = (stat $webdir)[4,5];
++print "Content uid, gid: $uid, $gid\n";
+
+ #
+ # User "apache" in Mandrake has user 48, gid 48
+@@ -136,6 +115,7 @@
+ $_=~ s|"\$\(fpexec_bin\)|\\\\\"$sbindir\/fpexec\\\\|;
+ $_=~ s|\$\(httpdconf\)|$httpdconf|;
+ $_=~ s|\$\(libexecdir\)|$libexecdir|;
++$_=~ s|root.root|root:wheel|;
+ print MAKF $_;
+ }
+
+@@ -143,7 +123,7 @@
+ ### Now, *that*'s very *ugly* ;-)
+ ###
+ print "Extracting the Source Code from the patch...\n";
+-$patch=` ls ../patch*|xargs -iPAT -n1 patch -f -i `;
++$patch=`patch -f < patch-1.5.1mdk-1.3.19 2>&1 > /dev/null`;
+ $result=`rm -f Makefile.tmpl *.orig *.rej *~`;
+
+ print "\n\nDone!!! Now have a look at the Makefile to see if it's ";
diff --git a/www/mod_frontpage/files/patch-fa b/www/mod_frontpage/files/patch-fa
new file mode 100644
index 000000000000..88797383aafe
--- /dev/null
+++ b/www/mod_frontpage/files/patch-fa
@@ -0,0 +1,52 @@
+--- frontpage/version4.0/change_server.sh.orig Mon Aug 14 11:51:36 2000
++++ frontpage/version4.0/change_server.sh Wed Mar 7 22:12:02 2001
+@@ -38,9 +38,12 @@
+ {
+ VERSION="4.0"
+ PATH=".:/bin:/usr/bin:/sbin:/usr/sbin:/usr/ucb:/etc:/usr/bsd"
+- NEWHTTPDNEW="/usr/local/frontpage/version${VERSION}/apache-fp/httpd"
+- NEWHTTPDCOMPAT="/usr/local/frontpage/version${VERSION}/apache-fp/httpd.Compat"
+- DEFAULTHTTPD="/usr/local/apache/sbin/httpd"
++ AP_TARGET=`PREFIX/sbin/apxs -q TARGET`
++ NEWHTTPDNEW="PREFIX/sbin/${AP_TARGET}"
++ NEWMODFPNEW="PREFIX/libexec/apache/mod_frontpage.so"
++ NEWHTTPDCOMPAT="${NEWHTTPDNEW}"
++ NEWMODFPCOMAPT="${NEWMODFPNEW}"
++ DEFAULTHTTPD="PREFIX/sbin/${AP_TARGET}"
+
+ case "`echo 'x\c'`" in
+ 'x\c') echo="echo -n" nnl= ;; #BSD
+@@ -217,8 +220,22 @@
+
+ clear
+
++ if ($strings $httpdfile | $fgrep "etc/apache/${AP_TARGET}.conf" > /dev/null)
++ then
++ NEWHTTPD=$NEWHTTPDNEW
++ NEWMODFP=$NEWMODFPNEW
++ echo "Selected server uses FreeBSD directory structure:"
++
++ targetVersionNumber=`$httpdfile -v | sed 's%^.*Apache/\([0-9\.]*\).*%\1%' | head -1`
++ targetFPVersionNumber=`$strings \`dirname \\\`dirname $httpdfile\\\`\`/libexec/apache/mod_frontpage.so | \
++ $fgrep "FrontPage/" 2> /dev/null | sed -e 's%^.*FrontPage/\([0-9\.]*\).*%\1%' | tail -1`
++
++ sourceVersionNumber=`$NEWHTTPD -v | sed 's%^.*Apache/\([0-9\.]*\).*%\1%' | head -1`
++ sourceFPVersionNumber=`$strings $NEWMODFP | $fgrep "FrontPage/" 2> /dev/null | \
++ sed -e 's%^.*FrontPage/\([0-9\.]*\).*%\1%' | tail -1`
++ else
+
+- if ($strings $httpdfile | $fgrep "etc/httpd.conf" > /dev/null)
++ if ($strings $httpdfile | $fgrep "etc/${AP_TARGET}.conf" > /dev/null)
+ then
+ NEWHTTPD=$NEWHTTPDNEW
+ echo "Selected server uses NEW directory structure:"
+@@ -235,7 +252,8 @@
+ sourceVersionNumber=`$NEWHTTPD -v | sed 's%^.*Apache/\([0-9\.]*\).*%\1%' | head -1`
+ sourceFPVersionNumber=`$strings $NEWHTTPD | $fgrep "FrontPage/" 2> /dev/null | sed -e '
+ s%^.*FrontPage/\([0-9\.]*\).*%\1%' | tail -1`
+-
++ fi
++
+ echo
+ echo "Currently running Apache/${targetVersionNumber} FrontPage/${nnl}"
+ if [ "${targetFPVersionNumber}" = "" ]
diff --git a/www/mod_frontpage/files/patch-fb b/www/mod_frontpage/files/patch-fb
new file mode 100644
index 000000000000..1c7e4c0ac7f0
--- /dev/null
+++ b/www/mod_frontpage/files/patch-fb
@@ -0,0 +1,293 @@
+--- frontpage/version4.0/fp_install.sh.orig Mon Aug 14 11:51:36 2000
++++ frontpage/version4.0/fp_install.sh Wed Mar 7 22:16:28 2001
+@@ -48,7 +48,8 @@
+ {
+ VERSION="4.0"
+ PATH=".:/bin:/usr/bin:/sbin:/usr/sbin:/usr/ucb:/etc:/usr/bsd"
+- INSTALLDIRDEFAULT="/usr/local/frontpage"
++ AP_TARGET=`PREFIX/sbin/apxs -q TARGET`
++ INSTALLDIRDEFAULT="PREFIX/frontpage"
+
+ case "`echo 'x\c'`" in
+ 'x\c') echo="echo -n" nnl= ;; #BSD
+@@ -129,7 +130,7 @@
+ checkuser()
+ {
+ #
+- # Make sure we are not running as root.
++ # Make sure we are running as root.
+ #
+
+ whoami=`whoami 2>/dev/null` || whoami=`/usr/bin/id | sed -e ' s/).*//; s/^.*(//;'`
+@@ -322,27 +323,27 @@
+
+ retval=0
+
+- echo
+- echo "Where would you like to install the FrontPage Extensions. If you"
+- echo "select a location other than /usr/local/frontpage/ then a symbolic"
+- echo "link will be created from /usr/local/frontpage/ to the location that"
+- echo "is chosen."
+- echo
+- $echo "FrontPage Extensions directory [/usr/local/frontpage/]: ${nnl}"
+- read installdir
++# echo
++# echo "Where would you like to install the FrontPage Extensions. If you"
++# echo "select a location other than /usr/local/frontpage/ then a symbolic"
++# echo "link will be created from /usr/local/frontpage/ to the location that"
++# echo "is chosen."
++# echo
++# $echo "FrontPage Extensions directory [${INSTALLDIRDEFAULT}]: ${nnl}"
++# read installdir
+
+- if [ "$installdir" = "" ]
+- then
++# if [ "$installdir" = "" ]
++# then
+ installdir=$INSTALLDIRDEFAULT
+- fi
++# fi
+ installdir=`dirname $installdir`/`basename $installdir`
+
+- if [ ! -d "$installdir" ]
+- then
+- echo "Creating $installdir"
+- if mkdir "$installdir"
+- then
+- echo "Directory $installdir has been created."
++# if [ ! -d "$installdir" ]
++# then
++# echo "Creating $installdir"
++# if mkdir "$installdir"
++# then
++# echo "Directory $installdir has been created."
+ if chmod "$prot" "$installdir"
+ then
+ echo "Directory $installdir chmoded to $prot."
+@@ -350,22 +351,22 @@
+ echo "ERROR: Unable to chmod $installdir to $prot."
+ retval=1
+ fi
+- else
+- echo "ERROR: Unable to create $installdir!"
+- retval=1
+- fi
+- else
+- echo "WARNING: Directory $installdir already exists."
+- echo "Installation will overwrite existing files."
+- echo
+-
+- myprompt 'yYnN' "Continue the installation (y/n)" "N"
+- echo
+- if [ $answer = n ] || [ $answer = N ]
+- then
+- exit 0
+- fi
+- fi
++# else
++# echo "ERROR: Unable to create $installdir!"
++# retval=1
++# fi
++# else
++# echo "WARNING: Directory $installdir already exists."
++# echo "Installation will overwrite existing files."
++# echo
++
++# myprompt 'yYnN' "Continue the installation (y/n)" "N"
++# echo
++# if [ $answer = n ] || [ $answer = N ]
++# then
++# exit 0
++# fi
++# fi
+
+ if [ "$installdir" != "/usr/local/frontpage" ]
+ then
+@@ -415,7 +416,7 @@
+ vtfile="fp40.$machine.tar"
+ echo "Platform is $machine."
+
+- vtfilelocation="`pwd`/"
++ vtfilelocation="/usr/ports/distfiles/"
+
+ getextfilename $vtfilelocation $vtfile || return 1
+
+@@ -539,7 +540,7 @@
+ upgrade="no"
+ echo "For details on how to upgrade servers manually, please see"
+ echo "the Server Extension Resource Kit (SERK), located in"
+- echo "/usr/local/frontpage/version${VERSION}/serk"
++ echo "MOD_FPDOCDIR/serk"
+ echo
+ return $retval
+ else
+@@ -656,10 +657,15 @@
+ *pache*) getHttpDirective $configfile AccessConfig $port
+ if [ "$param" != "" ]
+ then
+- file=`basename $param`
+- accessconffile="${configfiledir}${file}"
++ if [ "${param}" = "/dev/null" ]
++ then
++ accessconffile="${configfile}"
++ else
++ file=`basename $param`
++ accessconffile="${configfiledir}${file}"
++ fi
+ else
+- accessconffile="${configfiledir}access.conf"
++ accessconffile="${configfiledir}conf/access.conf"
+ fi
+
+ if [ ! -f "$accessconffile" ]
+@@ -1106,18 +1112,29 @@
+
+ webname="/"
+
++ defconfigfile="PREFIX/etc/apache/${AP_TARGET}.conf"
++
+ configfile=""
+ while ( [ "$configfile" = "" ] || [ ! -f $configfile ] )
+ do
+- $echo "Server config filename: ${nnl}"
++ $echo "Server config filename: [$defconfigfile] ${nnl}"
+ read configfile
+- done
++ if [ "$configfile" = "" ]
++ then
++ configfile=$defconfigfile
++ fi
++done
+
++ defadmin="fpadmin"
+ admin=""
+ until [ "$admin" != "" ]
+ do
+- $echo "FrontPage Administrator's user name: ${nnl}"
++ $echo "FrontPage Administrator's user name: [$defadmin] ${nnl}"
+ read admin
++ if [ "$admin" = "" ]
++ then
++ admin=$defadmin
++ fi
+ done
+
+ getparam Port $configfile
+@@ -1132,6 +1149,39 @@
+ getparam User $configfile
+ defwebowner=$param
+
++ if [ "$defwebowner" = "" ]
++ then
++ getHttpDirective $configfile ResourceConfig $port
++ if [ "$param" != "" ]
++ then
++ if [ "${param}" = "/dev/null" ]
++ then
++ resconffile="${configfile}"
++ else
++ file=`basename $param`
++ resconffile="${configfiledir}${file}"
++ fi
++ else
++ resconffile="${configfiledir}srm.conf"
++ fi
++
++ if [ ! -f "$resconffile" ]
++ then
++ echo "ERROR: $resconffile does not exist!"
++ return 1
++ fi
++
++ getparam DocumentRoot $resconffile
++ docroot=$param
++ if [ ! -d "$docroot" ]
++ then
++ echo "ERROR: $docroot does not exist!"
++ return 1
++ fi
++
++ defwebowner=`$lsg ${docroot}${service} | $awk ' { print $3}'`
++ fi
++
+ weconfigfile="${installdir}/we${port}.cnf"
+
+ webowner=""
+@@ -1147,6 +1197,12 @@
+
+ getparam Group $configfile
+ defgroup=$param
++
++ if [ "$defgroup" = "" ]
++ then
++ defgroup=`$lsg ${docroot}${service} | $awk ' { print $4}'`
++ fi
++
+ webgroup=""
+ until [ "$webgroup" != "" ]
+ do
+@@ -1158,6 +1214,8 @@
+ webgroup=$defgroup
+ fi
+ done
++
++defservertypenum="3"
+
+ until [ "$servertype" != "" ]
+ do
+@@ -1168,9 +1226,13 @@
+ echo " 4. netscape-fasttrack"
+ echo " 5. netscape-enterprise"
+ echo " 6. stronghold"
+- $echo "What type of Server is this: ${nnl}"
++ $echo "What type of Server is this: [$defservertypenum] ${nnl}"
+ read servertypenum
+ echo
++ if [ "$servertypenum" = "" ]
++ then
++ servertypenum=$defservertypenum
++ fi
+
+ case $servertypenum in
+ "1") servertype="ncsa" ;;
+@@ -1546,6 +1608,8 @@
+ read admin
+ done
+
++ defservertypenum="3"
++
+ until [ "$servertype" != "" ]
+ do
+ echo
+@@ -1555,9 +1619,13 @@
+ echo " 4. netscape-fasttrack"
+ echo " 5. netscape-enterprise"
+ echo " 6. stronghold"
+- $echo "What type of Server is this: ${nnl}"
++ $echo "What type of Server is this: [$defservertypenum] ${nnl}"
+ read servertypenum
+ echo
++ if [ "$servertypenum" = "" ]
++ then
++ servertypenum=$defservertypenum
++ fi
+
+ case $servertypenum in
+ "1") servertype="ncsa" ;;
+@@ -2024,7 +2092,6 @@
+ then
+ getHttpRootDirective $configfile $directive
+ fi
+-
+ }
+
+ getnetscapedocroot()
+@@ -2217,7 +2284,7 @@
+
+ initialize
+ step1
+-step2
++#step2
+ step3
+ #
+ # Run the external permissions script.
diff --git a/www/mod_frontpage/files/patch-fn b/www/mod_frontpage/files/patch-fn
new file mode 100644
index 000000000000..ed2572945fbf
--- /dev/null
+++ b/www/mod_frontpage/files/patch-fn
@@ -0,0 +1,15 @@
+--- frontpage/version4.0/set_default_perms.sh.orig Mon May 24 12:45:14 1999
++++ frontpage/version4.0/set_default_perms.sh Thu Feb 24 01:47:01 2000
+@@ -81,10 +81,10 @@
+ chmod 4755 $FPDIR/apache-fp/_vti_bin/fpexe || die set fpexe to be suid
+
+ # Set httpd
+-chmod 555 $FPDIR/apache-fp/httpd || die make httpd executable
++#chmod 555 $FPDIR/apache-fp/httpd || die make httpd executable
+
+ # Set httpd.Compat
+-chmod 555 $FPDIR/apache-fp/httpd.Compat || die make httpd.Compat executable
++#chmod 555 $FPDIR/apache-fp/httpd.Compat || die make httpd.Compat executable
+
+ # The apache-fp directory should not be writable to protect the stub program.
+ chmod 555 $FPDIR/apache-fp/_vti_bin || die restrict the apache-fp directory
diff --git a/www/mod_frontpage/pkg-comment b/www/mod_frontpage/pkg-comment
new file mode 100644
index 000000000000..41308f273f21
--- /dev/null
+++ b/www/mod_frontpage/pkg-comment
@@ -0,0 +1 @@
+Improved mod_frontpage for Apache, as APXS installation
diff --git a/www/mod_frontpage/pkg-descr b/www/mod_frontpage/pkg-descr
new file mode 100644
index 000000000000..8de4c6954e02
--- /dev/null
+++ b/www/mod_frontpage/pkg-descr
@@ -0,0 +1,14 @@
+This is a module for the Apache HTTP Server <http://www.apache.org/httpd.html>.
+It replaces the Apache-FP patches and module supplied with the FrontPage Server
+Extensions.
+
+Using this module allows you to use advanced features of the FrontPage client
+with your Apache HTTP Server (e.g. creating FrontPage-extended subwebs using the
+FrontPage client in contrast to creating them as user "root" with "fpinstall.sh"
+or the "fpsrvadm.exe"-utility on the system's shell).
+
+WWW: http://home.edo.uni-dortmund.de/~chripo
+FTP: ftp://ftp.edo.uni-dortmund.de/pub/mod_frontpage
+
+Copyright (C) 2001 Christof Pohl <chripo+frontpage@edo.uni-dortmund.de>
+APXS install by Jean-Michel Dault <jmdault@mandrakesoft.com
diff --git a/www/mod_frontpage/pkg-install b/www/mod_frontpage/pkg-install
new file mode 100644
index 000000000000..3b43c6a10f36
--- /dev/null
+++ b/www/mod_frontpage/pkg-install
@@ -0,0 +1,39 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/www/mod_frontpage/Attic/pkg-install,v 1.1 2001-08-31 11:42:15 jedgar Exp $
+#
+# Created by: hetzels@westbend.net, Modified by mb@imp.ch
+
+PKG_BATCH=${BATCH:=NO}
+PKG_PREFIX=${PKG_PREFIX}
+HOST_NAME=`/bin/hostname`
+
+AP_SHARE=${PKG_PREFIX}/share/doc/apache
+
+FPINSTALL=${PKG_PREFIX}/frontpage/version4.0/fp_install.sh
+CHANGESERVER=${PKG_PREFIX}/frontpage/version4.0/change_server.sh
+FPDOCDIR=${AP_SHARE}/manual/mod/mod_frontpage
+
+fix_frontpage_scripts ()
+{
+ /bin/cat ${FPINSTALL}-dist | \
+ /usr/bin/sed -e 's;PREFIX;'${PKG_PREFIX}';' \
+ -e 's;MOD_FPDOCDIR;'${FPDOCDIR}';' \
+ > ${FPINSTALL}
+ /bin/cat ${CHANGESERVER}-dist | \
+ /usr/bin/sed -e 's;PREFIX;'${PKG_PREFIX}';' \
+ > ${CHANGESERVER}
+ /bin/chmod 555 ${CHANGESERVER} ${FPINSTALL}
+ /usr/sbin/chown bin ${CHANGESERVER} ${FPINSTALL}
+}
+
+case $2 in
+ POST-INSTALL)
+ # If we are not in batch mode then run the FP install script.
+ if [ "${PKG_BATCH}" = "NO" ]; then
+ fix_frontpage_scripts
+ ${FPINSTALL}
+ fi
+ ;;
+
+esac
diff --git a/www/mod_frontpage/pkg-message b/www/mod_frontpage/pkg-message
new file mode 100644
index 000000000000..7655a6e228c9
--- /dev/null
+++ b/www/mod_frontpage/pkg-message
@@ -0,0 +1,12 @@
+************************************************************************
+
+The BSDI FrontPage Extentions require that libcrypt.* be linked to the
+libdescrypt.* libraries. The fpsrvadm.exe program can only create DES
+passwords, but the Apache server is unable to use them when libcrypt.*
+are linked to the libscrypt.* libraries.
+
+A new apache.sh.sample has been installed. Please replace your own
+apache.sh with this script. The frontpage suid key generation is
+needed by mod_frontpage. Without it it doesn't work.
+
+************************************************************************
diff --git a/www/mod_frontpage/pkg-plist b/www/mod_frontpage/pkg-plist
new file mode 100644
index 000000000000..560ba0cdacf4
--- /dev/null
+++ b/www/mod_frontpage/pkg-plist
@@ -0,0 +1,192 @@
+sbin/fpexec
+libexec/apache/mod_frontpage.so
+frontpage/%%FP_REV%%/LICENSE.TXT
+frontpage/%%FP_REV%%/change_server.sh-dist
+@unexec rm -f %B/change_server.sh
+@unexec rm -f %B/change_server_results.txt
+frontpage/%%FP_REV%%/fp_install.sh-dist
+@unexec rm -f %B/fp_install.sh
+frontpage/%%FP_REV%%/frontpage.cnf
+@unexec if [ -f %B/%f.orig ] ; then rm -f %B/%f.orig ; fi
+frontpage/%%FP_REV%%/set_default_perms.sh
+frontpage/%%FP_REV%%/readme.htm
+@unexec if [ -f %B/upgrade_results.txt ] ; then rm -f %B/upgrade_results.txt ; fi
+frontpage/%%FP_REV%%/_vti_bin/_vti_adm/admin.exe
+frontpage/%%FP_REV%%/_vti_bin/_vti_aut/author.exe
+frontpage/%%FP_REV%%/_vti_bin/fpcount.exe
+frontpage/%%FP_REV%%/_vti_bin/shtml.exe
+frontpage/%%FP_REV%%/admin/check.htm
+frontpage/%%FP_REV%%/admin/contents.htm
+frontpage/%%FP_REV%%/admin/delsbweb.htm
+frontpage/%%FP_REV%%/admin/direxe.htm
+frontpage/%%FP_REV%%/admin/dirnoexe.htm
+frontpage/%%FP_REV%%/admin/disable.htm
+frontpage/%%FP_REV%%/admin/enable.htm
+frontpage/%%FP_REV%%/admin/footer.htm
+frontpage/%%FP_REV%%/admin/fpadmin.htm
+frontpage/%%FP_REV%%/admin/fpbanner.htm
+frontpage/%%FP_REV%%/admin/fpcreate.gif
+frontpage/%%FP_REV%%/admin/ipaddr.htm
+frontpage/%%FP_REV%%/admin/newsbweb.htm
+frontpage/%%FP_REV%%/admin/newsrvr.htm
+frontpage/%%FP_REV%%/admin/perms.htm
+frontpage/%%FP_REV%%/admin/recalc.htm
+frontpage/%%FP_REV%%/admin/rensbweb.htm
+frontpage/%%FP_REV%%/admin/scripts/fpadmcgi.exe
+frontpage/%%FP_REV%%/admin/topleft.gif
+frontpage/%%FP_REV%%/admin/topright.gif
+frontpage/%%FP_REV%%/admin/uninstal.htm
+frontpage/%%FP_REV%%/apache-fp/_vti_bin/fpexe
+frontpage/%%FP_REV%%/apache-fp/fp-patch-apache_1.3.12
+frontpage/%%FP_REV%%/apache-fp/fpexe.c
+@unexec if [ -f %B/suidkey ] ; then rm -f %B/suidkey* ; fi
+frontpage/%%FP_REV%%/bin/_vti_inf.htm
+frontpage/%%FP_REV%%/bin/fpsrvadm.exe
+frontpage/%%FP_REV%%/bin/postinfo.htm
+frontpage/%%FP_REV%%/exes/_vti_bin/_vti_adm/admin.exe
+frontpage/%%FP_REV%%/exes/_vti_bin/_vti_aut/author.exe
+frontpage/%%FP_REV%%/exes/_vti_bin/fpcount.exe
+frontpage/%%FP_REV%%/exes/_vti_bin/shtml.exe
+frontpage/%%FP_REV%%/nls/cp_1250.nls
+frontpage/%%FP_REV%%/nls/cp_1251.nls
+frontpage/%%FP_REV%%/nls/cp_1252.nls
+frontpage/%%FP_REV%%/nls/cp_1253.nls
+frontpage/%%FP_REV%%/nls/cp_1254.nls
+frontpage/%%FP_REV%%/nls/cp_1255.nls
+frontpage/%%FP_REV%%/nls/cp_1256.nls
+frontpage/%%FP_REV%%/nls/cp_1257.nls
+frontpage/%%FP_REV%%/nls/cp_1258.nls
+frontpage/%%FP_REV%%/nls/cp_28592.nls
+frontpage/%%FP_REV%%/nls/cp_28605.nls
+frontpage/%%FP_REV%%/nls/cp_437.nls
+frontpage/%%FP_REV%%/nls/cp_850.nls
+frontpage/%%FP_REV%%/nls/cp_874.nls
+frontpage/%%FP_REV%%/nls/cp_932.nls
+frontpage/%%FP_REV%%/nls/cp_936.nls
+frontpage/%%FP_REV%%/nls/cp_949.nls
+frontpage/%%FP_REV%%/nls/cp_950.nls
+frontpage/%%FP_REV%%/serk/001.gif
+frontpage/%%FP_REV%%/serk/1ptrans.gif
+frontpage/%%FP_REV%%/serk/SERK.css
+frontpage/%%FP_REV%%/serk/adadv.htm
+frontpage/%%FP_REV%%/serk/adadv_1.htm
+frontpage/%%FP_REV%%/serk/adadv_2.htm
+frontpage/%%FP_REV%%/serk/adadv_3.htm
+frontpage/%%FP_REV%%/serk/adadv_4.htm
+frontpage/%%FP_REV%%/serk/adadv_5.htm
+frontpage/%%FP_REV%%/serk/adadv_6.htm
+frontpage/%%FP_REV%%/serk/adadv_7.htm
+frontpage/%%FP_REV%%/serk/adadv_8.htm
+frontpage/%%FP_REV%%/serk/adadv_9.htm
+frontpage/%%FP_REV%%/serk/adfpre.htm
+frontpage/%%FP_REV%%/serk/adfpre01.gif
+frontpage/%%FP_REV%%/serk/adfpre02.gif
+frontpage/%%FP_REV%%/serk/adfpre_1.htm
+frontpage/%%FP_REV%%/serk/adfpre_2.htm
+frontpage/%%FP_REV%%/serk/adfpre_3.htm
+frontpage/%%FP_REV%%/serk/adfpre_4.htm
+frontpage/%%FP_REV%%/serk/adfpre_5.htm
+frontpage/%%FP_REV%%/serk/adfpre_6.htm
+frontpage/%%FP_REV%%/serk/adfpre_7.htm
+frontpage/%%FP_REV%%/serk/adfpsr.htm
+frontpage/%%FP_REV%%/serk/adfpsr_1.htm
+frontpage/%%FP_REV%%/serk/adfpsr_2.htm
+frontpage/%%FP_REV%%/serk/adfpsr_3.htm
+frontpage/%%FP_REV%%/serk/adhtm.htm
+frontpage/%%FP_REV%%/serk/adhtm_1.htm
+frontpage/%%FP_REV%%/serk/adhtm_2.htm
+frontpage/%%FP_REV%%/serk/admart.gif
+frontpage/%%FP_REV%%/serk/admmc.htm
+frontpage/%%FP_REV%%/serk/admmc_1.htm
+frontpage/%%FP_REV%%/serk/admmc_2.htm
+frontpage/%%FP_REV%%/serk/admmc_3.htm
+frontpage/%%FP_REV%%/serk/admmc_4.htm
+frontpage/%%FP_REV%%/serk/admmc_5.htm
+frontpage/%%FP_REV%%/serk/admmc_6.htm
+frontpage/%%FP_REV%%/serk/adoview.htm
+frontpage/%%FP_REV%%/serk/apndx00.htm
+frontpage/%%FP_REV%%/serk/apndx01.htm
+frontpage/%%FP_REV%%/serk/apndx02.htm
+frontpage/%%FP_REV%%/serk/apndx03.htm
+frontpage/%%FP_REV%%/serk/apndx04.htm
+frontpage/%%FP_REV%%/serk/apndx05.htm
+frontpage/%%FP_REV%%/serk/apndxtoc.htm
+frontpage/%%FP_REV%%/serk/axrpc.htm
+frontpage/%%FP_REV%%/serk/back.gif
+frontpage/%%FP_REV%%/serk/bullet.gif
+frontpage/%%FP_REV%%/serk/cnrat_1.gif
+frontpage/%%FP_REV%%/serk/cnrat_2.gif
+frontpage/%%FP_REV%%/serk/cpyright.htm
+frontpage/%%FP_REV%%/serk/default.htm
+frontpage/%%FP_REV%%/serk/dwnarrow.gif
+frontpage/%%FP_REV%%/serk/home.gif
+frontpage/%%FP_REV%%/serk/incompat.htm
+frontpage/%%FP_REV%%/serk/inintro.htm
+frontpage/%%FP_REV%%/serk/inunix.htm
+frontpage/%%FP_REV%%/serk/inwindow.htm
+frontpage/%%FP_REV%%/serk/msft.gif
+frontpage/%%FP_REV%%/serk/next.gif
+frontpage/%%FP_REV%%/serk/noterule.gif
+frontpage/%%FP_REV%%/serk/ovarchit.htm
+frontpage/%%FP_REV%%/serk/ovart.gif
+frontpage/%%FP_REV%%/serk/ovfeat01.gif
+frontpage/%%FP_REV%%/serk/ovfeat02.gif
+frontpage/%%FP_REV%%/serk/ovfeat03.gif
+frontpage/%%FP_REV%%/serk/ovfeatur.htm
+frontpage/%%FP_REV%%/serk/ovpublis.htm
+frontpage/%%FP_REV%%/serk/ovscenar.htm
+frontpage/%%FP_REV%%/serk/ovwhatar.htm
+frontpage/%%FP_REV%%/serk/ovwhatis.htm
+frontpage/%%FP_REV%%/serk/previous.gif
+frontpage/%%FP_REV%%/serk/r_ydot.gif
+frontpage/%%FP_REV%%/serk/scintro.htm
+frontpage/%%FP_REV%%/serk/scuni.htm
+frontpage/%%FP_REV%%/serk/scuni_1.htm
+frontpage/%%FP_REV%%/serk/scuni_10.htm
+frontpage/%%FP_REV%%/serk/scuni_2.htm
+frontpage/%%FP_REV%%/serk/scuni_3.htm
+frontpage/%%FP_REV%%/serk/scuni_4.htm
+frontpage/%%FP_REV%%/serk/scuni_5.htm
+frontpage/%%FP_REV%%/serk/scuni_6.htm
+frontpage/%%FP_REV%%/serk/scuni_7.htm
+frontpage/%%FP_REV%%/serk/scuni_8.htm
+frontpage/%%FP_REV%%/serk/scuni_9.htm
+frontpage/%%FP_REV%%/serk/scunix01.gif
+frontpage/%%FP_REV%%/serk/scwin.htm
+frontpage/%%FP_REV%%/serk/scwin_1.htm
+frontpage/%%FP_REV%%/serk/scwin_2.htm
+frontpage/%%FP_REV%%/serk/scwin_3.htm
+frontpage/%%FP_REV%%/serk/scwin_4.htm
+frontpage/%%FP_REV%%/serk/scwin_5.htm
+frontpage/%%FP_REV%%/serk/scwin_6.htm
+frontpage/%%FP_REV%%/serk/scwin_7.htm
+frontpage/%%FP_REV%%/serk/scwin_8.htm
+frontpage/%%FP_REV%%/serk/scwin_9.htm
+frontpage/%%FP_REV%%/serk/secart.gif
+frontpage/%%FP_REV%%/serk/serkindx.htm
+frontpage/%%FP_REV%%/serk/serktop.gif
+frontpage/%%FP_REV%%/serk/serktop.htm
+frontpage/%%FP_REV%%/serk/serkxtra.gif
+frontpage/%%FP_REV%%/serk/serkxtra.htm
+frontpage/%%FP_REV%%/serk/setart.gif
+frontpage/%%FP_REV%%/serk/splash.gif
+frontpage/%%FP_REV%%/serk/termofus.gif
+frontpage/%%FP_REV%%/serk/top.gif
+frontpage/%%FP_REV%%/srcs/fp.suid.c
+@dirrm frontpage/%%FP_REV%%/_vti_bin/_vti_adm
+@dirrm frontpage/%%FP_REV%%/_vti_bin/_vti_aut
+@dirrm frontpage/%%FP_REV%%/_vti_bin
+@dirrm frontpage/%%FP_REV%%/admin/scripts
+@dirrm frontpage/%%FP_REV%%/admin
+@dirrm frontpage/%%FP_REV%%/apache-fp/_vti_bin
+@dirrm frontpage/%%FP_REV%%/apache-fp
+@dirrm frontpage/%%FP_REV%%/bin
+@dirrm frontpage/%%FP_REV%%/exes/_vti_bin/_vti_adm
+@dirrm frontpage/%%FP_REV%%/exes/_vti_bin/_vti_aut
+@dirrm frontpage/%%FP_REV%%/exes/_vti_bin
+@dirrm frontpage/%%FP_REV%%/exes
+@dirrm frontpage/%%FP_REV%%/nls
+@dirrm frontpage/%%FP_REV%%/serk
+@dirrm frontpage/%%FP_REV%%/srcs
+@dirrm frontpage/%%FP_REV%%
+@dirrm frontpage