aboutsummaryrefslogtreecommitdiff
path: root/www/mod_php4
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2003-02-05 14:13:21 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2003-02-05 14:13:21 +0000
commit4aa80a5750d09dfd5ff132394c524eebf723b5a9 (patch)
treefb3daebc10a418d166519ee2e286bcfd87511b50 /www/mod_php4
parent6583f9b5573eca87bc2fc18a9868bd23d0303b00 (diff)
downloadports-4aa80a5750d09dfd5ff132394c524eebf723b5a9.tar.gz
ports-4aa80a5750d09dfd5ff132394c524eebf723b5a9.zip
Notes
Diffstat (limited to 'www/mod_php4')
-rw-r--r--www/mod_php4/Makefile8
-rw-r--r--www/mod_php4/scripts/configure.php5
2 files changed, 13 insertions, 0 deletions
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index 22cdf24d695d..b767a45d23d6 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -99,4 +99,12 @@ post-clean:
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
+# XXX:
+# Has to be kept in sync with the defaults in configure.php
+.ifndef(WITHOUT_MYSQL)
+.ifmake describe
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+.endif
+.endif
+
.include <bsd.port.mk>
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index 2230696ea58d..6729ade0210e 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -166,6 +166,7 @@ while [ "$1" ]; do
\"MySQL\")
echo "LIB_DEPENDS+= mysqlclient.10:\${PORTSDIR}/databases/mysql323-client"
echo "CONFIGURE_ARGS+=--with-mysql=\${LOCALBASE}"
+ MYSQL=1
;;
\"PostgreSQL\")
echo "POSTGRESQL_PORT?= databases/postgresql7"
@@ -363,3 +364,7 @@ done
if [ "${LIBS}" ]; then
echo "CONFIGURE_ENV+= LIBS='${LIBS}'"
fi
+
+if [ -z "${MYSQL}" ]; then
+ echo "WITHOUT_MYSQL= 1"
+fi